[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#275628: #275628 success, at last

This report can be closed!

The installer now supports this hardware. The only trick to installation
is to power cycle immediately before booting off the cdrom.
Full report below.

Package: installation-reports


Debian-installer-version: netinst 20041015, from

uname -a: Linux grus1 2.4.27-1-sparc64 #1 Mon Aug 23 23:59:55 PDT 2004 sparc64 GNU/Linux

Date: 2004-11-06
  How did you install?  from netinst cd
  What did you boot off? netinst cd,
  If network install, from where?

Machine: Sun Ultra 10, OpenBoot 3.11

Processor: Ultra Sparc IIi 300 MHz

Memory: Socket 1: 128
        Socket 2: 128
	Socket 3: 64
	Socket 4: 64
        total - 384Mb

Root Device: /dev/hda (IDE disk)

Root Size/partition table:

Initially had a sun partition table, which I blew away.

Disk /dev/hda (Sun disk label): 15 heads, 63 sectors, 8894 cylinders
Units = cylinders of 945 * 512 bytes

   Device Flag    Start       End    Blocks   Id  System
   /dev/hda1             0       207     97807+   1  Boot
   /dev/hda2           207       635    202230   83  Linux native
   /dev/hda3             0      8894   4202415    5  Whole disk
   /dev/hda4           635      3810   1500187+  83  Linux native
   /dev/hda5          3810      5168    641655   83  Linux native
   /dev/hda6          5168      6755    749857+  82  Linux swap
   /dev/hda7          6755      7284    249952+  83  Linux native
   /dev/hda8          7284      8894    760725   83  Linux native

Output of lspci and lspci -n:
0000:00:00.0 0600: 108e:a000
0000:00:00.0 Host bridge: Sun Microsystems Computer Corp. Ultra IIi
0000:00:01.0 0604: 108e:5000 (rev 11)
0000:00:01.0 PCI bridge: Sun Microsystems Computer Corp. Simba Advanced PCI Brid
ge (rev 11)
0000:00:01.1 0604: 108e:5000 (rev 11)
0000:00:01.1 PCI bridge: Sun Microsystems Computer Corp. Simba Advanced PCI Brid
ge (rev 11)
0000:01:01.0 0680: 108e:1000 (rev 01)
0000:01:01.0 Bridge: Sun Microsystems Computer Corp. EBUS (rev 01)
0000:01:01.1 0200: 108e:1001 (rev 01)
0000:01:01.1 Ethernet controller: Sun Microsystems Computer Corp. Happy Meal (re
v 01)
0000:01:02.0 0300: 1002:4754 (rev 9a)
0000:01:02.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT
[Mach64 GT] (rev 9a)
0000:01:03.0 0101: 1095:0646 (rev 03)
0000:01:03.0 IDE interface: Silicon Image, Inc. (formerly CMD Technology Inc) PC
I0646 (rev 03)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]  see discussion
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


The system was running Solaris (2.6) before installation.
Shut system down with
  # halt

In OpenBoot,
  ok  boot cdrom
at SILO prompt
  boot: <return>

  the boot started ok, then failed with:
  kernel panic: VFS: Unable to mount root fs on 00:00
   Press L1-A to return to the boot prom

so I pressed the magic combo and got back to the boot prom.
  ok boot cdrom
at SILO prompt
  boot: <return>

  failed in the same way

Inserted joshk disk (20041015), same failure.

Power down.
Power up.
  <L1>-A during "Initializing memory"

  ok boot cdrom                   (joshk disk still)
  Initializing Memory \
  SILO 1.4.8
  boot: <ret>

  NOW it works.

Power down.
Power up.
Load d-i netinst 20041015.
  <L1>-A during "Initializing memory"

  ok boot cdrom
  SILO 1.4.8
  boot: <ret>

Installation proceeded as normal from this point.
Moral of the story: power cycle before trying to install sparcs.

During partitioning I tried auto-partitioning. This made [swap] and /tmp
a bit small for my liking (236M, not 2x memory, 768M) but otherwise did ok.

Nice work team!

Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.

Reply to: