[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#274621: Success, but packages progress bar stall and no domain name problems

Package: installation-reports

Debian-installer-version: pre-rc2
	Sat Oct  2 22:35:58 EDT 2004
uname -a: N/A
Date: Sat Oct  2 22:35:58 EDT 2004
Method: netinst, linux26.  ftp-mirror.internap.com

Machine: Custom
Processor: AMD Athlon(tm) MP 2400+ (single)
Memory: 512MB
Root Device: IDE /dev/hda
Root Size/partition table:
	/dev/hda2 -> /		6GB
Output of lspci and lspci -n:
0000:00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] System Controller (rev 20)
0000:00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-760 MP [IGD4-2P] AGP Bridge
0000:00:07.0 ISA bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ISA (rev 05)
0000:00:07.1 IDE interface: Advanced Micro Devices [AMD] AMD-768 [Opus] IDE (rev 04)
0000:00:07.3 Bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] ACPI (rev 03)
0000:00:10.0 PCI bridge: Advanced Micro Devices [AMD] AMD-768 [Opus] PCI (rev 05)
0000:02:00.0 USB Controller: Advanced Micro Devices [AMD] AMD-768 [Opus] USB (rev 07)
0000:02:04.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:02:05.0 VGA compatible controller: Silicon Integrated Systems [SiS] 300/305 PCI/AGP VGA Display Adapter (rev 80)
0000:02:06.0 Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
0000:02:08.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 78)
0000:00:00.0 0600: 1022:700c (rev 20)
0000:00:01.0 0604: 1022:700d
0000:00:07.0 0601: 1022:7440 (rev 05)
0000:00:07.1 0101: 1022:7441 (rev 04)
0000:00:07.3 0680: 1022:7443 (rev 03)
0000:00:10.0 0604: 1022:7448 (rev 05)
0000:02:00.0 0c03: 1022:7449 (rev 07)
0000:02:04.0 0200: 10ec:8139 (rev 10)
0000:02:05.0 0300: 1039:0300 (rev 80)
0000:02:06.0 0401: 13f6:0111 (rev 10)
0000:02:08.0 0200: 10b7:9200 (rev 78)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [O]
Reboot:                 [O]


Issue #1:

During installation of the base packages, the progress bar sits at 61%
for at least 3-4 minutes.  This is after "Unpacking" and "Configuring"
are displayed at the bottom of the dialog and just after "Installing"
is displayed.  However, looking at tty3 there doesn't appear to be any
change between these stages.  There are various
unpacking/configuring/setting up messages from apt even during the
"Installing" stage.

Despite the fact that the progress bar was stalled, the apt messages
appeared normal with no errors or particularly slow installations, and
continued to scroll by while the progress bar remained the same.

The same problem was present in the last daily I tried as well (before
rc1).  I think this is a serious problem.  I for one rebooted twice
when this happened thinking that it must be a bad read from the CD at
the same place, and that the entire install had hung as a result.

Issue #2:

This is unrelated to the first, despite sharing a similar symptom.
When prompted for a hostname, I stayed with the default of "debian".
When prompted for a domain name, I removed the default entry because
it was not appropriate and left the field blank.  As a result:

During initial install:
	"Setting up exim4-config"
	[about 10 second delay]
	hostname: Unknown hostname

	"Setting up exim4-daemon-light"
	Starting MTA:
	[60 second delay]

During first reboot:
	Starting MTA:
	[60 second delay]

During base-config:
	Selected Local delivery only; not on a network
	Reloading exim4 configuration files
	[60 second delay]

This is a bad user experience, especially since it happens on every
boot and every time the MTA is reconfigured (which happens too often
in Debian, but that is another issue).  Possible solutions:

1. Have Exim respect the /etc/hosts entry ("debian" in this case)
   and make sure it's there before Exim is installed
2. Set the timeout to a much lower value, e.g. 10 seconds


Reply to: