[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#220131: marked as done (grub-installer: should note a probably long progress)

Your message dated Sat, 2 Oct 2004 11:42:19 -0400
with message-id <20041002154219.GA18831@kitenet.net>
and subject line closing
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 7 Nov 2003 16:41:00 +0000
>From mquinson@ens-lyon.fr Fri Nov 07 10:40:59 2003
Return-path: <mquinson@ens-lyon.fr>
Received: from (galadriel) [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AI9fP-00015S-00; Fri, 07 Nov 2003 10:40:59 -0600
Received: from mquinson by galadriel with local (Exim 3.36 #1 (Debian))
	id 1AI9fK-0000qZ-00; Fri, 07 Nov 2003 17:40:54 +0100
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 7bit
From: Martin Quinson <Martin.Quinson@tuxfamily.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: installation-reports: 4 Nov 2003: reiserfs really hard to get;
 maybe grub issue; interface glitch
X-Mailer: reportbug 2.36
Date: Fri, 07 Nov 2003 17:40:54 +0100
Message-Id: <E1AI9fK-0000qZ-00@galadriel>
Sender: Martin Quinson <mquinson@ens-lyon.fr>
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_11_7 (

Package: installation-reports
Version: http://gluck.debian.org/cdimage/testing/netinst/i386/sarge-i386-netinst.iso, 5 nov 2003
Severity: normal

Debian-installer-version: http://gluck.debian.org/cdimage/testing/netinst/i386/sarge-i386-netinst.iso, 5 nov 2003
uname -a: Linux galadriel 2.4.22 #1 Wed Nov 5 20:17:29 UTC 2003 i686 GNU/Linux
Date: 5->6 november

Machine: Dell laptop inspiron 8100
Processor: Intel(R) Pentium(R) III Mobile CPU      1200MHz
Memory: 512Mo
Root Device: IDE /dev/hda
Root Size/partition table:
 Name FS Type           Size (MB)   Mount point
 hda1 W95 FAT32 (LBA)     3002.23
 hda2 Linux ReiserFS      3997.49   /
 hda3 Linux swap           600.45
 hda5 Linux ReiserFS     15002.92   /home
 hda6 Linux ReiserFS     25399.67   /pub

Output of lspci:
 00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory
 Controller Hub (rev 04)
 00:01.0 PCI bridge: Intel Corp. 82815 815 Chipset AGP Bridge (rev 04)
 00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 03)
 00:1f.0 ISA bridge: Intel Corp. 82801BAM ISA Bridge (LPC) (rev 03)
 00:1f.1 IDE interface: Intel Corp. 82801BAM IDE U100 (rev 03)
 00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 03)
 01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7
 LW [Radeon Mobility 7500]
 02:03.0 Multimedia audio controller: ESS Technology ES1983S Maestro-3i PCI
 Audio Accelerator (rev 10)
 02:06.0 Ethernet controller: 3Com Corporation 3c556 Hurricane CardBus (rev 10)
 02:06.1 Communication controller: 3Com Corporation Mini PCI 56k Winmodem
 (rev 10)
 02:0f.0 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus Controller
 02:0f.1 CardBus bridge: Texas Instruments PCI4451 PC card Cardbus Controller
 02:0f.2 FireWire (IEEE 1394): Texas Instruments PCI4451 IEEE-1394 Controller

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [E] Complained about the lack of ide module a bit,
                            and then worked. Weird. But I'm not sure I
                            didn't mess something myself.
Partition hard drives:  [O]
Create file systems:    [E] The mkfs.reiserfs ask for confirmation, what is
                             not handled by the installer.
			    I had to create my filesystems myself and ask
                             the installer to not mess them up.
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E] I failed to pass the --no-floppy option to
                             grub-installer, but I'm quite sure I did mess
                             things up.
Reboot:                 [E] I'm quite mad about that point. See below.
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


1/ My biggest problem came from the fact that I wanted to have reiserfs

First, I have to create the fs myself since the installer cannot deal with
the fact that mkfs.reiserfs asks for confirmation before doing its job.

Then, the option errors=remount-ro is not understood by reiserfs. Thus, my
root partition was always mounted ro at boot time, which leaded to problems
preventing the system to startup. 

The error did scroll so fast that I didn't understood the problem until a
very long time.

In the meanwhile, I booted on knoppix to try to fix things. I changed the
installed kernel to a kernel-image-2.4.22-reiserfs, in vain (of course). I
recompiled a kernel in a chroot under knoppix (what a great tool !). Of
course, it was also in vain. And studently, I managed to read fast the error
message before it disappeared, rebooted knoppix, fixed the /etc/fstab and it
worked perfectly...

2/ The problem with grub was most certainly caused by my own stupidity, but
it would be good to provide a way from the interface to set the --no-floppy

Likewise, the message in the interface should also inform the user that the
following step can take some time, avoiding him to press Ctrl-C after a few
seconds like I did. ;)

3/ While downloading the base package and installing them, the display is
not very nice because some lines are wrapped, causing the window to become

Either forcing the window to keep big enough to avoid that, or trimming the
beginning of each string and replacing it with '...' to keep it on only one
line would look nicer. Not a big deal, though.

4/ Various issues with the rare french translations, but I'll repport them
directly to the debian-l10n-french mailing list.

In a word, if you don't insist to have reiserfs, the installer rules ! 

Thanks for your work, Mt.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux galadriel 2.4.22 #1 Wed Nov 5 20:17:29 UTC 2003 i686
Locale: LANG=fr_FR@euro, LC_CTYPE=fr_FR@euro

Received: (at 220131-done) by bugs.debian.org; 2 Oct 2004 15:42:48 +0000
>From joey@kitenet.net Sat Oct 02 08:42:48 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CDm24-0005fs-00; Sat, 02 Oct 2004 08:42:48 -0700
Received: from dragon.kitenet.net (unknown [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id CBF7418568
	for <220131-done@bugs.debian.org>; Sat,  2 Oct 2004 15:41:04 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id 057A36E0D4; Sat,  2 Oct 2004 11:42:19 -0400 (EDT)
Date: Sat, 2 Oct 2004 11:42:19 -0400
From: Joey Hess <joeyh@debian.org>
To: 220131-done@bugs.debian.org
Subject: closing
Message-ID: <20041002154219.GA18831@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="/04w6evG8XlLl3ft"
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040907i
Delivered-To: 220131-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Closing this bug, we set --no-floppy now.

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.5 (GNU/Linux)



Reply to: