[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#270809: broken commandline-editing, base-config.udeb, select modules

Package: installation-reports

Version: Sarge netinst iso 20040908
Title: broken commandline-editing, base-config.udeb, select modules

uname -a: 
date: yesterday
Method: got iso from www.debian.org, verified md5sum, burned it
Machine: i386
Processor: pentium mmx 200MHz
Memory: 196MB
Root Device: IDE 585MB
Root Size/partition table:
  - fat32  45 MB
  - ext2  540 MB
Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [o]
Configure network HW:   [o]
Config network:         [e]
Detect CD:              [o]
Load installer modules: [o]
Detect hard drives:     [o]
Partition hard drives:  [o]
Create file systems:    [e]
Mount partitions:       [e]
Install base system:    [o]
Install boot loader:    [o]
base-config.udeb	[E]
Reboot:                 [ ]


same machine/disk/cd as last time,
  thanks to a tip from Frans Pop on howto clear bios password.

planning an easy install with X on a small disk.

@bootprompt: expert26 (so i can use this disk as rescuedisk for sarge)

i used dutch language for a change,
  'not a good choice' says mr. hindsight,
  because now i can't tell whether text errors are in original or translation.
as region i selected 'belgium' because uptonow i think it is only used for 
installer texts are polite however, and dont use modern spelling,
  so i wonder if there is a separate translation into vlaams (flemish).

at start of install,
  for every 2 steps forward, i do one step back,
  to keep message priority low.
choice for expert mode is not because i'm an expert.

[dutch] typo in "automatische herkenning cd..." :
  comma needed after ", of problemen veroorzaken"

i notice message that some modules are not available (yet?)
  tells what these modules are used for. was that already so before ?
it is a nice feature.

i find menu-item "debconf prioriteit veranderen"
[bug] it has priority medium, but should have priority high,
  as it has no reasonable default,
  ie i can not by reasoning about it infer default behaviour it has
    (not only is it more advanced than anyone would suspect,
     newbie is not aware that it exists at all),
  also, while it is easy to increase priority,
    it is impossible to lower priority if question is not shown.
[dutch] "U dient de laagste prioriteit waarvan U nog vragen wilt getoond 
worden :"
  removing whole sentence from this place and rewriting whole screen
  seems like best solution ;
  what to replace it with depends on
    whether any questions are asked not-by-debconf.
  maybe something like :
  "installer (needs|uses debconf) to ask you questions"]
  "questions that have defaults that normally work well
   are less important then questions to which installer can't know answer"
  "every question is assigned a priority. possible prioritys are :"
  <list of prioritys>
  "you can choose minimum priority of questions asked :"
  <selection menu> (default medium?)
(more verbose if there is space)

(i don't remember if user is anywhere told that (s)/he can go back
   and redo any step as often as they want. ??)

i set priority to 'laag' (basso continuo).

now i try shell, hoping to make my notes in digital form,
  instead of using pen and paper.
i go to vt2, and find busybox ash. (busybox v1.00-pre10)
"enter help for a list of commands"
  this list is incomplete.
  woody had 'try ls /bin /sbin /usr/bin /usr/sbin', which finds nano.
[remark] any amount of background info about menu and debconf questions
  could be put under /doc
i cannot write notes with nano,
  because i dont know where harddisk is in filesystem.
[wishlist?]  explanation of mount point and scsi filename format is desirable,
  as a newbie can not guess this.
  browsing with ls through all files does find partitions, however.

shell prompt (home space fence) gives impression that i am in 
  pwd shows i am in slash. change default prompt ?

"installatie modules van CD laden" :  i request base-config.udeb
'load installer modules from cd'

"automatisch herkennen van hardware"::unavailable modules :
'automatic recognition of hardware'
  "Een deel van de voor Uw hardware" _"vereiste"_ "modules.."
  'a part of the for your hardware required modules'
  a.o. floppy module.
  i do not require floppy, i do not even desire it,
  it is disabled in bios (by me) because floppydrive in pc is broken.
  (i do have good ones, i just never use them
    because they were always unreliable).
replace by 'drivers for your hardware' ?

let installer run dhcp twice works ok.
  (i couldnt find leases file though).

domain org.org

[dutch] "vragen voor module argumenten ?" -> "naar mod-arg vragen ?"

Again some modules are yet unavailable, so i am told,
  Exact same list as last time is displayed.
  Why ?!?

"Schijf indelen"  ('partition disk') :
  Intro tells about partition table,
    but not a word about submenu raid/lvm/help

[dutch] "er zijn geen raid partities" : typo : "zpartities"
  typo : "zo'n partities" -> "zulke"

  'The logical volume...' -> 'A logical ...' ; an lvm is not necessary.

submenu entry "begeleide schijfindeling" ('guided partitioning')
  gives hope that guidance is available for manual partitioning,
  but it is only a loop,
  and functionality is already provided by <back>
  remove please.

"help i.v.m. schijfindeling" -> "help tekst over schijfindeling lezen"
'help on partitioning'       -> 'read help text about partitioning'
  (more consistent style)

  "ruimte aanmaken" ('create space') :
    what would einstein say about that, i wonder ?

  "in welke vrije ruimte wilt u partities aanmaken ?"
  'in which free space do you want partitions to be created ?'
  -> "U kunt partities maken van vrije ruimte.
      U kunt partities verwijderen om vrije ruimte te krijgen ;
        dat wist alle gegevens uit die partities."
     'you can create partitions from free space,
     'you can remove partitions to get free space ;
      doing that will erase all data on these partitions'

 "om ... selecteert U deze" -> "...selecteert U deze en drukt U enter"
 'to ... you select this'   -> '... you select this and press enter'
   (consistency of what 'selecting' means)

 "dit installatie proces maakt het onmogelijk ... te overschrijven".
 'this install process makes it impossible to overwrite ...' .

[dutch] "aanhechtpunt voor deze partities" : "niet aankoppellen" typo
  "aankoppelopties" : @nodev : "karkater" typo

'typical use' :
  how many filechunkbytes/inode uses 'standard' ?
    (does kernel have small file support, storing small files in inode?)
  how many bytes does inode itself consume ?

[dutch] "gegevens van een andere partitie overnemen" is dubbelzinning,
  want ook partitie-instellingen zijn gegevens.
  -> "een andere partitie kopieren naar deze partitie"

menu 'use partition as' : two identical entries for fat32

i choose to use part1 (42 MB fat32) as fat32 on /windows ;
  i hope it wont be overwritten.
  it reassures me that it's not gonna overwrite
    by telling me what it'll do before doing what it does.

i think i am in base-install.udeb now

"choose kernel"
  nicer to have it here than in the help screens.

install grub in mbr works ok.

install lilo in mbr works ok.
  hey, 'advanced' allows custom partition selection,
    but still no description of filesystem layout (devfs).
  maybe 'advanced' is too easy to misinterpret :
    ofcourse i want an advanced system.

maybe <hr> separator in main menu after 'finish install' ?

'install base before restart ?' : wrong default 'nee'
  user already chose. no need to change choice. not dangerous.
  HEY! it doesnt do anything. (or so it seems).

'save logs' -> 'also save logs on diskette'
  i thought question meant that it would discard logs.
  i hoped that it would show path to file, so i could save nano notes.
[bug] it has no back button
  so it tries to write to nonexistent floppy (doomed to fail ofcourse...)
  "can't find floppy station"                (obviously)
  "you probably ran into a bug in 'bugreporter-udeb' package"
    (is it trying to say "it's not my fault and you cant report it" ?)

check cd :
  it would be visually quieter if all screens had same size.
  maybe add extra newline to display of short filenames ?

'check another cd ?'	 yes (but i didnt replace cd)
[bug] "De geplaatste cd is geen geldige Debian CD"
      'the placed cd is not a valid debian cd'
  Bullshit. you just ok'd it.
[bug] no <back> button.
  "De debian startup cd must be in drive, did you do this ?" Yes. Next.
i find myself back at main menu.
  maybe combine these two screens ?
  maybe relabel <next> to <back to main menu> ?

'open a shell'
  looks like same busybox ash i have on vt2
  mount : no mention of /dev/ram, so i assume ram is tmpfs
    "none on /dev"
    "none on /dev/pts"
    "none on /proc type proc type proc" (my notes may be wrong here)
  does mount tell what it didnt mount these days ?

/usr/lib has 2 versions of libdebconfclient : 0 and 0.0.0

commandline editing is broken :
  when using up-arrow to get previous command,
  appending to that command works ok,
  but editing it fails.
  example: try to add '-al' to 'ls /etc/dhcp'

network/interfaces has (default) mtu 1500,
  but my isp says i should set 1496
    (in it's windows-targeted manual)

i wonder why network interfaces were configured at all.
it is not needed until after reboot
  unless (like in my case now) i use base-install.udeb

ash has 'set' for 'printenv' (found by experiment, dangerous)
[bug]  locale not set at all.

[BUG] i have not been presented with kernel modules to load.
  i want fat32
  (shell said /windows is an empty partition,
   i dont know if there was anything on this disk)
  i want 8139too for my other network card (currently not installed)

'finish install'
@ BaseConfig :
  me no believe c'e timezone Zulu

[bug] screen error in menus : <cancel> displayed double,
  in original place, and to immediate right of <ok>
  thus not undrawn correctly when using tab key.
  arrows behave differently (from tab)

i choose Zulu

[wishlist] no option to specify uid in 'add a user'

[bug] display glitches in 'apt configuration' :
  a # and a <lotsofdots> are displayed after countrynames,
    not in scrollbar.
  also same <cancel> errors

packages are gotten from ftp.de.debian.org

  information scrolls over window.  near
    -identical lines, but without newline i
      nbetween, so unreadable wallpaper

"these packages can be upgraded, but you have asked for them to be held at 
\n\n\n\n\n\n\n\n\n\n\n\n\n\n\n their current version"
  No i didnt.

i cant continue from here.
is this aptitude in black and broken white ?

installation failed.


 RFCs are free enough for me.
 are people also software ?

Reply to: