[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#239443: marked as done (When debootstrap finishes, devfs has to be mounted on /target/dev when LVM is in use)

Your message dated Fri, 3 Sep 2004 15:15:25 -0400
with message-id <20040903191525.GA13853@kitenet.net>
and subject line closing
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 21 Mar 2004 12:42:34 +0000
>From mattheww@chiark.greenend.org.uk Sun Mar 21 04:42:34 2004
Return-path: <mattheww@chiark.greenend.org.uk>
Received: from chiark.greenend.org.uk [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B52Hh-0004q1-00; Sun, 21 Mar 2004 04:42:34 -0800
Received: by chiark.greenend.org.uk (Debian Exim 3.35 #1) with local
	for submit@bugs.debian.org
	id 1B52Hg-0005tx-00; Sun, 21 Mar 2004 12:42:32 +0000
Date: Sun, 21 Mar 2004 12:42:29 +0000
To: submit@bugs.debian.org
Subject: Installation report: beta 3, LVM root and boot.
Message-ID: <20040321124229.GA1440@golux.woodcraft.me.uk>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/
From: Matthew Woodcraft <mattheww@chiark.greenend.org.uk>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_12 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_12

Package: installation-reports

Debian-installer-version: Beta 3 (2004-03-17)
uname -a: Linux mere-device 2.4.25-1-686 #1 Tue Feb 24 10:55:59 EST 2004 i686 GNU/Linux
Date: 2004-03-20
Method: hd-media, sarge-i386-businesscard.iso, booting with grub.

Machine: Generic Pentium II from 1999, Intel 440BX motherboard
Processor: Pentium II 400MHz
Memory: 128MB
Root Device: LVM volume on IDE hda
Root Size/partition table:
   Device Boot Start     End   #cyls    #blocks   Id  System
/dev/hda1          0+   1202    1203-   9663066   8e  Linux LVM
/dev/hda2          0       -       0          0    0  Empty
/dev/hda3          0       -       0          0    0  Empty
/dev/hda4   *   1203    1231      29     232942+   5  Extended
/dev/hda5       1203+   1231      29-    232911   83  Linux

LVM volumes:
Disk /dev/vg00/root: 32 cylinders, 128 heads, 128 sectors/track
Disk /dev/vg00/var: 128 cylinders, 128 heads, 128 sectors/track
Disk /dev/vg00/usr: 500 cylinders, 128 heads, 128 sectors/track
Disk /dev/vg00/home: 512 cylinders, 128 heads, 128 sectors/track

Output of lspci:
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
00:10.0 PCI bridge: PicoPower Technology PT86C525 [Nile-II] PCI-to-PCI Bridge (rev 01)
00:11.0 Multimedia audio controller: Ensoniq ES1370 [AudioPCI] (rev 01)
00:12.0 Ethernet controller: NetVin NV5000SC
01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 PF/PRO AGP 4x TMDS
02:08.0 SCSI storage controller: Advanced System Products, Inc ABP940-U / ABP960-U (rev 03)
02:09.0 Multimedia video controller: Zoran Corporation ZR36057PQC Video cutting chipset (rev 02)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [?]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Partition hard drives:

For this installation, I was trying to put all filesystems on LVM.

I created a single primary partition and set it to be an LVM physical volume.
I left hda5 alone as it was mounted for the hd-media install.

I chose to configure LVM and tried to create a volume group, but it said no
physical volumes were found. Console 3 says:
  pvscan -- no valid physical volumes found
So I ran
  pvcreate /dev/hda1
in a shell, and it let me configure LVM and then create the file systems.

Install base system:

When the base system install reached the kernel, I chose
kernel-image-2.4.25-1-686. Installation failed with error
  mkinitrd: constituent device /dev/vg00/root does not exist!

(cf bug 237466).

So I started again, and while the base system installation paused to offer me
a choice of kernel, I did the following:
  mkdir /target/dev/vg00
  cd /target/dev/vg00
  mknod group c 109 0
  mknod root b 58 0
  mknod var b 58 1
  mknod usr b 58 2
  mknod home b 58 3

  chroot /target
  apt-get install lvm-common
  apt-get install lvm10

(This also brings in binutils, file, and libmagic1.)

This time the kernel installed without errors and the base system install

Then I ran
  apt-get install devfsd
inside the chroot, because a debconf note in one of the lvm packages advised it.

Install boot loader:

When it gave me a dialog asking where to install grub, I chose to cancel and
install lilo instead, because I needed support for booting from an LVM volume.

I chose to install lilo from the main menu. I accepted the default selection
for root as /dev/vg00/root. This installation appeared to complete
successfully. But I didn't see an /etc/lilo.conf in the target afterwards, so
I wrote my own and ran lilo by hand:




I chose the reboot option from the main menu.

I was shown a message saying

<< Are you sure you want to reboot now? If you have not finished the install,
your system may be left in an unusable state. >>

As far as I could tell, I had finished the install (there were no further
entries in the main menu), so I chose to reboot.

The machine rebooted successfully, but instead of continuing with base-config,
I was left at the login prompt.

Some things were still unconfigured: /etc/network/interfaces was empty, and
/etc/console/boottime.kmap was missing.

I fixed these and then ran base-config by hand. The installation completed

There is no /var/log/debian-installer, but I have preserved the following logs
from just before the reboot:


In the partitioner, there is a dialog in which you choose the usage method,
file system, mount point and so on for a partition. It would be useful if this
dialog could show somewhere which partition it is manipulating. When I was
using this dialog with the LVM partitions, it was sometimes difficult to
remember which one I was dealing with when I had to select the mount point.

Received: (at 239443-done) by bugs.debian.org; 3 Sep 2004 19:16:28 +0000
>From joey@kitenet.net Fri Sep 03 12:16:28 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1C3JXw-00089r-00; Fri, 03 Sep 2004 12:16:28 -0700
Received: from dragon.kitenet.net (unknown [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id A950117E99
	for <239443-done@bugs.debian.org>; Fri,  3 Sep 2004 19:15:08 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id E999B6E0C6; Fri,  3 Sep 2004 15:15:25 -0400 (EDT)
Date: Fri, 3 Sep 2004 15:15:25 -0400
From: Joey Hess <joeyh@debian.org>
To: 239443-done@bugs.debian.org
Subject: closing
Message-ID: <20040903191525.GA13853@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="2fHTh5uZTiUOsy+g"
Content-Disposition: inline
User-Agent: Mutt/1.5.6+20040818i
Delivered-To: 239443-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-3.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

I'm closing this bug report because current daily builds of d-i support
installing root on lvm with no hackery.

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.5 (GNU/Linux)



Reply to: