[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#269822: i386 rc1 netinst failure (pentium 3, via)

Package: installation-reports

Debian-installer-version: rc1 netinst CD image (i386) downloaded some time last week.  or was it two weeks ago?
uname -a: Linux hostname 2.4.27 #2 Fri Sep 3 10:05:23 EDT 2004 i686 GNU/Linux (custom kernel I built after woody installation -- see below)
Date: Thu Sep 2, in the afternoon; and Fri Sep 3, morning
Method: Partitioned the disk (13 GB disk with Win98) using partition magic, leaving about 2.2 GB free.  Booted the sarge CD, hit Enter (default 2.4.x kernel).

Machine: White-box Pentium III mid-tower PC, VIA chipset.  As generic as you can ask for.
Processor: Pentium III (Coppermine) 800 MHz
Memory: 256 MB
Root Device: /dev/hda (Maxtor 51369U3 ATA disk)
Root Size/partition table: /dev/hda1 = Win98.  /dev/hda2 = Linux ext3, /dev/hda3 = Linux swap (see below)
Output of lspci and lspci -n: (see below)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [E]
Mount partitions:       [E]
Install base system:    [E]
Install boot loader:    [ ]
Reboot:                 [ ]


Ugh, where to start.  Let's start by stating clearly that I used this
*very same* sarge netinst CD to install sarge on a different i386 box
last week, and it went smooth as silk.  So it's not a bad image, and
it's *probably* not a damaged CD.

This computer is not mine; it was brought to me to be converted from a
Win98 box to a Win98/Debian dual-boot box.  I won't have access to it
after today, so I can't repeat this installation.

Installed partition magic 7.0 from CDs, ran it, attempted to resize the
(FAT32) partition to leave space for Linux.  This failed during the reboot
cycle (where it does the actual work).  Had to reboot into DOS mode and
run scandisk (which acts like a DOS program if you reboot into DOS, but
acts like a Windows program if you boot normally -- and is utterly useless
in Windows).  Fixed the file system corruption, reran PM, got the partition

Booted the sarge CD.  Laid out the partitions like this (typing, not

 Disk /dev/ide/host0/bus0/target0/lun0/disc: 13.5 GB, 13520166912 bytes
 255 heads, 63 sectors/track, 1643 cylinders

      Device Boot     Start    End      Blocks      Id  System
   .../part1   *          1   1351    10851876       c  W95 FAT32 (LBA)
   .../part2           1352   1618     2144677+     83  Linux
   .../part3           1619   1643      200812+     82  Linux swap

Created an ext3 file system on /dev/hda2 and swap on /dev/hda3.  It began
installing the base system from the CD-ROM, and that's when everything
started going wrong.  The actual symptom was an error message saying that
installing the base system had failed (Alt-F3 for details, etc.).

I went to Alt-F3 and there were a lot of errors of the form "package foo
pre-depends on package bar, but bar is not configured yet, but I'll carry
on anyway".  I have no idea where the first error was; it was too far back.

I retried several times.  My next try was just to re-install the base
system over top of the half-installed one.  This failed.  Then I tried
recreating the ext3 file system, so that it could start with a fresh
slate.  That failed again.  I might have tried a few more times as well;
I forget.

At some point I saw that dpkg had suffered a segmentation fault.
This led me to think that perhaps the computer had bad RAM.  So I
went back into Win98, downloaded the memtest86 floppy image .zip file,
realized I had no way to unzip it, unzipped it on my unix workstation,
then downloaded the unzipped files by ftp.  Tried to write the image
to a floppy, but that failed.  Multiple times.  I couldn't even *read*
a known-good floppy, so I replaced the floppy drive.  After that, I was
able to format a floppy (with 128k worth of bad sectors, but apparently
not at the front of the floppy) and write memtest86's image to it.
I booted that and let it run overnight.

There were no memtest86 errors.  If this machine has hardware problems,
they're elsewhere.

Then I tried sarge again.  Booted the CD-ROM, went through the menus up
to the disk partitioner.  When I tried to redo the file system and swap
area, it *hung*.  No errors on Alt-F3 or anything, though I could flip
back and forth between the virtual consoles.  That's why I've marked the
three "E"s in the grid up above.  Everything from the partitioner to
the base system was flaky as hell, and I couldn't get through it.

So then I took out my woody CD and installed woody on the computer, using
"bf24", leaving the partition table alone but recreating the ext3 file
system and swap space.  That worked flawlessly.  Not a single problem
with the installation from the woody CD.

I upgraded it to sarge.  That also went flawlessly.  (Note: the network
was working at this point.)

Built a custom kernel.  Twice, in fact.  No sign of "sig11" evilness
anywhere -- no segfaults from gcc, no mysterious failures anywhere at all.
The only problem I had was getting the tulip driver to talk to either
of my walljacks (one locked at 100-half, the other at 10-full).  When I
first started out this morning, it worked great in the 100-half walljack;
but then, mysteriously, after rebooting into my custom 2.4.27 kernel,
it couldn't negotiate the correct speed or duplex with the 100-half jack
any more in any Linux kernel.  Even the one that had just worked an hour
before that.  And then an hour later it suddenly worked again.  But that's
not a d-i installation problem, so I won't dwell on it any further....

Short story: sarge blew up, woody worked great.

Here's the lspci output from Alt-F2 on the sarge CD (after mounting the
long-form of /dev/hda2 and then chrooting into it):

sh-2.05b# lspci
pcilib: Cannot open /proc/bus/pci
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x] (rev 44)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 12)
0000:00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 08)
0000:00:07.3 Host bridge: VIA Technologies, Inc. VT82C596 Power Management (rev 20)
0000:00:08.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev 01)
0000:00:09.0 USB Controller: NEC Corporation USB (rev 41)
0000:00:09.1 USB Controller: NEC Corporation USB (rev 41)
0000:00:09.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
0000:00:0a.0 Serial controller: 5610 56K FaxModem 56K FaxModem Model 5610 (rev 01)
0000:00:0b.0 Ethernet controller: Lite-On Communications Inc LNE100TX [Linksys EtherFast 10/100] (rev 25)

And here's "lspci -n" from the installed woody-to-sarge system on the
hard drive (2.4.27 kernel):

# lspci -n
0000:00:00.0 0600: 1106:0691 (rev 44)
0000:00:01.0 0604: 1106:8598
0000:00:07.0 0601: 1106:0596 (rev 12)
0000:00:07.1 0101: 1106:0571 (rev 06)
0000:00:07.2 0c03: 1106:3038 (rev 08)
0000:00:07.3 0600: 1106:3050 (rev 20)
0000:00:08.0 0300: 121a:0005 (rev 01)
0000:00:09.0 0c03: 1033:0035 (rev 41)
0000:00:09.1 0c03: 1033:0035 (rev 41)
0000:00:09.2 0c03: 1033:00e0 (rev 02)
0000:00:0a.0 0700: 12b9:1008 (rev 01)
0000:00:0b.0 0200: 11ad:c115 (rev 25)

In addition to the PCI devices, this computer has an ISA SoundBlaster
AWE64 sound card in it.  I did not try to remove it at any point.
"modprobe sb" succeeded, though I didn't test it (no speakers handy).
There are no other ISA devices.

Reply to: