[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#269529: OldWorld pmac installation -- several problems

Package: installation-reports

        powerpc businesscard 20040829 OldWorld PowerMac


Debian-installer-version: <Fill in date and from where you got the image>

    Index of /pub/cdimage-testing/daily/powerpc/current 

     Name                           Last modified       Size  Description

     Parent Directory               29-Aug-2004 00:21      -  
     MD5SUMS                        29-Aug-2004 00:21     1k  
>>>> sarge-powerpc-businesscard.iso 29-Aug-2004 00:19   141M  
     sarge-powerpc-netinst.iso      29-Aug-2004 00:21   298M  
    Apache/1.3.31 Server at cdimage.debian.org Port 80

uname -a: <The result of running uname -a on a shell prompt>

    Linux dillserver 2.6.7-powerpc #1 Thu Aug 5 23:48:59 CEST 2004 ppc GNU/Linux

Date: <Date and time of the install>

    4 AM (UTC) 2004-09-01

    How did you install?

	businesscard CD-ROM

    What did you boot off?

        MacOS-9 via BootX

    If network install, from where?

	#deb http://debian.uchicago.edu/debian/ sarge main

	deb http://debian.uchicago.edu/debian/ testing main
	deb-src http://debian.uchicago.edu/debian/ testing main

	deb http://ftp.us.debian.org/debian/ testing main
	deb-src http://ftp.us.debian.org/debian/ testing main

	deb http://security.debian.org/ testing/updates main



Machine: <Description of machine (eg, IBM Thinkpad R32)>

    PowerMac 6500/225


    processor       : 0
    cpu             : 603ev
    clock           : 225MHz
    revision        : 2.1 (pvr 0007 0201)
    bogomips        : 148.99
    machine         : Power Macintosh
    motherboard     : AAPL,e411 MacRISC
    detected as     : 36 (Gazelle)
    pmac flags      : 00000000
    memory          : 128MB
    pmac-generation : OldWorld


    128 MB

Root Device: <IDE?  SCSI?  Name of device?>

    IDE /dev/hda11

Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.

               The root is on hda11, swap is on hda7.
               The sda disk is present but unused in this installation.
               The rest of the hda disk (particularly the hda9 "Apple_Bootstrap" partition) is unused
               in this installation.

	    #                    type name                  length   base      ( size )  system
    /dev/hda1     Apple_partition_map Apple                     63 @ 1         ( 31.5k)  Partition map
    /dev/hda2        Apple_Driver_ATA Macintosh                 54 @ 64        ( 27.0k)  Unknown
    /dev/hda3        Apple_Driver_ATA Macintosh                 74 @ 118       ( 37.0k)  Unknown
    /dev/hda4      Apple_Driver_IOKit Macintosh                512 @ 192       (256.0k)  Unknown
    /dev/hda5           Apple_Patches Patch Partition          512 @ 704       (256.0k)  Unknown
    /dev/hda6               Apple_HFS untitled             1024000 @ 1216      (500.0M)  HFS
    /dev/hda7         Apple_UNIX_SVR2 swap                  500001 @ 1025216   (244.1M)  Linux swap
    /dev/hda8         Apple_UNIX_SVR2 root-8              19531251 @ 1525217   (  9.3G)  Linux native
    /dev/hda9         Apple_Bootstrap boot                    1954 @ 21056468  (977.0k)  NewWorld bootblock
    /dev/hda10        Apple_UNIX_SVR2 root                19531251 @ 21058422  (  9.3G)  Linux native
    /dev/hda11        Apple_UNIX_SVR2 root-11             19531251 @ 40589673  (  9.3G)  Linux native
    /dev/hda12             Apple_Free Extra              100715556 @ 60120924  ( 48.0G)  Free space

    Block size=512, Number of Blocks=160836480
    DeviceType=0x0, DeviceId=0x0
    1: @ 64 for 21, type=0x701
    2: @ 118 for 34, type=0xf8ff

	    #                    type name                length   base    ( size )  system
    /dev/sda1     Apple_partition_map Apple                   63 @ 1       ( 31.5k)  Partition map
    /dev/sda2          Apple_Driver43 Macintosh               54 @ 64      ( 27.0k)  Driver 4.3
    /dev/sda3          Apple_Driver43 Macintosh               74 @ 118     ( 37.0k)  Driver 4.3
    /dev/sda4      Apple_Driver_IOKit Macintosh              512 @ 192     (256.0k)  Unknown
    /dev/sda5           Apple_Patches Patch Partition        512 @ 704     (256.0k)  Unknown
    /dev/sda6               Apple_HFS untitled           1024000 @ 1216    (500.0M)  HFS
    /dev/sda7         Apple_UNIX_SVR2 root               6291456 @ 1025216 (  3.0G)  Linux native
    /dev/sda8         Apple_UNIX_SVR2 swap               1126920 @ 7316672 (550.3M)  Linux swap

    Block size=512, Number of Blocks=8443591
    DeviceType=0x0, DeviceId=0x0
    1: @ 64 for 23, type=0x1
    2: @ 118 for 36, type=0xffff

Output of lspci and lspci -n:

    0000:00:0b.0 Host bridge: Apple Computer Inc. Bandit PowerPC host bridge (rev 03)
    0000:00:10.0 ff00: Apple Computer Inc. O'Hare I/O (rev 01)
    0000:00:11.0 Ethernet controller: Digital Equipment Corporation DECchip 21041 [Tulip Pass 3] (rev 21)
    0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 41)

    0000:00:0b.0 0600: 106b:0001 (rev 03)
    0000:00:10.0 ff00: 106b:0007 (rev 01)
    0000:00:11.0 0200: 1011:0014 (rev 21)
    0000:00:12.0 0300: 1002:4754 (rev 41)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [o] Note 0 and 1 
Configure network HW:   [e] Note 2
Config network:         [o] Note 2
Detect CD:              [e] Note 3
Load installer modules: [o]
Detect hard drives:     [e] Note 3
Partition hard drives:  [o] Note 0 and 4
Create file systems:    [o]
Mount partitions:       [o]
Install base system:    [o] Note 5 and 7
Install boot loader:    [ ] Note 0
Reboot:                 [e] Note 3 and 6


<Description of the install, in prose, and any thoughts, comments
      and ideas you had during the initial install.>

Note 0:

I used MacOS-9 and the BootX boot loader.  I skipped the "install boot
loader" phase of d-i, as a consequence.

Because of the need to preserve the MacOS-9 partition on the disk, I
used the manual partition option in the Partition Hard Drive phase.

Note 1:

During the language/keyboard choice phase, I took all the defaults
(Language->English, Region->UnitedStates, KeyboardType->USB) until it
came to the Keymap choice.  There the default was "European".  This is
*not* what I expected -- or what was the default behavior in the past!
Having done everything possible to indicate that I was in the USA and
speaking English, I would have expected the default keymap to be

A serious violation of the principle of least astonishment.

Note 2:

In spite of what lspci says about the ethernet chip being a "Tulip",
it seems to much prefer the "d4x5" driver.  I can find nothing in the
output of lspci or in the /proc/device-tree structure that would give
a clue that this is the case.  Does anybody know what the difference
between the two drivers is? 

In any case, the network initial configuration phases tried to load
the "tulip" driver, but failed to activate the interface with that
driver, so I had to chose the d4x5 driver manually from the fall-back
list of network drivers.

I successfully configured the network addresses/names/etc manually.
That part seems to have been fixed.

Note 3:

The CD-rom drive is on the apple "mesh" scsi controller.  I had go to
the F2 console and manually "modprobe mesh" to get it to recognize the
CD-ROM drive and the SCSI disk.  Because the mesh driver module was
loaded behind d-i's back (so to speak), d-i didn't know about it, and
as a result, "mesh" wasn't present in /etc/modules after the reboot.

Many oldworld PowerMac's have the "mesh" scsi controller as their
*only* (and in any case *primary*) mass-storage interface.  Failure to
load the mesh driver module will make it impossible for inexperienced
users to install Debian on their machines.  It seems to me that the
mesh driver should be loaded by default on *all* oldworld PowerMac

Note 4:

The partitioner seems to default to putting the "noatime" attribute on
new ext3 partitions.  This is a violation of the principle of least
astonishment.  The default should be standard UNIX behavior!

Note 5:

For reasons I don't entirely understand, wget does not recover well
from occasional dropped packets, so it times-out and fails during the
"install base system" phase.  Retrying the phase works (usually,
barring another dropped packet).  This is a common enough problem that
it would seem a good idea to automatically re-try a failing wget a few
times before giving up and bugging the user.

Note 6:

Prior to the reboot, I tried to "Save debug logs" to a floppy disk.
It failed because "No floppy device was found".  The oldworld Macs all
use the "swim3" floppy controller.

Attempting to manually "modprobe floppy" from the F2 console gives the

	FATAL: Error inserting floppy
	Device or resource busy

Interestingly, floppy.ko has date "Jan 1 1970".  All other modules in
that directory have date "Aug 26 14:53".  Strange...

Note 7:

The default kernel that is offered in the base install phase is 2.6.7,
even though the d-i is running under the 2.6.8 kernel.  When I
manually chose to install the 2.6.8 kernel, the reboot failed.  It
hung very early in the boot process -- before the Tux Penguin image
was supposed to appear at the top of the screen.

I had to go back and re-do the install and accept the default 2.6.7
kernel.  Very strange!

Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.

Reply to: