[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#256374: Installation hangs on Compaq Presario 1220 while loading module 'ide-cd' during hardware detection for the CD-ROM drive (beta4, i386, linux26)

Per Olofsson wrote:

On Sat, Jun 26, 2004 at 16:46 -0300, Robin Blondon wrote:
I found in bug #250596, the person had to eject and reinsert his wireless card for it to be detected. I tried this and it worked. Is the system supposed to be able to detect the card without needing to reinsert the card?

Yes, you shouldn't need to reinsert the card. Do you have to reinsert
the card after boot under a running sarge system too?

In the installer, I found that instead of ejecting and reinserting the card I can go into the shell and kill and restart cardmgr. The intstaller then detected the card after choosing to detect network hardware from the installer menu.

However, after the base system was installed and the system rebooted, eth0 was unavailable. Some messages went by quickly during the boot regarding trying to set the ESSID but there is no eth0. Also, while the PCMCIA services were starting up there were some errors to the effect of "insmod yenta_socket failed". cardmgr was not running and lsmod showed that there were no PCMCIA modules running except pcmcia_core. When I tried to run cardmgr from the shell I got the error "cardmgr[716]: no pcmcia driver in /proc/devices".

The first set of messages are:
Configuring network interfaces...Error for wireless request "Set ESSID" (8B1A):
SET failed on device eth0 ; No such device.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device eth0 ; No such device.
Error for wireless "Set Mode" (8B06) :
SET failed on device eth0 ; No such device.

The second set of messages after starting PCMCIA services are:
/lib/modules/2.4.25-1-386/kernel/drivers/pcmcia/yenta_socket.o: init_module: No such device Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.25-1-386/kernel/drivers/pcmcia/yenta_socket.o: insmod /lib/modules/2.4.25-1-386/kernel/drivers/pcmcia/yenta_socket.o failed /lib/modules/2.4.25-1-386/kernel/drivers/pcmcia/yenta_socket.o: indmos yenta_socket failed

Is there anything else I should try?

- Robin

Reply to: