[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#256426: SCSI fatal bug seems recent

Package: installation-reports

Debian-installer-version: June 19, 2004  ftp.rutgers.edu  testing
uname -a:
    Linux jeeves 2.4.25-1-586tsc #2 Wed Apr 14 20:49:50 EST 2004 i586 GNU/Linux
Date: June 19, 2004  about 2200 EDT
Method: How did you install?  FTP download from mirror
	What did you boot off?  Floppies, 20040528 set, with network
		drivers floppy
	If network install, from where?  ftp://ftp.rutgers.edu
	Proxied?  No.

Machine:  Compaq Deskpro
Processor:  Pentium 133
Memory:  32 MB
Root Device: SCSI, AHA1542 host adapter.  Name of device?  /dev/sda3
Root Size/partition table:

Disk /dev/hda: 2577 MB, 2577383424 bytes
128 heads, 63 sectors/track, 624 cylinders
Units = cylinders of 8064 * 512 = 4128768 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           3          28      104832    6  FAT16
/dev/hda2              29          41       52416   83  Linux
/dev/hda3               1           2        8032+  12  Compaq diagnostics
/dev/hda4              42         624     2350656    5  Extended
/dev/hda5              42          58       68512+  82  Linux swap
/dev/hda6              59         624     2282080+  83  Linux

Partition table entries are not in disk order

Disk /dev/sda: 2151 MB, 2151067648 bytes
64 heads, 32 sectors/track, 2051 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          50       51184   83  Linux
/dev/sda2              51         306      262144   82  Linux swap
/dev/sda3             307        2051     1786880   83  Linux

Disk /dev/sdb: 2149 MB, 2149071360 bytes
64 heads, 32 sectors/track, 2049 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1               1         800      819184   83  Linux
/dev/sdb2             801        2049     1278976   83  Linux

/dev/sda3 on / type reiserfs (rw)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/sda1 on /boot type reiserfs (rw)
/dev/sdb1 on /var type reiserfs (rw)
/dev/sdb2 on /home type reiserfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/fd0 on /media/floppy type ext2 (rw,noexec,nosuid,nodev,user=jac)

Output of lspci:

00:00.0 Host bridge: Intel Corp. 430HX - 82439HX TXC [Triton II] (rev 01)
	Flags: bus master, medium devsel, latency 32

00:03.0 Ethernet controller: Digital Equipment Corporation DECchip 21041 [Tulip Pass 3] (rev 11)
	Flags: bus master, medium devsel, latency 66, IRQ 11
	I/O ports at 1080 [size=128]
	Memory at 41000000 (32-bit, non-prefetchable) [size=128]
	Expansion ROM at f7fc0000 [disabled] [size=256K]

00:07.0 ISA bridge: Intel Corp. 82371SB PIIX3 ISA [Natoma/Triton II] (rev 01)
	Flags: bus master, medium devsel, latency 0

00:07.1 IDE interface: Intel Corp. 82371SB PIIX3 IDE [Natoma/Triton II] (prog-if 80 [Master])
	Flags: bus master, medium devsel, latency 64
	I/O ports at 1000 [size=16]

00:0f.0 VGA compatible controller: Cirrus Logic GD 5436 [Alpine] (prog-if 00 [VGA])
	Flags: medium devsel
	Memory at 40000000 (32-bit, non-prefetchable) [size=16M]
	Expansion ROM at 000c0000 [disabled] [size=32K]

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O/E]
Partition hard drives:  [O/E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O/E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


	This report summarizes results of further test runs on the same
Pentium machine described in report #252551.  I decided to make this a
separate report in order to give it a more informative title.
	The principal discovery is that the choice of mirror to download
installer components is what determines whether a fatal bug occurs in the
	Previous results had implied that the number of drives connected to
the SCSI host adapter determined whether the installer hung at the end of
partition layout, but that turned out not to be correct.
	(It is also possible that the fatal bug might not be specific to
SCSI drives; however, my only IDE drive holds a working server installation,
so I can't overwrite it for tests.  However, since it showed up on two
radically different SCSI machines, and has not been reported by others, it
is very likely SCSI-specific.)
	When the installer has booted from the floppies, network modules are
installed from the floppy, and the network has been configured, the
program asks the user to select a mirror to load installer components.
	If I select ftp://ftp.rutgers.edu and the "testing" branch, I am
able to complete the installation.  I haven't tested this mirror with http
	If I select any other of the mirrors I tried, or if I select
ftp.rutgers.edu but the "unstable" branch, the installer hangs.  I'm able to
assign mountpoints to partitions, and the program checks swap space on first
/dev/hda5 and then /dev/sda2, but then it hangs.  Issuing any command in
virtual terminal 2 causes the shell to exit.  Opening the virtual terminal
again and attempting to issue a command causes it to exit again.
	Other mirrors I tried are: ftp.us.debian.org, debian.uchicago.edu,
debian.lcs.mit.edu, ftp-linux.cc.gatech.edu, lyre.mit.edu, ftp.debian.org. 
The exact behavior and messages on virtual terminals 3 and 4 at the time of
failure vary, but none get as far as mounting /target.
	I also noticed that the screen layout of the partitioner from
ftp.rutgers.edu "testing" looks a little less polished than the other
mirrors' partitioning programs, including the ftp.rutgers.edu "unstable"
partitioner.  This suggests that the only known successful partitioner is an
older version, and that the fatal bug was introduced recently.

	No installer tested gives any help in installing or identifying the
proper SCSI driver modules, either on this machine or the much newer "edgar"
which has a PCI SCSI interface.  However, I did determine that it was
possible to open virtual terminal 2 and then browse the
/lib/modules/2.4.26-1-i386/kernel/drivers tree, to find the names of the
modules available.  I was then able to issue the command
		modprobe aha1542
just before detecting drives, and see all the SCSI devices.
	Similarly, when I wanted to use a NE-2000 clone ISA-PNP Ethernet
adapter to download the installer components, I waited until the driver disk
had been read, and then issued the command
		modprobe ne
	Until a convenient aid to manual module selection is built into the
installer, it would be highly desirable to describe this procedure in the
installer manual.
	It would also be very helpful to put a message on the first screen
along the lines of "Use expert mode for SCSI or other unusual hardware. 
Press F1 for more information."  Right now, the existence of expert mode is
difficult to discover.

Reply to: