[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Install Report (22 June 04 Daily Build), Problem with Time Zones



Debian-installer-version:
========================================
22 June 2004

$ md5sum sarge-i386-netinst.iso
5db3c8d500380d664c748356910a6d2e  sarge-i386-netinst.iso

(md5sum is okay)
========================================

Install Date:
========================================
23 June 2004
========================================

Method:
========================================
netinst (CD)
========================================

Hardware:
========================================
Athlon 2200 XP
ASUS A7N8X (Motherboard)
ASUS V8420 - NVIDIA GeForce 4 (Video)
512 MB RAM
========================================

Base System Installation Checklist:
========================================
Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]**
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
========================================


Comments:
========================================

There appears to be some problem with the time zone settings.  I set the
clock to UTC and my time zone to Eastern (Canada).  Then I noticed... the
time that is displayed is UTC.

I then poked around in the /etc files and another directory I found:
---
user@debian:/usr/share/zoneinfo$ ls -lat localtime
lrwxrwxrwx    1 root     root           14 2004-06-23 20:07 localtime -> /etc/localtime
---

The above is RED (broken link) -- '/etc/localtime' does NOT exist--
I suspect this is an install quirk!  

It is annoying because KDE seems to be happy setting my time zone and 
I've figured out that this setting appears in "/etc/timezone" --but it 
doesn't actually do much; if I run "date" (at the command line) it tells 
me my time zone is 'UTC' (which it isn't).

The way I fixed this is:
# apt-cache show timezoneconf
# dpkg-reconfigure timezoneconf

After I ran "dpkg-reconfigure timezoneconf" I found a "/etc/localtime"  
file (or rather more precisely-- a symbolic link into
"/usr/share/zoneinfo/Canada/Eastern"). 

The final step was doing a sync with the local time server:
# apt-get install ntpdate 
# ntpdate tick.utoronto.ca	
	(set time using utoronto time server)

(If it isn't there already... a nice one for the installer wish-list is 
-- asking the user if they want to sync to a local time server --and 
having a nice list of time servers to choose from).
	
-----
	
Any case, it was nice to see that the normal user I created was put 
into the group "audio" -- the sound worked without me having to 
do anything. :-)  When I first installed Debian last August, I remember 
being frustrated about the sound not working.  Later I read a couple 
of people on slashdot had the same problem... I think with the
new installer many newbies will be happy their sound works.  :-)

Cheers,
Michael



Reply to: