[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Take 3: sparc64 CDs work?

Hash: SHA1

On Saturday 05 June 2004 16:39, Joshua Kwan wrote:
> On Sat, Jun 05, 2004 at 03:21:59PM +0200, Frederik Dannemare wrote:
> > [...]
> > NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
> > Kernel panic: VFS: Unable to mount root fs on 00:00
> >  Press L1-A to return to the boot prom
> Curses!
> I'm back to having no idea... Also no idea why it worked for that one
> guy. Possibly it is a kernel bug only on some machines? That's even
> more insidious. Right now, the situation makes no sense at all, even
> less than it did before...
> A summary:
> * SILO 1.3.2 does not work with more machines than 1.4.5 breaks
> * rootfstype=ext2 fixed it for one person, indicating corruption
>   of the initrd by the FS checks
> * Ben's kernel patch did not help.
> so no rhyme or reason wrt fixes.

Today I just gave it a try with root=/dev/hda1 instead of 

This gave me the following output (thank you, minicom...):

[ ENTER - Boot install ]   [ Type "rescue" - Boot into rescue mode ]
boot: linux cdrom devfs=mount rw ramdisk_size=8192 rootfstype=ext2 
Allocated 8 Megs of memory at 0x40000000 for kernel
Loaded kernel version 2.4.26
Loading initial ramdisk (1865444 bytes at 0x0lx phys, 0x10C00000 
Remapping the kernel... done.
Booting Linux...
PROMLIB: Sun IEEE Boot Prom 3.15.2 1998/11/10 10:35
Linux version 2.4.26-sparc64 (root@june.voxel.net) (gcc version 3.3.3 
(Debian 20040404
Ethernet address: 08:00:20:a5:0d:b4
initrd extends beyond end of memory (0x0000000020dc76e4 > 
disabling initrd
On node 0 totalpages: 32118
zone(0): 32650 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Found CPU 0 (node=f006d088,mid=0)
Found 1 CPU prom device tree node(s).
Kernel command line: cdrom devfs=mount rw ramdisk_size=8192 
rootfstype=ext2 cdrom dev1
Calibrating delay loop... 665.19 BogoMIPS
Memory: 253840k available (2544k kernel code, 592k data, 184k init) 
Dentry cache hash table entries: 32768 (order: 6, 524288 bytes)
Inode cache hash table entries: 16384 (order: 5, 262144 bytes)
Mount cache hash table entries: 512 (order: 0, 8192 bytes)
Buffer cache hash table entries: 8192 (order: 3, 65536 bytes)
Page-cache hash table entries: 32768 (order: 5, 262144 bytes)
POSIX conformance testing by UNIFIX
PCI: Probing for controllers.
PCI: Found SABRE, main regs at 000001fe00000000, wsync at 
SABRE: Shared PCI config space at 000001fe01000000
SABRE: DVMA at c0000000 [20000000]
PCI-IRQ: Routing bus[ 3] slot[ 0] map[1] to INO[11]
PCI-IRQ: Routing bus[ 3] slot[ 4] map[1] to INO[10]
PCI0(PBMA): Bus running at 33MHz
PCI-IRQ: Routing bus[ 1] slot[ 1] map[0] to INO[21]
PCI-IRQ: Routing bus[ 1] slot[ 2] map[0] to INO[0f]
PCI-IRQ: Routing bus[ 1] slot[ 3] map[0] to INO[20]
PCI0(PBMB): Bus running at 33MHz
ebus0: [auxio] [power] [SUNW,pll] [se] [su] [su] [ecpp] [fdthree] 
[eeprom] [flashprom]
PCIO serial driver version 1.54
su(mouse) at 0x1fff13062f8 (irq = 4,7ea) is a 16550A
Sun Mouse-Systems mouse driver version 1.00
su(kbd) at 0x1fff13083f8 (irq = 9,7e9) is a 16550A
keyboard: not present
SAB82532 serial driver version 1.65
ttyS00 at 0x1fff1400000 (irq = 12,7eb) is a SAB82532 V3.2
ttyS01 at 0x1fff1400040 (irq = 12,7eb) is a SAB82532 V3.2
Console: ttyS0 (SAB82532)
power: Control reg at 000001fff1724000 ... powerd running.
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
VFS: Disk quotas vdquot_6.5.1
Journalled Block Device driver loaded
devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
pty: 256 Unix98 ptys configured
rtc_init: no PC rtc found
Floppy drive(s): fd0 is 1.44M
FDC 0 is a National Semiconductor PC87306
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
loop: loaded (max 8 devices)
sunhme.c:v2.01 26/Mar/2002 David S. Miller (davem@redhat.com)
eth0: HAPPY MEAL (PCI/CheerIO) 10/100BaseT Ethernet 08:00:20:a5:0d:b4
eth1: HAPPY MEAL (PCI/CheerIO) 10/100BaseT Ethernet 08:00:20:a5:0d:b4
Uniform Multi-Platform E-IDE driver Revision: 7.00beta4-2.4
ide: Assuming 33MHz system bus speed for PIO modes; override with 
CMD646: IDE controller at PCI slot 01:03.0
CMD646: chipset revision 3
CMD646: chipset revision 0x03, MultiWord DMA Force Limited
CMD646: 100% native mode on irq 4,7e0
    ide0: BM-DMA at 0x1fe02c00020-0x1fe02c00027, BIOS settings: hda:pio, 
    ide1: BM-DMA at 0x1fe02c00028-0x1fe02c0002f, BIOS settings: hdc:pio, 
hda: ST39140A, ATA DISK drive
ide: Assuming 33MHz system bus speed for PIO modes; override with 
hdc: CRD-8322B, ATAPI CD/DVD-ROM drive
ide0 at 0x1fe02c00000-0x1fe02c00007,0x1fe02c0000a on irq 4,7e0
ide1 at 0x1fe02c00010-0x1fe02c00017,0x1fe02c0001a on irq 4,7e0 (shared 
with ide0)
hda: attached ide-disk driver.
hda: 17803440 sectors (9115 MB) w/448KiB Cache, CHS=17662/16/63, (U)DMA
Partition check:
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4
SCSI subsystem driver Revision: 1.00
kmod: failed to exec /sbin/modprobe -s -k scsi_hostadapter, errno = 2
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
host/usb-uhci.c: $Revision: 1.275 $ time 01:55:34 Apr 24 2004
host/usb-uhci.c: High bandwidth mode enabled
host/usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usb.c: registered new driver usbmouse
usbmouse.c: v1.6:USB HID Boot Protocol mouse driver
usb.c: registered new driver usbkbd
usbkbd.c: :USB HID Boot Protocol keyboard driver
mice: PS/2 mouse device common for all mice
Initializing Cryptographic API
NET4: Linux TCP/IP 1.0 for NET4.0
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 32768)
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
VFS: Mounted root (ext2 filesystem).
.version 2.78 booting
Running /etc/init.d/boot
Mounting /proc device                                                 
Mounting /dev/ptsblogd: console=/dev/console, stdin=/dev/console, must 
differ, boot ld
Run file system check on root for LVM activation                      
Remounting root file system (/) read/write for vgscan...
Scanning for LVM volume groups...
modprobe: modprobe: Can't open dependencies 
file /lib/modules/2.4.26-sparc64/modules.)
vgscan -- LVM driver/module not loaded?

Activating LVM volume groups...
modprobe: modprobe: Can't open dependencies 
file /lib/modules/2.4.26-sparc64/modules.)
modprobe: modprobe: Can't open dependencies 
file /lib/modules/2.4.26-sparc64/modules.)
vgchange -- LVM driver/module not loaded?

Activating swap-devices in /etc/fstab...                              
Checking file systems...
fsck 1.24a (02-Sep-2001)
fsck.ext2: No such file or directory while trying to open /dev/hda1
The superblock could not be read or does not describe a correct ext2
filesystem.  If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate 
    e2fsck -b 8193 <device>

fsck failed.  Please repair manually and reboot. The root
file system is currently mounted read-only. To remount it
read-write do:

   bash# mount -n -o remount,rw /

Attention: Only CONTROL-D will reboot the system in this
maintanance mode. shutdown or reboot will not work.

Give root password to login:

Does this info help in any way?
- -- 
Frederik Dannemare | frederik@dannemare.net | http://dannemare.net
GnuPG key: search for 'dannemare' on http://pgpkeys.mit.edu
Key fingerprint: BB7B 078A 0DBF 7663 180A  F84A 2D25 FAD5 9C4E B5A8
Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: