[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#250360: Discover & hotplug issues

Package: installation-reports
Version: 20040513


Debian-installer-version: Netinst 100MB CD, build 20040513
Date: May 22, 2004
Method: Boot off CD, DEBCONF_PRIORITY=medium, both 2.4 and 2.6 installs

Machine: Toshiba Satellite A40
Processor: Mobile Intel Pentium 4, 2.80 GHz
Memory: 512 MB
Root Device: Hitachi Travelstar 80GN (60GB IDE)

Output of lspci and lspci -n:
(has full lspci and discover info obtained under 2.5.6 kernel)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


General report
I've bought me a new laptop, amongst others to demo Debian and to test d-i :-)
I've tried both 2.4 and 2.6 installations (with matching kernels selected for 
base system installation). Both work, but it seems I'll stick to 2.6.5 
machine because it supports the hardware somewhat better.

Installation went very well, I've X and KDE running with touchpad and sound 
working. ACPI and basic powermanagement are also working, but the system does 
not yet come up from 'standby'.

Discover issues
- Discover apparently lists i810_rng for 8086:2448, but when I modprobe
  the module I get "RNG not detected"; so this should be removed.
- Discover should list ehci-hcd for 8086:24cd.
- Why does discover not list my modem (8086:24c6)?

Also, if d-i is going to fully support 2.6 kernels, I think discover should 
distinguish between 2.4 modules en 2.6 modules.
In some cases they are different. Examples:
- 2.4 has usb-uhci, but 2.6 has uhci_hcd
- 2.4 has ehci-hcd, but 2.6 has ehci_hcd (hyphen/underscore)
- 2.4 has i810_rng, but in 2.6 this is in hw_random
- 2.4 has OSS modules for soundcards, but for 2.6 ALSA is preferred

Because of these differences, with the 2.6.5 kernel some of my hardware is not 
initialized by discover, but luckily hotplug does the job shortly afterwards. 
There seems to be a lot of overlap between the two for 2.6.5.
(With the 2.6.5 kernel for my soundcard both OSS modules (by discover) _and_ 
ALSA modules (by hotplug) are loaded automatically; seems like overkill ;-)

Hotplug issues with 2.4.26 kernel
With the 2.4.26 kernel I get:
Starting hotpug subsystem:
 [failed]   net
** can't synthesize pci hotplug events
 [failed]   usb
** can't synthesize root hub events
And nothing is actually done.

Hotplug issues with 2.6.5 kernel
With the 2.6.5 kernel, a lot of hardware is recognized, and only usb fails 
with "** can't synthesize root hub events".
A full log from the console for the hotplug stage is available at:

There are several probes that are not valid for my system. I'm not sure if 
hotplug has a 'try everything and see what fails' policy or that it should 
specifically target the hardware.
- intel-mch-agp is not the correct module for my system but loads anyway
  (with preceding error 'Unsupported Intel chipset (device id: 3580) ??? )
- modules pciehp and shpchp fail with errors
- hw_random fails with error "RNG not detected"

The end result with the 2.6.5 kernel is OK, as hotplug _does_ initialize all 
hardware that is present correctly (even the stuff that is not handled 
correctly by discover).

Reply to: