[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian-sarge grub install - SOLUTION

Hi all

i finally fixed this after much sweat and toil.

i would perhaps classify this as a bug in the installer. again, it
worked fine on my other machine just not this one. although i wouldn't
consider this machine to be an extreme case as other distros i had on
before debian worked with no problems.

anyway, for whatever reason any attempt at installing grub was not
working. it would still come up with GRUB GRUB looping infinitely on the
screen. it wasn't installing correctly in the mbr and having trouble
locating stage2.

my setup:
fstab entries:
/dev/hda1       none		(120GB)           
/dev/hda2       /               
/dev/hdd1       /backup         (80GB)
/dev/hdb1       /home           (120GB)

drive setup for hda from fdisk was as follows:

Disk /dev/hda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1         146     1172713+  82  Linux swap
/dev/hda2   *         147       14593   116045527+  83  Linux

i tried grub-install and setup from grub with their various combinations
all to no avail. finally the following worked:
root (hd0,1)
install /boot/grub/stage1 d (hd0,1)/boot/grub/stage2 p

anyway, i have also posted complete text of what i tried and failed on
linuxquestions.org at

again, i don't know if this is a bug in the installer. either way, the
above worked when nothing else would. 

now to just throw out that boot disk :).

thanks heaps to all those that helped - it made me dig further.


Reply to: