[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian-sarge grub install

Hi... my progress with this issue so far.
i've been fiddling a lot with it - still to no avail.

using debian sid (i was informed on #debian that what i had was not
sarge but sid - sorry still a newbie).

i upgraded grub to the latest 0.94 (was 0.93). no change.
i deinstalled then reinstalled. no change.

i have checked the files in /boot and /boot/grub against the other box
and they look fine.

my setup for hda is as follows - from fdisk:

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1               1         146     1172713+  82  Linux swap
/dev/hda2   *         147       14593   116045527+  83  Linux

the /boot dir is on /dev/hda2.
the correct drive is set bootable.

from grub>
grub> find /boot/grub/stage1  

so it finds everything ok.

i reinstalled from grub
grub> root (hd0,1) 
grub> setup (hd0) 
grub> quit

no change after the above

i reinstalled from a terminal
grub-install /dev/hda1
no change.

also, during the install i tried to install lilo instead - basically it
didn't let me. selecting lilo to install just went back to grub and lilo
was never installed (i do prefer grub btw).

so after huffing and puffing i still get GRUB GRUB... all over the
screen on boot. it almost seems that it can't find stage 1.5 or 2 ( or

i have deinstalled/reinstalled/updated/deleted etc... grub many many
times and still no change.

one interesting experiment was reinstalling suse and letting it write
the mbr entries. then reinstall debian, remove suse but fudge the
writing to the mbr in the debian installer. this actually worked and it
used the /boot/grub entries created by debian but the mbr was untouched
by the debian installer. i should have kept it this way i think as now i
have my system all setup and i revisisted the issue to finally fix it
using debian packages and now i'm stuffed again. currently using a boot
disk to boot into debian. i don't really want to start from scratch

anyway... any suggestions would be appreciated.


On Tue, 2004-04-20 at 21:27, Benjamin Edwards wrote: 
> Probably should not say this on this list but if this is your first
> debian install it may be better to try lilo or even use the old
> installer.  This  installer is still being developed (of course it is
> great that you are helping 'test' it). Debian is a little more difficult
> to install than some other distros but it is well worth it when you get
> a system up and running.  
> I often use the bf2.4 (with old installer) kernel and after the reboot
> modprobe the network card and put it into /etc/modules.
> I then let the installer add the apt sources and after basic install
> (if I wanted sarge) change all occurrence of stable to sarge in
> sources.list (this can be done in another console).  
> In fact as soon as I have the network up and changed sources.list I do
> a apt-get update/upgrade/dist-upgrade in another console so the rest of
> the install uses sarge.
> Ben
> --
> Ben Edwards - 2287
> >>> "Takis Diakoumis" <takisd@alphalink.com.au> 04/19/04 02:55pm >>>
> Hi 
> i'm having quite the problem with grub and booting into my system. 
> i am installing debian-sarge (27032004 release) and can't seem to get
> beyond the first reboot. 
> when i do reboot all i get is GRUB GRUB GRUB... all over the screen
> repeating infinitely so it appears to be a problem with the boot loader
> and
> its installation in the MBR (?).
> the HD setup is as follows: 
> hda - 120GB drive (/) 
> hdb - 20GB drive (/backup) 
> hdc - 80GB drive (/home) 
> i have tried different combinations including separate /boot partitions
> -
> all to no avail. 
> grub is installed on hda. 
> previously i had redhat9, mandrake9.2 and suse9 on this machine
> (individually - not mutli-boot). all of these worked fine (i've been
> weaning myself onto debian). only now when i installed debian is it
> causing
> problems. 
> i also installed the same debian distro on another machine and didn't
> have
> problems - so it must be the combination of this machine and
> debian-sarge. 
> i have checked the bios and it is booting into the correct drive. 
> i remembered a suse install bootdisk i created had a boot from hd
> option so
> i used this selecting boot from hd and only then did i get the grub
> menu
> -sequence was: boot disk -> select boot from hd -> grub menu. 
> ok, so now at a command prompt. i reinstalled grub on the mbr using: 
> grub> root (hd0,0) 
> grub> setup (hd0) 
> the above said it was successful. but it still didn't boot and came up
> with
> the same GRUB all over the screen. 
> i then cleared the MBR completely scrubbing it with zeros and then
> reinstalling grub on the machine and the MBR. still no go. 
> i searched the web for similar issues and found a few. most seemed to
> be
> related to bios LBA settings. the bios was set to autodetect the drives
> and
> always defaulted to LBA anyway. i did force LBA on it through the bios 
> -
> this didn't help either.
> i also tried installing grub with setup --force-lba (hd0) but this too
> didn't work.
> i'm stumped!! it worked fine for other distros - now its stuffed and
> all i
> get is GRUB GRUB GRUB GRUB GRUB GRUB all over my screen over and over.
> i have checked /boot/grub contents and all images/files are there and
> look
> ok. 
> if anyone has any ideas i would really appreciate it. i'm getting
> desparate
> here. i'm determined to have a debian box up and running!!
> any suggestions at all.... 
> thanks heaps... 
> Takis

Reply to: