[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#248260: (no subject)

Package: installation-reports

Debian-installer-version: <Fill in date and from where you got the image>
uname -a: <The result of running uname -a on a shell prompt>
Thu May  6 22:43:46 EEST 2004
Method: <How did you install?  What did you boot off?  If network
      install, from where?  Proxied?>
Booted from CD

Machine: Toshiba Laptop
Processor: P4
Memory: 256
Root Device: Ide
Root Size/partition table: <Feel free to paste the full partition
      table, with notes on which partitions are mounted where.>
Output of lspci:

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [E] Integrity check fails!
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


These are comments I took whilst trying to install Debian on a Polish friend's
computer, a couple of days ago. I am writing this up from poor notes, so
apologies. Polish friend is a novice, and I tried not to interfere with the


Black part in beginning is scary. (Keep it all white?)

Didn't want to use help at lilo/syslinux prompt. What for?

You should only get prompted for help if you need it. And it doesn't make sense
for novices after just booting the installer.


(It's like using PINE)


Choosing keypad after choosing Polish language results in large menu with PL preselected. A little confusing for
the novice.


What does DHCP mean? It is later explained... sort of.


Asking for IP loops. (Novice does know anything about networking)


Back eventually leads to awesome big menu.


Choosing English from language menu, automatically goes back to DHCP phase
which was inappropriate as there wasn't a network, let alone a DHCP server on
that network.


Partition resize. Can it resize fat32? Intuitively selecting cursors on size
selection results in a long pause (LVM checks?), and a prompt to change
partition. A very confusing dialogue as it doesn't tell what's it's changing.
Also "Go Back" and "No" are the same thing.


Guided partitioning does not work


Write changes before partitioning / changing size ?

Why ?


Big menu does not show the steps.

Difficult to navigate for novice.

Novice does not know dependencies. e.g. lilo vs grub

Novice does not know what has been done or what still needs to be done.
(OK/Done on menu options?)

Navigation needs to be improved.


Integrity test fails. Checked md5sum and different CDs and recording hardware.
After it fails there is no accessible option to quit install and reboot, frustratingly.

Reply to: