[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#247949: main-menu: eject command not available in installer shell

reassign 247949 debian-installer

On Fri, May 07, 2004 at 09:36:06PM +0000, Chris Tillman wrote:
> Package: main-menu
> Version: debian-installer 4/28/2004
> Severity: important
> On powerpc, the eject command is critical to be able to remove
> CDs from the computer. Many Macs are slot-based, there is no
> button on the front which will eject the CD.
> In the system I tested, where an installation had already been
> completed using Sarge CD #1 built on 4/28/2004, I was unable
> to eject the CD which had been booted in order to try another
> CD. The eject command was not available in /bin, /sbin, 
> /usr/bin, or /usr/sbin in the ramdisk system.
> eject had been installed on the target hard disk, but was not
> usable. I tried /target/usr/bin/eject from console #2, and 
> it said it couldn't unmount it. I tried unmounting it first,
> and it gave an ioctl error. I tried chrooting to /target,
> but then the cdrom mount point (ramdisk /cdrom) was 
> inaccessible. I couldn't eject the disk from the console.
> This bug is written on main-menu, because boot-floppies
> had a main menu item which called eject, and I believe
> that would be an appropriate solution to this issue.

This isn't main-menu's responsibility; individual packages provide
installer-menu-items when they're available. I think we just need to
include eject-udeb in all powerpc floppy and cdrom initrds.

> By the way, the CD should be ejected by the installer 
> before it reboots into the new system.

I thought cdrom-detect did that automatically, although
/target/usr/bin/eject would have to work. Maybe it should just depend on
eject-udeb and do it that way.

Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: