[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#247921: Installer Beta3: Reboot fails with mixed discs

Package: installation-reports

Debian-installer-version: <Beta 3 installer for i386>
uname -a: <Linux space01 2.4.25-1-386 #2 Wed Apr 14 19:38:08 EST 2004 i686 GNU/Linux>
Date: <From April 14>
Method: <Beta 3 installer, network install, from uk.debian.org direct>

Machine: <Shuttle Spacewalker HOT-649A>
Processor: Dual Pentium II 450
Memory: 768MB
Root Device: <IDE /dev/hda1>
Root Size/partition table: </dev/hda1 approx 10 percent of 20GB used
 /dev/hdc1 less than 1 percent of 80GB used, available for multimedia editing
 /dev/sda1 less than 1 percent of 70GB used, available for multimedia editing>
Output of lspci:

0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:08.0 SCSI storage controller: Adaptec AHA-2940U2/U2W / 7890/7891
0000:00:09.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 05)
0000:00:0a.0 FireWire (IEEE 1394): Texas Instruments TSB12LV23 IEEE-1394 Controller
0000:00:0b.0 Multimedia controller: Sigma Designs, Inc. REALmagic Hollywood Plus DVD Decoder (rev 02)
0000:00:0c.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
0000:01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2164W [Millennium II] AGP

Base System Installation Checklist:

Initial boot worked:    [O ]
Configure network HW:   [O ]
Config network:         [O ]
Detect CD:              [O ]
Load installer modules: [O ]
Detect hard drives:     [O ]
Partition hard drives:  [O ]
Create file systems:    [O ]
Mount partitions:       [O ]
Install base system:    [O ]
Install boot loader:    [E ]
Reboot:                 [E ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


   Please note that I am by no means an expert!

   Installer only allowed GRUB, and I was unable to install LILO. GRUB has
always failed to reboot a mixture of IDE and SCSI drives correctly when
booting from IDE because the SCSI system is not scanned until the boot
system has given up looking for SCSI devices/directories. The error message
comes from fsck.ext2 "No such device while trying to open /dev/sda1 Possibly
non-existent or swap device? fsck failed". Loading halted with an error
message, and did not continue until I had entered Ctrl D, the system then
completed the reboot with only hda1 and hdc1 available.
   I also tried putting a small /boot partition on the SCSI disc. The
motherboard can connect to narrow SE, wide SE, and wide LVD SCSI devices at
the same time, but my narrow SE scanners, backup tapes, etc, can only be
used on SCSI IDs 0 - 6, so the wide LVD SCSI disc is ID 8. I reset the BIOS
to boot from SCSI, but that also failed to reboot correctly.

   Installer did not offer the choice of UID for the first user (important
for networked systems?) and I was unable to see a way to avoid creating a
temporary normal user (then delete the temporary user, group, and all files

   I could access the internet normally and ping other machines by both IP
address and name, but when I tried to telnet or ftp to other local machines
it appeared to go through the normal login proceedure, but every attempt
just looped back and logged in to the home directory with the same name on
itself. Not understood, probably needs to be configured.

Chris Bell

Reply to: