[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#247762: hppa installation report -- hangs at "Searching for devices"

Package: installation-reports

Debian-installer-version: Sarge beta 4
Date: Thu May  6 11:37:47 PDT 2004
Method: 110MB ISO

Machine: HP Visualize B2000 workstation (hppa)
Root Device: /dev/sda

Base System Installation Checklist:

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


It was a bit tricky to get the console setting right, so I marked the 
initial boot as error.  palo guesses my sti console path and 
provides that along with a font string on the boot command line.  The font 
specification that it used (sti_font=VGA8x16) causes the machine to hang 
after the "both 64 and 32 bit kernels available, choosing 32" message.
Editing the boot string to remove the sti_font part allowed a good boot.

Here's the lspci output for my graphics card in case it matters:
0000:01:00.0 3D controller: Hewlett-Packard Company Visualize FXe (rev 03)
        Subsystem: Hewlett-Packard Company: Unknown device 108c
        Flags: bus master, 66MHz, medium devsel, latency 255, IRQ 128
        Memory at fb000000 (64-bit, prefetchable) [size=16M]
        Memory at fa000000 (64-bit, non-prefetchable) [size=16M]
        Expansion ROM at f4800000 [disabled] [size=128K]

Upon reboot the bootloader was also incorrect about my kernel location.  I 
setup a separate /boot partition like so:
/dev/sda1 38M <palo>
/dev/sda2 38M /boot
/dev/sda3 4G  /
/dev/sda4 512M <swap>

palo tried to load '2/boot/vmlinux' when it should have been '1/vmlinux'.
AIUI the kernel must be on a partition which is completely within the 
first 2G so this should be a common scenario.

The curses screens for partitioning, language selection, etc. were 
slightly broken.  Text and borders were misaligned and somewhat hard to 
read.  Hard to explain this one without a screenshot, which I can't take 
during the install process.

Finally, install via serial console doesn't seem possible -- not sure if
this is documented anywhere.



Paul Telford | 1024D/431B38BA | pxt@debian.org | paul@droflet.net
       C903 0E85 9AF5 1B80 6A5F  F169 D7E9 4363 431B 38BA

Reply to: