[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#247080: marked as done (should look for already mounted OSes too)



Your message dated Tue, 04 May 2004 21:32:02 -0400
with message-id <E1BLBGU-00037C-00@newraff.debian.org>
and subject line Bug#247080: fixed in os-prober 0.10
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 3 May 2004 06:14:25 +0000
>From wdinst@wricomp.com Sun May 02 23:14:25 2004
Return-path: <wdinst@wricomp.com>
Received: from satexas.com (rooster.satexas.com) [207.235.90.2] (root)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BKWif-0003xC-00; Sun, 02 May 2004 23:14:25 -0700
Received: from localhost (s2p3-165.world-net.net [207.71.22.165])
	by rooster.satexas.com (8.12.9p2/8.12.9) with SMTP id i436FqVs031764
	for <submit@bugs.debian.org>; Mon, 3 May 2004 01:16:10 -0500 (CDT)
	(envelope-from wdinst@wricomp.com)
From: Don Wright <wdinst@wricomp.com>
To: submit@bugs.debian.org
Subject: Install report beta4
Date: Mon, 03 May 2004 01:14:06 -0500
Message-ID: <m2nb90tj8d9cfb3gut6gmgfnh6rlnkjilb@4ax.com>
X-Mailer: Forte Agent 2.0/32.652
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
X-Scanned-By: MIMEDefang 2.39
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 
X-CrossAssassin-Score: 1

Package: installation-reports

Debian-installer-version: sarge-i386-netinst.iso (Beta4)
    Debian GNU/Linux testing "Sarge" - Official NetInst Snapshot i386
Binary-1 (20040430)

http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/i386/beta4/sarge-i386-netinst.iso

uname -a: Linux charlie 2.4.25-1-386 #2 Wed Apr 14 19:38:08 EST 2004
i586 GNU/Linux
Date: 2-May-2004
Method: CD Boot & install, default priority.

Machine: clone with PT-5VMD mobo
Processor: AMD K6-2/450
Memory: 256 MB
Root Device: 10 GB IDE primary slave (/dev/hdb)
Root Size/partition table: 
    hda1:  542.8 MB  swap
    hda2:  17.7 GB   ext3   (unused)
    hda3:  2.1 GB    fat32  (unused-should be /windows)
    hdb1:  9.5 GB    ext3   /
    hdb5:  444.1 MB  swap

Output of lspci:
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT82C598 [Apollo
MVP3] (rev 04)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo
MVP3/Pro133x AGP]
0000:00:07.0 ISA bridge: VIA Technologies, Inc. VT82C586/A/B
PCI-to-ISA [Apollo VP] (rev 47)
0000:00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev
06)
0000:00:07.2 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0
controller] (rev 02)
0000:00:07.3 Host bridge: VIA Technologies, Inc. VT82C586B ACPI (rev
10)
0000:00:09.0 Multimedia audio controller: Avance Logic Inc. ALS4000
Audio Chipset
0000:00:0a.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX
[Cyclone] (rev 64)
0000:01:00.0 VGA compatible controller: Trident Microsystems 3DImage
9750 (rev f3)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:
Grub does not detect the Windows 98 partition (/dev/hda3) when it was
mounted as /windows during the partition step, claiming Debian was the
only OS installed. Going back to the partition step and changing it to
"Do not use" allows Grub to detect the Windows 98 partition and
install it as an additional OS choice in the Grub menu.

This was tested under both Linux (2.4 kernel) and Linux26 (2.6 kernel)
installations - same result.



---------------------------------------
Received: (at 247080-close) by bugs.debian.org; 5 May 2004 01:38:02 +0000
>From katie@ftp-master.debian.org Tue May 04 18:38:02 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [208.185.25.31] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BLBMI-0007wO-00; Tue, 04 May 2004 18:38:02 -0700
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1BLBGU-00037C-00; Tue, 04 May 2004 21:32:02 -0400
From: Joey Hess <joeyh@debian.org>
To: 247080-close@bugs.debian.org
X-Katie: $Revision: 1.49 $
Subject: Bug#247080: fixed in os-prober 0.10
Message-Id: <E1BLBGU-00037C-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Tue, 04 May 2004 21:32:02 -0400
Delivered-To: 247080-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 
X-CrossAssassin-Score: 2

Source: os-prober
Source-Version: 0.10

We believe that the bug you reported is fixed in the latest version of
os-prober, which is due to be installed in the Debian FTP archive:

os-prober_0.10.dsc
  to pool/main/o/os-prober/os-prober_0.10.dsc
os-prober_0.10.tar.gz
  to pool/main/o/os-prober/os-prober_0.10.tar.gz
os-prober_0.10_i386.udeb
  to pool/main/o/os-prober/os-prober_0.10_i386.udeb



A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 247080@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Joey Hess <joeyh@debian.org> (supplier of updated os-prober package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.7
Date: Tue,  4 May 2004 20:52:29 -0400
Source: os-prober
Binary: os-prober
Architecture: source i386
Version: 0.10
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
Description: 
 os-prober  - utility to detect other OSes on a set of drives (udeb)
Closes: 246700 247080
Changes: 
 os-prober (0.10) unstable; urgency=low
 .
   * Colin Watson
     - Restore module dependencies, using debian/module-depends.$(ARCH).
       Closes: #246700
   * Joey Hess
     - Have os-prober run mounted tests on partitions that are already
       mounted (skipping /  and /target). Closes: #247080
Files: 
 4d8cbcd7a1ad30872baf9a5cb4e295ed 630 debian-installer optional os-prober_0.10.dsc
 650da382a9448a1fea5fe0c2c1665e09 9436 debian-installer optional os-prober_0.10.tar.gz
 5022a8e7a10a560da0b611e8ca8855b6 5288 debian-installer optional os-prober_0.10_i386.udeb
package-type: udeb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFAmDvc2tp5zXiKP0wRAp07AJ4iwbMfi62FJwQUWO5YXuF4NIvJfQCdFlOz
LYGHhMQqrXOT/GF5AZjcY6U=
=64+V
-----END PGP SIGNATURE-----



Reply to: