[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#246707: marked as done (Network driver stops autoloading after install)



Your message dated Mon, 3 May 2004 20:01:45 -0400
with message-id <20040504000145.GA23677@kitenet.net>
and subject line fixed
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 23 Apr 2004 14:52:38 +0000
>From era@iki.fi Fri Apr 23 07:52:38 2004
Return-path: <era@iki.fi>
Received: from rhols66.adsl.netsonic.fi (there.afraid.org) [194.29.198.66] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BH22f-0003Oe-00; Fri, 23 Apr 2004 07:52:38 -0700
Received: by there.afraid.org (Postfix, from userid 1000)
	id 8FC2F4626; Fri, 23 Apr 2004 17:52:35 +0300 (EEST)
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Dell GX270, sarge beta3 netinst credit card i386, mostly successful 
X-Debbugs-CC: era eriksson <era+debian@iki.fi>
From: era eriksson <era@iki.fi>
Message-Id: <20040423145235.8FC2F4626@there.afraid.org>
Date: Fri, 23 Apr 2004 17:52:35 +0300 (EEST)
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-10.0 required=4.0 tests=BAYES_00,HAS_PACKAGE,
	X_DEBBUGS_CC autolearn=ham version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 
X-CrossAssassin-Score: 1

Package: installation-reports
Version: +N/A; reported 2004-04-22; d-i beta3 credit card ISO
Severity: normal

INSTALL REPORT

Debian-installer-version: (see above && below)
uname -a:
Linux toad 2.4.25-1-686-smp #1 SMP Tue Feb 24 12:07:16 EST 2004 i686 GNU/Linux
Date: 2004-04-19
Method: Sarge beta3 netinst ISO burned on a CD, then proceed to http install
	(using ftp.fi.debian.org, Debian testing, no proxy)
      install, from where?  Proxied?>

Machine: Dell GX270
Processor: dual Pentium 4 (in fact shows up as 4 processors, whee :-)
Memory: 1Gb
Root Device: hda1
Root Size/partition table: hda1 all except last 500Mb for swap
Output of lspci:
0000:00:00.0 Host bridge: Intel Corp. 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
0000:00:02.0 VGA compatible controller: Intel Corp. 82865G Integrated Graphics Device (rev 02)
0000:00:1d.0 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #1 (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #2 (rev 02)
0000:00:1d.2 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #3 (rev 02)
0000:00:1d.3 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB UHCI #4 (rev 02)
0000:00:1d.7 USB Controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev c2)
0000:00:1f.0 ISA bridge: Intel Corp. 82801EB/ER (ICH5/ICH5R) LPC Bridge (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801EB/ER (ICH5/ICH5R) Ultra ATA 100 Storage Controller (rev 02)
0000:00:1f.2 IDE interface: Intel Corp. 82801EB (ICH5) Serial ATA 150 Storage Controller (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller (rev 02)
0000:01:0c.0 Ethernet controller: Intel Corp. 82540EM Gigabit Ethernet Controller (rev 02)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [!]
Config network:         [!]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [!]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [!]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:

I originally tried to install Woody but it would not even detect most
of the hardware, lspci just had a lot of "unknown blah blah" entries
instead of what you see above. I figured this would be a good time to
try the Sarge installer since presumably it would be better equipped
to deal with contemporary hardware. Generally, it worked quite nicely.

* Configure network HW: This went fine but after the reboot, it would
no longer know anything about the network card! I had to insmod e1000
by hand in order to proceed with the installation.

  wishlist item: when the installer detects hardware and gets it up
  and running, it sure would be nice if the required drivers would be
  installed permanently so that they are available after the next
  reboot also.

Also sound hardware was not correctly configured after a reboot, and
had to be added to /etc/modules by hand.

* Configure network: I'm on a network where DHCP is kind of slow,
and running on some sort of Windows server abomination. What's funny
is that if I switched over to the second virtual console and ran
dhcpclient, it would appear to work better. This could however also be
because I might have made some wrong assumptions when the DHCP client
in vt1 did in fact get a connection -- it went by so fast that I
thought it had just erroneously jumped to the next screen without
having gotten a DHCP lease. (This is something I've reconstructed
after the fact. This analysis might be wrong. I just know I bobbed
back and forth and eventually got through to where I did have a good
network connection with a DHCP-allocated IP address.)

  wishlist item: could there be a brief notification on the next
  screen where it asks for the host name, if/when it got a DHCP lease
  and in that case for which address? I don't know if this is really
  the right solution in usability terms but it would remove one
  ambiguity IMHO.

I noticed that dhclient runs on lo as well as eth0; is that useful
and/or done on purpose?

* Partition hard drives:

I have gotten into the habit of creating a minimal hda1 partition (as
small as cfdisk will allow on that particular disk; these days usually
4 or 8 Mb) and dd if=bf2.4/images-2.88/rescue.bin of=/dev/hda1 from
the Woody installation disks, just to have an easy rescue partition
for when (not if) I mess up the regular installation royally. I tried
to do that here as well, before I started the sarge installer.

I ended up thrashing back and forth in the partitioning dialogs for a
while because I would have liked to keep this setup but otherwise
proceed as normal, but in the end I gave up and simply put in a huge
single partition plus 500Mb swap at the end as suggested (or rather,
in practice, forced on me) by the installer.

I'll admit that I didn't consult the manual and didn't know exactly
what all the options in the partitioning dialog meant. I also tried
the LVM stuff because I've heard about it and would be interested to
know more, but backed out because it looked scary.

* Install base system:

I guess this must have been beaten to death, but displaying only
American time zones is something I find offensive.

  wishlist item: at least make "other" the preselected value since
  it's going to be correct for more users than any one time zone in
  America (let alone specifically the one which is preselected).

As indicated above, after reboot the network was unconfigured and I
had to enable it by hand before installation could proceed.

Ditto for sound, once I got that far, but that of course didn't harm
the installation itself.

I dropped into the shell on vt2 with alt-f2 and did modprobe e1000 and
ran dhclient by hand and then I could proceed with downloading
packages etc.

I upgraded the kernel in Aptitude and installed a lot of new packages.

  wishlist item: for those of us who would like to stay on Sarge once
  it becomes stable, would it be possible to make the default version
  to install be "sarge" rather than "testing" in apt/sources.list etc?
  I mean for prerelease betas such as this one. Or at least provide
  this as an option.

I guess comments on this are beyond the scope of this report, but I
would really really really like for X installation not to melt my
brains.

This particular system has a problem with the display card which fails
to allocate enough memory to start up in anything more than 640x480.
The fix is available as a Debian package called 865patch, download
from http://www.joepenguin.com (thanks, Joe!)

I installed Gnome but unfortunately the version in testing seems to
retain that familiar Gnome look and feel -- some parts simply don't
work, and it will crash if you click rapidly in unexpected places etc.

/* era */

-- 
formail -s procmail <http://www.iki.fi/era/spam/ >http://www.euro.cauce.org/
cat | more | cat<http://www.iki.fi/era/unix/award.html>http://www.debian.org/

---------------------------------------
Received: (at 245452-done) by bugs.debian.org; 4 May 2004 00:03:02 +0000
>From joey@kitenet.net Mon May 03 17:03:02 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [64.62.161.42] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BKnOo-0003DX-00; Mon, 03 May 2004 17:03:02 -0700
Received: from dragon.kitenet.net (216-98-94-198.access.naxs.com [216.98.94.198])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id 5533618191
	for <245452-done@bugs.debian.org>; Tue,  4 May 2004 00:03:01 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id EB6436E733; Mon,  3 May 2004 20:01:45 -0400 (EDT)
Date: Mon, 3 May 2004 20:01:45 -0400
From: Joey Hess <joeyh@debian.org>
To: 245452-done@bugs.debian.org
Subject: fixed
Message-ID: <20040504000145.GA23677@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="r5Pyd7+fXNt84Ff3"
Content-Disposition: inline
User-Agent: Mutt/1.5.5.1+cvs20040105i
Delivered-To: 245452-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-2.0 required=4.0 tests=BAYES_00 autolearn=no 
	version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 
X-CrossAssassin-Score: 1


--r5Pyd7+fXNt84Ff3
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

This was transient breakage in testing; a bad discover/discover-data
combination failed to detect any hardware. It is now fixed, we recommend
you apt-get install discover1 to fix it. Or, try a new installation with
beta4 of the debian-installer.

--=20
see shy jo

--r5Pyd7+fXNt84Ff3
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFAlt1pd8HHehbQuO8RArCZAKCXJGP2iyiQpkVWABe9hKi8VaeddwCggAO1
9JVM+BK6lMhN0b8wOSrItMo=
=SVNL
-----END PGP SIGNATURE-----

--r5Pyd7+fXNt84Ff3--



Reply to: