[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#246706: marked as done (Network driver stops autoloading after install)

Your message dated Mon, 3 May 2004 20:01:45 -0400
with message-id <20040504000145.GA23677@kitenet.net>
and subject line fixed
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 22 Apr 2004 21:05:29 +0000
>From marc@mit.edu Thu Apr 22 14:05:29 2004
Return-path: <marc@mit.edu>
Received: from pulse-plasma-gun.nerd-militia.org [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BGlNw-0007XK-00; Thu, 22 Apr 2004 14:05:29 -0700
Received: from horowitz-m1.mit.edu (unknown [])
	by pulse-plasma-gun.nerd-militia.org (Postfix) with ESMTP id 0009A4C6C2
	for <submit@bugs.debian.org>; Thu, 22 Apr 2004 17:05:26 -0400 (EDT)
Received: by horowitz-m1.mit.edu (Postfix, from userid 8888)
	id 8C7712AC6A; Thu, 22 Apr 2004 17:05:26 -0400 (EDT)
Sender: marc@mit.edu
From: Marc Horowitz <marc@mit.edu>
To: submit@bugs.debian.org
Date: 22 Apr 2004 17:05:26 -0400
Message-ID: <t53u0zbg1ux.fsf@horowitz-m1.mit.edu>
Lines: 106
User-Agent: Gnus/5.0807 (Gnus v5.8.7) Emacs/20.7
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-7.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 1

Package: installation-reports

Debian-installer-version: http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/i386/beta3/sarge-i386-businesscard.iso, 2004-04-20
uname -a: Linux quincy 2.4.25-1-386 #1 Tue Feb 24 08:11:13 EST 2004 i686 GNU/Linux
Date: 2004-04-21, around 1pm 
Method: I booted the cd image, did the normal (non-expert) install, and used http://debian.lcs.mit.edu as my install source.
Machine: Dell Dimension 4500 (Minitower)
Processor: P4 1.8ghz
Memory: 512mb
Root Device: IDE /dev/hda3
Root Size/partition table:
 Disk /dev/hda: 20.0 GB, 20000000000 bytes
 255 heads, 63 sectors/track, 2431 cylinders
 Units = cylinders of 16065 * 512 = 8225280 bytes

    Device Boot      Start         End      Blocks   Id  System
 /dev/hda1               1           4       32098+  de  Dell Utility
 /dev/hda2               5         641     5116702+   7  HPFS/NTFS (winxp pro, for dual boot, not mounted under linux)
 /dev/hda3   *         642        1133     3951990   83  Linux (mounted on /)
 /dev/hda4            1134        2431    10426185    f  W95 Ext'd (LBA)
 /dev/hda5            1134        1193      481918+  82  Linux swap
 /dev/hda6            1194        2431     9944203+  83  Linux (mounted on /u1)

Output of lspci:
 pcilib: Cannot open /sys/bus/pci/devices
 0000:00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 11)
 0000:00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 11)
 0000:00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 01)
 0000:00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 01)
 0000:00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 01)
 0000:00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 01)
 0000:00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB/ER Hub interface to PCI Bridge (rev 81)
 0000:00:1f.0 ISA bridge: Intel Corp. 82801DB (ICH4) LPC Bridge (rev 01)
 0000:00:1f.1 IDE interface: Intel Corp. 82801DB (ICH4) Ultra ATA 100 Storage Controller (rev 01)
 0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 01)
 0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)
 0000:01:00.0 VGA compatible controller: ATI Technologies Inc Rage 128 Pro Ultra TF
 0000:02:02.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


In general, the install went well.  The interface feels a lot like the
old one, which I suppose is intentional.  There were a few issues, all
after the reboot:

- There was no way to specify a local mirror.

- The system loaded pcmcia drivers, and the yenta drivers tried to
load when I rebooted.  This failed, because my machine has no pcmcia

- This is the worst one: although the installer, after booting off the
cd, correctly identified my net hardware and brought up the network
using dhcp, when the machine rebooted, it had no network, because no
ethernet driver had been added to /etc/modules.  I switched to another
desktop to get a shell, but I hadn't yet set the root pw, so I
couldn't log in.  Once I had the chance to set the root pw a few
screens later, I logged in and did modprobe 8139too; ifdown eth0; ifup
eth0 and then the network was ok.  Of course, I had to do this before
the packages for the rest of the install would download.  I had to add
8139too to /etc/modules, too.

- There is no way to tell the installer not to create a user.  My
network uses ldap, so I didn't want to create any local users.  Even
if I did, I would have wanted to choose a uid so NFS would work right,
which I couldn't do, either.  I don't expect all the various adduser
flags to be supported, but I would like to be able to skip the user
creation process entirely.

- It would be nice if I could choose which mail package to install.  I
let it install exim, then had to rip it out (it didn't even work; I'll
be filing another bug on that) and install postfix.  This isn't a big
deal, but being able to choose one would be nice.

Things I liked:

- The automatic partitioning, although I did have to manually remove
my old linux partitions.  Perhaps the installer could have an option
to overwrite an existing install.  (After all, who wants to keep
redhat around.)

- X just worked.  This is often the most finicky part of any linux
install.  I told it I had an ATI card which could do
1600x1200x24@75hz, and everything just worked.  Even better would be
if it figured this out by itself: between lspci and DPMS, it should be
possible to probe both the driver and the monitor properties in many
cases.  I think knoppix does this.

- A 26gb iso is really convenient.

Received: (at 245452-done) by bugs.debian.org; 4 May 2004 00:03:02 +0000
>From joey@kitenet.net Mon May 03 17:03:02 2004
Return-path: <joey@kitenet.net>
Received: from kitenet.net [] (postfix)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BKnOo-0003DX-00; Mon, 03 May 2004 17:03:02 -0700
Received: from dragon.kitenet.net (216-98-94-198.access.naxs.com [])
	(using TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits))
	(Client CN "Joey Hess", Issuer "Joey Hess" (verified OK))
	by kitenet.net (Postfix) with ESMTP id 5533618191
	for <245452-done@bugs.debian.org>; Tue,  4 May 2004 00:03:01 +0000 (GMT)
Received: by dragon.kitenet.net (Postfix, from userid 1000)
	id EB6436E733; Mon,  3 May 2004 20:01:45 -0400 (EDT)
Date: Mon, 3 May 2004 20:01:45 -0400
From: Joey Hess <joeyh@debian.org>
To: 245452-done@bugs.debian.org
Subject: fixed
Message-ID: <20040504000145.GA23677@kitenet.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="r5Pyd7+fXNt84Ff3"
Content-Disposition: inline
User-Agent: Mutt/
Delivered-To: 245452-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-2.0 required=4.0 tests=BAYES_00 autolearn=no 
X-CrossAssassin-Score: 1

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

This was transient breakage in testing; a bad discover/discover-data
combination failed to detect any hardware. It is now fixed, we recommend
you apt-get install discover1 to fix it. Or, try a new installation with
beta4 of the debian-installer.

see shy jo

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (GNU/Linux)



Reply to: