[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#228661: marked as done (installation-reports: beta2 bootfloppies on i386 + LVM -- LONG REPORT)



Your message dated Mon, 3 May 2004 22:18:20 +0100
with message-id <20040503211820.GA15285@deprecation.cyrius.com>
and subject line installation-reports: beta2 bootfloppies on i386 + LVM -- LONG REPORT
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--------------------------------------
Received: (at submit) by bugs.debian.org; 20 Jan 2004 01:59:15 +0000
>From giuseppe@eppesuigoccas.homedns.org Mon Jan 19 17:59:15 2004
Return-path: <giuseppe@eppesuigoccas.homedns.org>
Received: from host157-82.pool80117.interbusiness.it (eppesuigoccas.homedns.org) [80.117.82.157] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AilAg-00078W-00; Mon, 19 Jan 2004 17:59:15 -0800
Received: from giuseppe by eppesuigoccas.homedns.org with local (Exim 3.36 #1 (Debian))
	id 1AilAU-0002Un-00; Tue, 20 Jan 2004 02:59:02 +0100
Content-Type: text/plain; charset="us-ascii"
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
From: Giuseppe Sacco <giuseppe@eppesuigoccas.homedns.org>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: installation-reports: beta2 bootfloppies on i386 + LVM -- LONG REPORT
X-Mailer: reportbug 2.37
Date: Tue, 20 Jan 2004 02:59:02 +0100
Message-Id: <E1AilAU-0002Un-00@eppesuigoccas.homedns.org>
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_01_14 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=HAS_PACKAGE autolearn=no 
	version=2.60-bugs.debian.org_2004_01_14
X-Spam-Level: 

Package: installation-reports
Severity: normal

INSTALL REPORT

Debian-installer-version: daily CD image + (floppy & bootfloppy from http://www.debian.org/devel/debian-installer/)
uname -a: Linux debian 2.4.23-1-686 #1 Sun Nov 30 20:51:10 EST 2003 i686 GNU/Linux
Date: 2004-jan-19 23:30 CET
Method: bootfloppy + floppy + netinst image
Machine: Siemens Primergy 400
Processor: PentiumIII
Memory: 640Mb
Root Device: SCSI /dev/sda5
Root Size/partition table:
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1        8683     8891376    5  Extended
/dev/sda5               1        8683     8891360   83  Linux
/dev/sdb1               1        8715     8924144    5  Extended
/dev/sdb5               1        8715     8924128   83  Linux
/dev/sdc1               1       17429    17847280    5  Extended
/dev/sdc5               1         488      499680   82  Linux swap
/dev/sdc6             489       17429    17347568   83  Linux
Output of lspci:
00:00.0 Host bridge: Intel Corp. 440GX - 82443GX Host bridge
00:01.0 PCI bridge: Intel Corp. 440GX - 82443GX AGP bridge
00:02.0 System peripheral: Siemens Nixdorf AG FSC Multiprocessor Interrupt Controller (rev 02)
00:03.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
00:04.0 Class ff00: Siemens Nixdorf AG FSC Copernicus Management Controller (rev 01)
00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
02:00.0 VGA compatible controller: Cirrus Logic GD 5446 (rev 45)
02:01.0 SCSI storage controller: LSI Logic / Symbios Logic 53c895 (rev 01)
02:09.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
02:0a.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 08)
Base System Installation Checklist:

Initial boot worked:    [O] (bootfloppy)
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Comments/Problems:

The machine did not boot from CDROM because of BIOS settings and couldn't
change it since I am still waiting for the BIOS password, so I booted
from the already installed grub, the inserted the bootfloppy and typed
that long lines

root (fd0)
kernel /linux vga=normal initrd=initrd.gz ramdisk_size=8192 root=/dev/rd/0 devfs=mount,dall rw
initrd /initrd.gz
boot

then it booted. At the choose language screen the first line was a series of ?????
I selected italian as language and it as keymap. then I sed 'no' to loading drivers
from floppy and went to a network card list. This machine has two network cards but
I do not knew either models, so I tried all of them without being lucky.

I went back to the main menu and selected 'load drivers from floppy disk' and loaded the cd
and net floppies. Then I was prompted for what network card to use as main card. Since
I had two network card I didn't know which one was eth0, so I had to random pick one.

The network cards were both recognized by the eepro100 driver, dhcp worked and I
selected a proxy. Perfect.

The SCSI controller is recognized by the ncr53c8xx driver as 53c895 Symbios.
sda is a SEAGATE ST39175LC 8683MB  (20Mb/s)
sdb is a FUJITSU MAH3091MC 8716MB  (33Mb/s)
sdc is a FUJITSU MAG3128LC 17429MB (29Mb/s)

So I decided to create only one partition per disk of type 8E (for LVM) and a swap
partition. Then I created one VG and two LV. Everything went right.

The file system were created and mounted, the base system download and installed, but when
installing the kernel package kernel-image-2.4.34-1-386 I got a fatal error.
There were no error messages in tty4 and I followed the menu to select a new kernel,
but the list only shown one (that) menu, so I selected it and press 'continue'.
It worked.

Then I tried to install lilo (since grub wouldn't work on LVM, I think), but when selecting
'install lilo' I was brought to the 'install kernel' menu. Probably it didn't really work :-(

Last few lines in tty4 were:
DEBUG: Menu item 'lilo-installer' selected
DEBUG: configure lilo-installer, status: 2
DEBUG: configure kernel-installer, status: 4
DEBUG: configure created-fstab, status: 0
DEBUG: virtual package created-fstab
info: Found kernels 'kernel-image-2.4.23-1-386'

I then decided to restart the installation without LVM. I went back to 'partition a hard disk'
and the system let me repartition all disks even if they were already mounted in /target!
I only changed the type of every partition to 83 (linux.)

Then I selected 'configure and mount partition'. The installer told me that the partition were
already mounted and let me select to unmount them before proceeding, but then it showed me
the list of LVM volumes instead of the new ones.

So, I went back to 'automatically partition hard drives' and it told me that it would
completely destroy all my partitions. This sentence in italian is not correctly shown:
the last letter of the uppercase string 'cancellerà' isn't shown. So I checked the
CVS for debian-installer/tools/autopartkit/debian/po/it.po and I think it is correct.
How do I check if this is missin character in the font? any other ideas?

At this point I got an error from every disk (the error says that the disk is busy and
the kernel cannot re-read the partition table) but then it started creating file system
somewhere. After creating the file system I got again the three errors (one per disk)
and a final error: cannot mount /target (already in use).

I went to tty2 and checked what was mounted, but /target wasn't mounted.

Again, I went to the partition menu for every disk and I found them without any partition.
I created one big partition on every of them, type 83, and a small swap partition on the
last one.

Then, in the 'configure and mount partition' I still found the LVM partition! So I went
once again to LVM config and select 'Remove' from VG actions, but it didn't found any VG
so I got an error.

Back to the 'configure and mount' (magically!) I got both the LVM partition and the
normal ones. I assigned the new ones to file system types and mount points.

The installer created all file systems and mounted them correctly. I had to manually
select 'install base system' and then I got the same error as above about the kernel.

In tty2, I checked the /target/boot directory and I think that the kernel is there
but the initrd file has a zero lenght. I chroot in /target and tried to install
grub. apt-get gave me an error like 'package not found', so I did check the
sources.list and found only line copy:///cdrom ...
I added a line http://... and the apt-get update. After this I was able to install
grub but got an error while processing kernel-image-2.4.23-1-386. Finally I found
the problem:

Setting up kernel-image-2.4.23-1-386 (2.4.23-1)
error reading /lib/modules/2.4.23-1-386/build: No such file ir directory
Deleting /lib/modules/2.4.23-1-386/build
/usr/sbin/mkinitrd: Cannot determine root device
Failed to create initrd image.

I found that the problem was a missing /etc/fstab (the file was there but contained
only a comment). I filled it ant then apt-get --reinstall install kernel-...
and it worked.

I then setup all required files for grub in /boot/grub.

Then I left the chroot and went back to the menu, I selected the 'install kernel'
(just to be sure) and found a lot of kernels (because I did change the sources.list
while in the chroot), so I selected kernel-image-2.4.23-1-686 and installed it.

At the end I selected 'install grub' and it worked. Then the installer ejected my
CD and proposed to reboot the machine. I selected 'continue' and the system
rebooted.

After rebooting the base-config script started but the system did not used the
network cards (/etc/network/interfaces wasn't initialized.)

Another problem I found after the reboot, while at the step 'select packages to install'
is that the text is too large and the left part isn't visible. Maybe the problem is that
in italian the sentences explaining what are tasksel, aptitude and dselect are too long.


This is one of the longest Debian installation I ever did :-(

Bye,
Giuseppe

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux casa 2.4.23-xfs #1 SMP Sun Jan 4 17:49:41 CET 2004 i686
Locale: LANG=C, LC_CTYPE=C


---------------------------------------
Received: (at 228661-done) by bugs.debian.org; 3 May 2004 21:19:09 +0000
>From tbm@cyrius.com Mon May 03 14:19:09 2004
Return-path: <tbm@cyrius.com>
Received: from sorrow.cyrius.com [65.19.161.204] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BKkqD-0005Sc-00; Mon, 03 May 2004 14:19:09 -0700
Received: by sorrow.cyrius.com (Postfix, from userid 10)
	id 7540064D50; Mon,  3 May 2004 21:18:33 +0000 (UTC)
Received: by deprecation.cyrius.com (Postfix, from userid 1000)
	id 3CE77104AB; Mon,  3 May 2004 22:18:20 +0100 (BST)
Date: Mon, 3 May 2004 22:18:20 +0100
From: Martin Michlmayr <tbm@cyrius.com>
To: 228661-done@bugs.debian.org
Subject: Re: installation-reports: beta2 bootfloppies on i386 + LVM -- LONG REPORT
Message-ID: <20040503211820.GA15285@deprecation.cyrius.com>
References: <E1AilAU-0002Un-00@eppesuigoccas.homedns.org> <20040502233347.GA26142@deprecation.cyrius.com> <1083617541.656.2.camel@localhost>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <1083617541.656.2.camel@localhost>
User-Agent: Mutt/1.5.5.1+cvs20040105i
Delivered-To: 228661-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-2.0 required=4.0 tests=BAYES_00 autolearn=no 
	version=2.60-bugs.debian.org_2004_03_25
X-Spam-Level: 
X-CrossAssassin-Score: 1

* Giuseppe Sacco <giuseppe@eppesuigoccas.homedns.org> [2004-05-03 22:52]:
> I just tried the latest image on the same machine and found a very big
> improvement in d-i. I still got a problem when installing the kernel,
> but I filed a different report so you may close this one.

Thanks for testing!
-- 
Martin Michlmayr
tbm@cyrius.com



Reply to: