[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

problems with 2.4.2x on alpha.


does anyone have working 2.4.2x kernel (preferably the latest one) with qlogic
isp1020 and dec ethernet card support? i've spent all the saturday and today's
morning trying to compile one mysalef, but failed.

for archives, here's the story: i decided to change the 2.2.20 kernel installed
with woody. i got the sources from kernel-source-2.4.26_2.4.26-1_all.deb,
checked the usual options for workstation with enhanced firewall, compiled
the kernel, installed, reboot. first surprise: the qlogic card support seems
to be broken. ok, google is my friend so after a while i got:

i've added the drivers from feral.com mentioned in that thread, checked
the new option, compiled kernel, installed, reboot. smile on my face lasted
until i've tried to login. no way, keyboard not responding. few lines over
login prompt i've found message: 
 keyboard: timeout - at keyboard not present?(f4)
how the hell could that be? the keyboard is working perfectly in 2.2.20, so
something must be bad in that new kernel. google again and voila:

using the recompiled kernel with CONFIG_ALPHA_GENERIC=y instead of
CONFIG_ALPHA_MIATA=y i was at last able to login. why does it make any
difference for keyboard support?

anyways, after a while it appeared that there's no network connection. the
drivers i've used are the same as in 2.2.20 kernel - generic dec:
CONFIG_DE4X5. ifconfig claimed that there's tx traffic but no rx at all. ok,
so i've tried the other drivers, for tulip cards (as adviced in other post on
debian-alpha) but no luck again: the system just hung with
 eth0(x): system error occured(2)
(where x is a number) spawining so fast that i could hardly follow
the text, the only cure was hard reset with poweroff button :(

quoting /usr/src/kernel-source-2.4.26/drivers/net/tulip/interrupt.c:
if (csr5 & SytemError) {
    int error = (csr5 >> 23) & 7;
        /* oops, we hit a PCI error.  The code produced corresponds
         * to the reason:
         *  0 - parity error
         *  1 - master abort
         *  2 - target abort
         * Note that on parity error, we should do a software reset
         * of the chip to get it back into a sane state (according              
         * to the 21142/3 docs that is).
         *   -- rmk
    printk(KERN_ERR "%s: (%lu) System Error occured (%d)\n",        
    dev->name, tp->nir, error);
i confess that i got no idea what 'target abort' means.

that driver seems to be confused about the ethernet card, as the final
messages after `modprobe tulip` are:
 tulip0: ***warning***: no mii transceiver found!
 eth0: digital ds21143 tulip rev 48 at 0x9000, 00:00:f8:76:60:11, irq 24
the spawning begins when i do `ifup -a`.

i've tried both, compiling the drivers into kernel and using them as modules.
no luck :( is there any fix available?

i've tried also the debian sarge installer (beta 3), but it hangs on qlogic
card detection, hence it's useless on miata platform :( is there any chance
that the feral drivers will be added to debian kernel-{source,image}-*?

my troublesome hardware:
platform string         : Digital Personal WorkStation 600au
system type             : Miata
Ethernet controller: Digital Equipment Corporation DECchip 21142/43 (rev 30)
SCSI storage controller: QLogic Corp. ISP1020 Fast-wide SCSI (rev 05)

i'd appreciate any hints allowing me run the 2.4.2x on that computer. with
net :) i'm subscribed to both lists, so please send followups there.

 use gnus, not guns!

Reply to: