[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#246841: qualified success on iBook G4

On Sat, May 01, 2004 at 08:44:51PM +0200, Giuseppe Sacco wrote:
> Il sab, 2004-05-01 alle 19:40, Jonathan Matthew ha scritto:
> > I chose manual partitioning in order to leave some space for a certain
> > proprietary operating system.  Partitioning itself worked well, but
> > when exiting the partitioner, it refused to believe that I'd created
> > the bootstrap partition.  I messed around with the size a bit, but it 
> > didn't help. I tried creating the bootstrap partition using mac-fdisk, 
> > and that didn't work either.  I eventually ignored the warning and 
> > carried on.  The message I was getting here was 
> > partman-newworld/no_newworld, not partman-newworld/wrong_size.
> > 
> > I don't know if it's possible to do this check inside the partition 
> > editor, so you don't need to write the partition table to disk before 
> > you find out you've got to go back and fix it, but that'd be nice.
> > 
> > When installing the boot loader, the same message appeared.  I started
> > a shell, chrooted into /target, mounted /proc, ran ybin, and it worked.
> > 
> > Those things aside, everything worked fine.  
> I believe this is the same as #244957 so I think that beta4 is
> uninstallable on any newworld machine. :-(

It was perfectly fine here, so no, I don't think that's the case at all.

I'd like to see the contents of the directory corresponding to that
filesystem in /var/lib/partman/devices, particularly the 'method' file.
Also, can one of you put 'set -x' at the top of
/lib/partman/finish.d/07newworld and arrange for partman's stderr to go
somewhere you can capture?

Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: