[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#246889: d-i beta4 installation report

Package: installation-reports


Debian-installer-version: 2004-05-01, http.us current netboot images
uname -a: Linux syndicate 2.4.26-1-686 #3 Sun Apr 18 21:17:21 EST 2004 i686 GNU/Linux
Date: 2004-05-01T23:00+0100
Method: Installed using PXE boot, your instructions were a bit out of date
	and I needed to write a PXE configuration file manually to pass
	the right options and load the right kernel.

Machine: HP Compaq NC4010 notebook
Processor: Pentium-M 1.5Ghz
Memory: 512MB
Root Device: IDE 40GB hda
Root Size/partition table: Used the automatic setup.

Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        4802    38572033+  83  Linux
/dev/hda2            4803        4864      498015    f  W95 Ext'd (LBA)
/dev/hda5            4803        4864      497983+  82  Linux swap

Filesystem            Size  Used Avail Use% Mounted on
/dev/hda1              37G  285M   35G   1% /
tmpfs                 236M     0  236M   0% /dev/shm

Output of lspci and lspci -n:

0000:00:00.0 Host bridge: ATI Technologies Inc: Unknown device cbb2 (rev 02)
0000:00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
0000:00:06.0 Multimedia audio controller: ALi Corporation M5451 PCI AC-Link Controller Audio Device (rev 02)
0000:00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge [Aladdin IV]
0000:00:08.0 Modem: ALi Corporation M5457 AC'97 Modem Controller
0000:00:09.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
0000:00:0b.0 CardBus bridge: O2 Micro, Inc. OZ711M1 SmartCardBus MultiMediaBay Controller (rev 20)
0000:00:0b.1 CardBus bridge: O2 Micro, Inc. OZ711M1 SmartCardBus MultiMediaBay Controller (rev 20)
0000:00:0b.2 System peripheral: O2 Micro, Inc. OZ711Mx MultiMediaBay Accelerator
0000:00:10.0 IDE interface: ALi Corporation M5229 IDE (rev c4)
0000:00:11.0 Bridge: ALi Corporation M7101 PMU
0000:00:12.0 USB Controller: NEC Corporation USB (rev 43)
0000:00:12.1 USB Controller: NEC Corporation USB (rev 43)
0000:00:12.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
0000:00:13.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5705M Gigabit Ethernet (rev 01)
0000:01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 340M

0000:00:00.0 Class 0600: 1002:cbb2 (rev 02)
0000:00:01.0 Class 0604: 1002:7010
0000:00:06.0 Class 0401: 10b9:5451 (rev 02)
0000:00:07.0 Class 0601: 10b9:1533
0000:00:08.0 Class 0703: 10b9:5457
0000:00:09.0 Class 0200: 168c:0013 (rev 01)
0000:00:0b.0 Class 0607: 1217:7114 (rev 20)
0000:00:0b.1 Class 0607: 1217:7114 (rev 20)
0000:00:0b.2 Class 0880: 1217:7110
0000:00:10.0 Class 0101: 10b9:5229 (rev c4)
0000:00:11.0 Class 0680: 10b9:7101
0000:00:12.0 Class 0c03: 1033:0035 (rev 43)
0000:00:12.1 Class 0c03: 1033:0035 (rev 43)
0000:00:12.2 Class 0c03: 1033:00e0 (rev 04)
0000:00:13.0 Class 0200: 14e4:165d (rev 01)
0000:01:05.0 Class 0300: 1002:4337

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Being a hackerish kinda guy, I tried to use the 2.6 kernel images.
Unfortunately Xu appears to have jerked his knee right into the
balls of my shiny new laptop.

The image doesn't support either the framebuffer device or network
card because he's removed the firmware!

The 2.4 kernel image didn't support the framebuffer either, I suspect
due to simple non-support but thankfully supported the network card
(not yet lobotomised) so I could install d-i using that.

After reboot, the tg3 module needed wasn't automatically loaded ...
this may have been because I unstalled unstable and Md might've
broken hotplug ... I'm not sure.

<Description of the install, in prose, and any thoughts, comments
      and ideas you had during the initial install.>

Very slick, first time I've tried d-i and I'm actually impressed.
An improvement in every way over bf, *except* for the newly
lobotomised kernels...

Modern hardware needs its firmware loaded from disk.  This is a
fact we're going to *have* to deal with, otherwise we're going to
have an installer which supports some arcane architectures like
m68k but not any modern hardware.

I know it's not your problem, but I cannot recommend d-i despite
its otherwise wonderfulness because of this.

Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.

Reply to: