[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241231: DECstation 5000/133 (mipsel) install with some problems

I just tried with beta4:

* tbm <tbm@cyrius.com> [2004-03-31 14:21]:
> I first chose the language, but it didn't ask me for the country but
> instead dropped me into main menu on "Select a keyboard layout".   Maybe

This means that keyboard selection had problems detecting the serial
console.  This is fixed.

> "Select a keyboard layout": doesn't do anything (I didn't have a
> keyboard conncted, but anyway).

Fixed, see above.

> Hardware detection: it tries to load all kind of IDE modules, but then
> skips it because the modules are not available.  In fact, it also shows me

Cosmetics only, minor bug filed.

> DHCP: normally (on installs on other machines), I get a DHCP response at
> 20%.  Here, the first thing I saw was 40%, and it got an IP at 80%...
> perhaps it should wait longer on slow machines?

Probably a race error, reported elsewhere.

> Anyway, the partition table was written, so I just went ahead with
> "Configure and mount partitions".  Again, /etc/fstab was empty.

"Fixed" by using partman.

> The install was fine, but no boot loader was installed!  I only got
> "Continue without boot loader".  I don't know why delo-installer was not
> installed at all!

It was not installed because it was not in testing... Now, colo and
delo are installed; this is a bug in libd-i which has been fixed in

> Also, kernel-image-2.4.19-r4k-kn04 was installed instead of the -r3k-kn02
> variant.  From looking at the code, I have no idea why.

Hasn't happened since.

> Also, no ttyS2 entry was added to /etc/inittab


> After the last screen when it tells me it is going to reboot, the screen
> was not cleared and all sort of funny characters appeared (some cannot be
> seen here):
> S± SIGKILL   .ng the installation                      
> P    ±  ., check that there are no       
> KN02-BA V5.7    (PC: 08019404, SP: 0812°8)in the tray.  If you made 

> Would it be possible to clear the screen or do something?

Still there.  We should clear the screen.

> During boot, I get:
>     sed: can't read MOTD: No such file or directory
> I have no idea where this is from.


> I also get:
>     INIT: open(/dev/console): Input/output error

Not there anymore.

> I also get:
>     decstation login: root
>     Login incorrect
> root cannot log in because ttyS2 is not listed in /etc/securetty.  I think


Boot from CD-ROM still doesn't work afaik.

Summary: successful installation; everything apart from the
colo/delo-installer problem works, and this problem is known and fixed
in SVN.
Martin Michlmayr

Reply to: