[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#172340: marked as done (Mostly successful installation log with feature requests)

Your message dated Thu, 29 Apr 2004 04:08:04 -0700
with message-id <20040429110804.GA1486@tara>
and subject line Done!
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 9 Dec 2002 12:11:36 +0000
>From samj@aos.net.au Mon Dec 09 06:11:35 2002
Return-path: <samj@aos.net.au>
Received: from (moe.aos.net.au) [] 
	by master.debian.org with smtp (Exim 3.12 1 (Debian))
	id 18LMl4-0000UQ-00; Mon, 09 Dec 2002 06:11:34 -0600
Received: (qmail 18332 invoked by uid 1000); 9 Dec 2002 12:11:32 -0000
Date: 9 Dec 2002 12:11:32 -0000
Message-ID: <20021209121132.18331.qmail@moe.aos.net.au>
From: samj@debian.org
Subject: Mostly successful installation log with feature requests
To: submit@bugs.debian.org
X-Mailer: bug
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=0.3 required=5.0

Package: installation-reports
Version: N/A
Severity: wishlist


Debian-installer-version: http://people.debian.org/~sjogren/d-i/local-di-sarge.iso 20021207
uname -a: Linux localhost 2.4.19-386 #1 Sun Oct 6 17:23:00 EST 2002 i686   GNU/Linux
Date: 20021209 22:30 AEST
Method: Burnt CD from ISO using Easy CD Creator, and booted successfully.
        Installed from CD.  

Machine: Mongrel white box.
Processor: AMD Duron 1200
Memory: 256Mb DDR
Root Device: 40Gb Seagate IDE ST340824A
Root Size/partition table:  

/dev/hda1	1	319	2562336		83	Linux		/
/dev/hda2	320	352	265072+		82	Linux Swap	
/dev/hda3	353	512	1285200		83	Linux		/var
/dev/hda4	513	4865	34965472+	83	Linux		/home

Output of lspci: (numeric as I'm copying these over manually)

0600 1022:700e r14
0604 1022:700f
0601 1106:0686 r40
0101 1106:0571 r06
0c03 1106:3038 r1a
0c03 1106:3038 r1a
0c05 1106:3057 r40
0401 1106:3058 r50
0200 10b7:9200 r74
0300 10de:002d r15

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E] PEBCAC?
Config network:         [E] PEBCAC?
Detect CD:              [O]
Load installer modules: [E] PEBCAC?
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


 - I noticed some errors along the way, including:

Cannot open template file /var/lib/cdebconf/templates.dat
Debian Installer Main Menu
Prompt: 1 - 4> (critital, high, medium, low)
rmdir: unable to remove '/usr/share/discover': Directory not empty


Linux IDE-SCSI emulation layer
kmod: failed to exec /sbin/modprobe -s -k nls_iso8859-1, errno = 2
kmod: failed to exec /sbin/modprobe -s -k nls_cp437, errno = 2

 - There was no default retriever so I had to answer a question that probably
   didn't need answering.

 - Had some trouble getting the network installation going (specifically,
   detecting card and installing module) but think that was PEBCAC. It's late
   and I'm tired. Thought I had an eepro100 but it was a 3c59x. I think it may
   have been broken anyway as I did try auto detection but got modprobe errors
   which I suspect is because the relevant low priority package hadn't been

 - Tried to install GRUB, but without success:

Installing GRUB failed:
chroot: cannot execute /sbin/grub-install: No such file or directory

 - Finished the installation and reboot failed:

mkdir: Cannot create directory '/target/var/log/debian-installer': No such
file or directory
postinst exited with status 256

 - No post installation happened, and as such there was no root password, etc.
   This is probably to be expected given the alpha status.

 - fstab was broken, lacking header line(s), readable formatting (with 
   spaces/tabs), and most importantly, cdrom, devfs, proc, etc. lines
   (which broke a bunch of startup scripts).

 - Feature Requests:

There were some questions I had to answer that could have had sensible 
defaults, including cdrom-retriever and low priority packages. Minimising 
the number of times we hassle the user should probably be prioritised.

Some sort of template driven auto partitioning, even if only / + swap, so 
people can at least try debian without having to understand partitioning.

Lacking XFS support. I still use ext3 usually, but I'd like to try something
new, and XFS looks like a good place to start. Any other candidates?

PCMCIA looks broken. It's probably meant to be. There were some errors on

I will, more often than I would like, want to mount a partition as an
afterthought. Usually it's /var. I'll then have to reboot to single user,
mount it manually, move the relevant files over, and remount it where it's
meant to be. fstab hacking is occasionally required too. This process could
presumably be automated during installation. Being able to automate this
process somewhat from the installer would be nice for live systems too...
ie I've just installed a new hard drive, and want to mount it as /home, but
need to copy everything over first. Where better to do it but from the

Automated Installations would be *really* handy. I'd love to see these
implemented in time for sarge... I figure this is already fairly well mapped
out and would involve some answers for installation questions, possibly a
partition template (sfdisk?), a list of packages and some reasonably sane way
of giving debconf the right answers and making it quiet. Storing this
information somewhere other than the CD (did I hear something about http?)
and allowing config to be specified (by DHCP option?) for each machine would
really make my day. Is this being discussed somewhere? Has it already been
discussed? Implemented?

Received: (at 172340-done) by bugs.debian.org; 29 Apr 2004 11:07:55 +0000
>From scott@tranzoa.com Thu Apr 29 04:07:55 2004
Return-path: <scott@tranzoa.com>
Received: from mx-2.azc.com [] 
	by spohr.debian.org with smtp (Exim 3.35 1 (Debian))
	id 1BJ9OV-0002Ah-00; Thu, 29 Apr 2004 04:07:55 -0700
Received: (qmail 27427 invoked from network); 29 Apr 2004 11:07:53 -0000
Received: from unknown (HELO tara) (
  by mx-2.azc.com with SMTP; 29 Apr 2004 11:07:53 -0000
Date: Thu, 29 Apr 2004 04:08:04 -0700
From: Scott Robinson <scott@tranzoa.com>
To: 172340-done@bugs.debian.org
Subject: Done!
Message-ID: <20040429110804.GA1486@tara>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="PNTmBPCT7hxwcZjr"
Content-Disposition: inline
User-Agent: Mutt/
Delivered-To: 172340-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-1.5 required=4.0 tests=BAYES_01 autolearn=no 
X-CrossAssassin-Score: 1

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Thanks again for your bug report!

The attached posts indicate this has actually been totally hashed through.

The report itself applies to a stone-age old version of the installer.
Furthermore, most of the wishlist is either not relevent or done.


http://quadhome.com/            - Personal webpage
http://tranzoa.net/             - Corporate webpage

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (GNU/Linux)



Reply to: