[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#245411: Debian installation-reports

Package: installation-reports

  Snapshot from 2004-04-21


uname -a: <The result of running uname -a on a shell prompt>

Date: 2004-04-22

Method: CD

Machine:     Dell Dimension 8300 Series
Processor:   Pentium 4 3.0 GHz w/ HT
Memory:      2 Gb DDR

Root Device: SATA disk #2
Root Size/partition table:
  /        119.4 Gb  ext3   primary
  swap     510 Mb    swap   logical

Output of lspci:

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O] [comment]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O] [comment] (on SATA #2)
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


* Partition hard drives
  - Is 510 MB really the largest swap partition possible!? I was
    expecting to create a swap partition of about 2-4 Gb!

* Install boot loader
  - During installation of GRUB, d-i incorrectly thought that
    Debian was the only OS on the system.  Windows is on SATA #1.
    I use want to use the BIOS to switch between boots and don't
    want GRUB on the first disk.

  - d-i then said "that I needed to install GRUB somewhere and could
    use hdn or /dev notation.  I suggest listing a couple of examples,
    since no Linux newbie would know what this means.  E.g.
      disk 1 = hd0
      disk 2 = hd1

* Reboot: Major problem.  Here's the error message:
  root (hd1,0)
   Filesystem type unknown, partition type 0xde
  kernel /boot/vmlinuz-2.4.xxx root=/dev/hde1 ro

  Error 17: Cannot mount selected partition

  A google search found fdisk/part.c, revealing that
    0xDE, "Dell Maint  ", "Dell maintenance partition"

  As I do have a Dell [see above], this makes some sense.
  However, I let d-i partition the drive for me... I don't know
  why the 0xde is showing up.

* For good measure I tried the installation more than once...  The
  first time, I was presented with an option for choosing between
  kernel 2.6.3 and 2.4.25, and I picked the former.  Second and third
  times d-i chose 2.4.25 by default, without presenting the option.
  Why would this be?  What is d-i doing?  (I want 2.6!)

* I have heard good things about Debian and am anxious to begin trying it!

Reply to: