[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#244323: Installation on Thinkpad T41

Package: installation-reports


Debian-installer-version: Beta 3
uname -a: Linux hige 2.4.26 #1 Wed Apr 14 23:24:00 EDT 2004 i686 GNU/Linux
Date: 15-Apr-2004
Method: CD netinst

Machine: Thinkpad T41
Processor: Pentium M 1.7 GHz
Memory: 512 MB
Root Device: IDE /dev/hda
Root Size/partition table:  

  hda1        Boot        Primary   NTFS              5240.96 
  hda2                    Primary   Linux XFS          301.92 /
  hda3                    Primary   Linux XFS         5999.62 /usr
  hda5                    Logical   Linux XFS          998.65 /var
  hda6                    Logical   Linux XFS        42802.43 /home
  hda7                    Logical   Linux swap        1068.32

Output of lspci:

pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Host bridge: Intel Corp. 82855PM Processor to I/O Controller (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 82855PM Processor to AGP Controller (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 01)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 01)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 01)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 01)
0000:00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 81)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 01)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 01)
0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBM (ICH4) SMBus Controller (rev 01)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 01)
0000:00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 01)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf [Radeon Mobility 9000 M9] (rev 02)
0000:02:00.0 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
0000:02:00.1 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
0000:02:01.0 Ethernet controller: Intel Corp. 82540EP Gigabit Ethernet Controller (Mobile) (rev 03)
0000:02:02.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [E]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [E]


I wanted to install XFS on my root partition.  Grub doesn't work with
that, but the installer wouldn't actually install Lilo instead.  There
were no error messages from the installing lilo step.  It just didn't
work.  So I had to execute a shell, run chroot, run liloconfig, and
then /sbin/lilo.  After that I could "Do without a bootloader" and
"Finish installation and reboot".

The default Debian mirror, ftp.us.debian.org, didn't work when
downloading drivers.  The error message was unhelpful, as I didn't
know whether there was no network, no connection to the particular
mirror, or no drivers in the mirror (it was the latter).  The old boot
floppies gave a better error.

One annoyance I found was that the partioner wouldn't reuse the
information about where partitions were mounted.  So every time I ran
through the installer, I had to tell it again that /dev/hda2 is /,

Hardware detection was, in general, quite good.  It didn't want to
load the network module (e1000) after the reboot, and I had to do that
manually.  There was a warning about e1000 when loading the drivers,
so I was on the lookout for it.

In general, a lot of things just happened automatically without even
prompting "Next".  It was somewhat disquieting, though I guess it is
OK.  Expert mode doesn't do that, so it is ok with me.

After everything was installed, the ethernet interface was
automatically configured to come up during booting, causing a long
wait if it wasn't connected.  Also, I checked the "Laptop" box in
tasksel, but it didn't install laptop-net.

In general, if it had worked, it would have been great.  The main
problem is that there weren't enough error messages when things go
wrong.  Neither the ftp.us.debian.org problem nor the Lilo problem
gave good error messages.

Reply to: