[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#243011: os-prober: installation report (beauty, but some issues)

Frans Pop wrote:
> Booting Woody fails with the following message.
>   Booting 'Debian GNU/Linux (3.0) (on /dev/hda5)'
>   root (hd0,0)
>     filesystem is ext2fs, partition type 0x83
>   kernel /boot/vmlinuz root=/dev/hda5
>   Error 15: file not found
> I think it fails because it looks for /boot/vmlinuz on /dev/hda5 while it is 
> on my boot partition, which is /dev/hda1.

It told grub the right boot partition (hd0,0), but then gage it a path
to the kernel that is not relative to that partition (/boot/vmlinuz
instead of /vmlinuz). Fixed.

> I was very surprised that for /dev/hdb8 (hd1,7) (Unstable) the GRUB on that 
> partition is chainloaded. From the entries in menu.lst, I would have expected 
> Linux to be loaded directly (like it tries to do for Woody).

I don't understand why the menu.lst would cause grub to do that, unless
grub has some special behavior when told to set its root to a partiton
containing another grub, or something like that. Very strange. Perhaps
the grub maintainer can shed some light on this.

> I have some additional entries in my current lilo.conf for backup kernel 
> versions and for memtest. These were not included in the new GRUB menu. This 
> means, if I had installed GRUB on /dev/hda, I would have lost these entries.

Something went wrong, you should have gotten those entries. When I run
the probe manually on your lilo.conf (after touching all the files in
/boot), I get this:

root:/home/joey/src/d-i/packages/os-prober/linux-boot-probes/mounted/i386>./50lilo /dev/hda5 /dev/hda1 /
/dev/hda5:/dev/hda1:Linux:/boot/vmlinuz::root=/dev/hda5 ro hdc=ide-scsi
/dev/hda5:/dev/hda1:LinuxPrevious:/boot/vmlinuz.old::root=/dev/hda5 ro hdc=ide-scsi
/dev/hda5:/dev/hda1:LinuxStable:/boot/vmlinuz.stable::root=/dev/hda5 ro hdc=ide-scsi

Note that this includes all the entries, even memtest. It looks to me
like the lilo probe failed somehow, and you got the fallback probe,
which looks only for vmlinuz files. That explains why the title of
the entry in menu.lst is "Debian GNU/Linux (3.0)" instead of the "Linux"
label from lilo.conf.

One possibility might be that it failed to mount your /boot partition
/dev/hda1 when probing /dev/hda5. The fstab parser needed to do that
might be buggy. Can you send me your /etc/fstab for /dev/hda5? Also,
grep for "linux-boot-prober" in the installed system's
/var/log/debian-installer/syslog and send me that as well.

> I ran the GRUB installation twice. This resulted in all additional entries 
> being included twice in the new GRUB menu. Probably easy to fix by cleaning 
> up before starting the probe for other OS.


> Other observations
> ==================
> As you can see in my partition list, fdisk marks /dev/hda3 as the active 
> partition. I don't understand what's happening here because lilo is installed 
> on /dev/hda (master boot record) and I am certain it boots from that!
> Lilo can't be installed on /dev/hda3 as the boot record of that partition 
> contains the win2k bootrecord. So it looks like lilo works independent of the 
> 'active partition'.
> I think a test should be run to see what happens if current lilo is on for 
> example /dev/hda5 and you install GRUB to /dev/hda. Will a new boot use the 
> old lilo or the new GRUB?
> You might need to change the active partition during GRUB installation in such
> situations (or something).

This is beyond my knowledge and should probably be a bug on partman.

see shy jo

Attachment: signature.asc
Description: Digital signature

Reply to: