[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#229736: marked as done (discover hangs on closing serial port)

Your message dated Tue, 06 Apr 2004 11:14:14 +0200
with message-id <E1BAmes-0005iW-00@minerva.hungry.com>
and subject line Problem is solved
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 20 Jan 2004 20:59:03 +0000
>From sfrost@ns.snowman.net Tue Jan 20 12:59:02 2004
Return-path: <sfrost@ns.snowman.net>
Received: from snowman.net (relay.snowman.net) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Aj2xi-0000Hy-00; Tue, 20 Jan 2004 12:59:02 -0800
Received: from ns.snowman.net (ns.snowman.net [])
	by relay.snowman.net (8.12.10/8.12.10/Debian-1) with ESMTP id i0KKwVU2018952
	for <submit@bugs.debian.org>; Tue, 20 Jan 2004 15:58:31 -0500
Received: from ns.snowman.net (localhost [])
	by ns.snowman.net (8.12.10/8.12.10/Debian-5) with ESMTP id i0KKwVjY020860
	for <submit@bugs.debian.org>; Tue, 20 Jan 2004 15:58:31 -0500
Received: (from sfrost@localhost)
	by ns.snowman.net (8.12.10/8.12.10/Debian-5) id i0KKwVtD020858
	for submit@bugs.debian.org; Tue, 20 Jan 2004 15:58:31 -0500
Date: Tue, 20 Jan 2004 15:58:30 -0500
From: Stephen Frost <sfrost@snowman.net>
To: Debian Bug Tracking System <submit@bugs.debian.org>
Subject: Install Report - discover locked, boot hung
Message-ID: <20040120205830.GQ1464@ns.snowman.net>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="jiGx5cYVmJx/T6kL"
Content-Disposition: inline
X-Editor: Vim http://www.vim.org/
X-Info: http://www.snowman.net
X-Operating-System: Linux/2.4.20 (i686)
X-Uptime: 15:56:20 up 143 days, 20:34, 14 users,  load average: 0.29, 1.20, 1.07
User-Agent: Mutt/1.5.4i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_01_20 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=HAS_PACKAGE autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline

Package: installation-reports
Version: Beta2; Downloaded: 18-Jan-2004
Severity: important


	Beta2; 18-Jan-2004;

uname -a: N/A, didn't get that far
Date: 19-Jan-2004
	Booted off the netinst ISO and installed from it.

Machine: Sony Vaio PCG-FRV28
Processor: Intel Pentium 4 - 2.8Ghz
Memory: 512MB
Root Device: IDE, single disk on primary controller (/dev/hda)
Root Size/partition table:
	(From memory):
	/dev/hda1 - 5G 'recovery'
	/dev/hda2 - 10G NTFS (WinXP)
	/dev/hda3 - 128MB root
	/dev/hda4 - Extended
	  /dev/hda5 - 10G NTFS (WinXP)
	  /dev/hda6 - 3G /usr
	  /dev/hda7 - 1G /var
	  /dev/hda8 - 5G /home

Output of lspci:
	Unfortunately I havn't got it, the install didn't make it far
	enough to where I could get it off using the network.  If I can
	run it from the install CD I could hand copy it, if necessary.

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O] - only eth0 :(
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [O]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Alright, first a few bitches:
	- Waiting for DHCP to time out sucked, I know it won't work,
	  eth0 isn't even connected to anything
	- Couldn't configure my wireless card (eth1), though it did
	  appear to be detected and looked operational
	- bash on con2, for whatever reason, stops responding if you hit
	  'alt-1' by accident (like when going for alt-f1 to get back to
	  the installation), this is *very* annoying since you have to
	  restart the install to get a shell to work in, it'd be nice to
	  have a way to forcibly reset the shell or bring up another one
	  or something
	- Every other step it appears to 'detect hardware' or whatever,
	  what's with that?  I don't have a floppy on the machine but
	  every time it takes a few seconds to try and load it.

Now, the big problems:
	- discover just hung for a *long* time (>30 minutes), it was
	  called with 'modules-detect all', iirc.  This was in the
	  postinst of discover after the 'base system' had been
	  installed and it was installing 'extra components', iirc.
	  I didn't see any kernel oops or anything abnormal, and I was
	  able to kill discover off (though it just restarted and got
	  stuck at the same place).  Eventually I just hacked up the
	  postinst to act like it didn't find anything (MODULES="").
	  This got me through the rest of the install and to reboot.
	- On boot, everything looked alright except after saying
	  something like 'lp0: detected blah blah' nothing else showed
	  up.  It looked to have just hung at that point.  Maybe it
	  was trying to load up some framebuffer or maybe X is supposted
	  to start at that point?  I dunno, but I couldn't do anything,
	  none of the other consoles appeared to be up or anything.  I
	  recall being warned that there might be a problem with the
	  current X in Debian and the graphics card in my laptop (ATI
	  Radeon IGP 345M 64MB (shared)), though 4.3 (released *how*
	  long ago?) supports it.  Don't know if that's a problem here
	  or not.

	  Hope this helps, I'm thinking about trying a daily-build or
	  something.  If anyone has any comments/suggestions on things I
	  could try, I'm all ears.  I'd really like to get Debian on the
	  box, and heard d-i was starting to get pretty decent...



Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.3 (GNU/Linux)



Received: (at 217788-done) by bugs.debian.org; 6 Apr 2004 09:14:47 +0000
>From pere@gigs.hungry.com Tue Apr 06 02:14:47 2004
Return-path: <pere@gigs.hungry.com>
Received: from 217-13-7-10.dd.nextgentel.com (minerva.hungry.com) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BAmfP-00010M-00; Tue, 06 Apr 2004 02:14:47 -0700
Received: from pere by minerva.hungry.com with local (Exim 3.35 #1 (Debian))
	id 1BAmes-0005iW-00; Tue, 06 Apr 2004 11:14:14 +0200
To: 217788-done@bugs.debian.org
Subject: Problem is solved
From: Petter Reinholdtsen <pere@hungry.com>
Message-Id: <E1BAmes-0005iW-00@minerva.hungry.com>
Sender: Petter Reinholdtsen <pere@gigs.hungry.com>
Date: Tue, 06 Apr 2004 11:14:14 +0200
Delivered-To: 217788-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-1.0 required=4.0 tests=BAYES_30 autolearn=no 
X-CrossAssassin-Scores: 1

This was not an NMU, but a real upload from the maintainers CVS.

Reply to: