[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#152677: marked as done (discover: kernel 2.4.18 with RealTek RTL-8139 s/rtl8139/8139too/)

Your message dated Sat, 03 Apr 2004 11:31:29 +0200
with message-id <E1B9hUv-0003wv-00@minerva.hungry.com>
and subject line discover: no way to use one module name for kernel 2.2 and another for kernel 2.4
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 11 Jul 2002 23:35:24 +0000
>From karlheg@microsharp.com Thu Jul 11 18:35:24 2002
Return-path: <karlheg@microsharp.com>
Received: from asl.microsharp.com (juniper.intra.microsharp.com) [] 
	by master.debian.org with esmtp (Exim 3.12 1 (Debian))
	id 17SnT2-0002ej-00; Thu, 11 Jul 2002 18:35:24 -0500
Received: from juniper.intra.microsharp.com (karlheg@localhost [])
	by juniper.intra.microsharp.com (8.12.4/8.12.4/Debian-2) with ESMTP id g6BNZNSK000805
	(version=TLSv1/SSLv3 cipher=EDH-RSA-DES-CBC3-SHA bits=168 verify=FAIL);
	Thu, 11 Jul 2002 16:35:23 -0700
Received: (from karlheg@localhost)
	by juniper.intra.microsharp.com (8.12.4/8.12.4/Debian-2) id g6BNZN6G000802;
	Thu, 11 Jul 2002 16:35:23 -0700
Message-Id: <200207112335.g6BNZN6G000802@juniper.intra.microsharp.com>
Subject: discover: kernel 2.4.18 with RealTek RTL-8139 s/rtl8139/8139too/
From: "Karl M. Hegbloom" <karlheg@microsharp.com>
To: "Debian Bug Tracking System" <submit@bugs.debian.org>
X-Mailer: reportbug 1.99.40
Date: Thu, 11 Jul 2002 16:35:22 -0700
Delivered-To: submit@bugs.debian.org

Package: discover
Version: 1.5-1
Severity: normal

  Bus  0, device  11, function  0:
    Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 16).
      IRQ 10.
      Master Capable.  Latency=64.  Min Gnt=32.Max Lat=64.
      I/O at 0x6800 [0x68ff].
      Non-prefetchable 32 bit memory at 0xe0a00000 [0xe0a000ff].

 (What other info and how do I obtain it please?)

 That device is detected by "discover" as an "rtl8139".  That's
probably right for a 2.2 kernel, but for 2.4.18, there's two choices
for the 8139.  I tried to modprobe 8139cp, and it failed, but modprobe
8139too worked fine.

-- System Information
Debian Release: 3.0
Architecture: i386
Kernel: Linux juniper #1 SMP Thu May 2 13:28:57 PDT 2002 i686

Versions of packages discover depends on:
ii  ash                           0.3.8-38   NetBSD /bin/sh
ii  debconf                       1.1.11     Debian configuration management sy
ii  libc6                         2.2.5-6    GNU C Library: Shared libraries an
ii  libdiscover1                  1.5-1      hardware identification library

-- debconf information excluded

Received: (at 109763-done) by bugs.debian.org; 3 Apr 2004 09:32:02 +0000
>From pere@gigs.hungry.com Sat Apr 03 01:32:02 2004
Return-path: <pere@gigs.hungry.com>
Received: from 217-13-7-10.dd.nextgentel.com (minerva.hungry.com) [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B9hVR-0001tF-00; Sat, 03 Apr 2004 01:32:02 -0800
Received: from pere by minerva.hungry.com with local (Exim 3.35 #1 (Debian))
	id 1B9hUv-0003wv-00; Sat, 03 Apr 2004 11:31:29 +0200
To: 109763-done@bugs.debian.org
Subject: Re: discover: no way to use one module name for kernel 2.2 and another for kernel 2.4
From: Petter Reinholdtsen <pere@hungry.com>
Message-Id: <E1B9hUv-0003wv-00@minerva.hungry.com>
Sender: Petter Reinholdtsen <pere@gigs.hungry.com>
Date: Sat, 03 Apr 2004 11:31:29 +0200
Delivered-To: 109763-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=0.0 required=4.0 tests=none autolearn=no 

Version 2 of discover is now in Debian Unstable.  This problem is
fixable, as the version 2 dataformat support having kernel modules
change from kernel version to kernel version.

Because of this, I close this bug.

Reply to: