[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#231105: marked as done (Should not run several times during the installation process)

Your message dated Sat, 03 Apr 2004 01:32:04 -0500
with message-id <E1B9ehI-0007jJ-00@newraff.debian.org>
and subject line Bug#231105: fixed in ddetect 0.81
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 4 Feb 2004 13:18:28 +0000
>From aleidenf@bigpond.net.au Wed Feb 04 05:18:27 2004
Return-path: <aleidenf@bigpond.net.au>
Received: from gizmo12ps.bigpond.com [] 
	by spohr.debian.org with smtp (Exim 3.35 1 (Debian))
	id 1AoMvD-0003lE-00; Wed, 04 Feb 2004 05:18:27 -0800
Received: (qmail 30426 invoked from network); 4 Feb 2004 13:13:54 -0000
Received: from unknown (HELO psmam03.bigpond.com) (
  by gizmo12ps.bigpond.com with SMTP; 4 Feb 2004 13:13:54 -0000
Received: from cpe-144-132-189-89.nsw.bigpond.net.au ([]) by psmam03.bigpond.com(MAM REL_3_4_2 83/52009299) with SMTP id 52009299; Wed, 04 Feb 2004 23:17:54 +1000
Subject: installation-reports: sarge i386 beta2, success but severe glitches
From: Andree Leidenfrost <aleidenf@bigpond.net.au>
To: submit@bugs.debian.org
Content-Type: text/plain
Organization: private
Message-Id: <1075900673.958.63.camel@aurich.ostfriesland>
Mime-Version: 1.0
X-Mailer: Ximian Evolution 1.4.5 
Date: Thu, 05 Feb 2004 00:17:53 +1100
Content-Transfer-Encoding: 7bit
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_02_01 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=HAS_PACKAGE autolearn=no 

Package: installation-reports 
Debian-installer-version: beta2, Debian website
uname -a: whateer came with the installer, 2.4.22...
Date: 04 Feb 04, 21:00:00 GMT+11
Method: installed of 100MB CD, rest from mirror.aarnet.edu.au via ftp

Machine: home grown
Processor: AMD Athlon(tm) XP 2400+ stepping 01
Memory: 512MB
Root Device: /dev/hda2
Root Size/partition table: 
/dev/hda1 swap         1GB
/dev/hda2 /          150MB
/dev/hda3 /root      150MB
/dev/hda5 /tmp         1GB
/dev/hda6 /var         1GB
/dev/hda7 /usr         3GB
/dev/hda8 /usr/local   1GB
/dev/hda9 /home       33GB

Output of lspci (from woody):

00:00.0 Host bridge: VIA Technologies, Inc. VT8367 [KT266]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8367 [KT266 AGP]
00:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 10)
00:10.0 USB Controller: VIA Technologies, Inc. UHCI USB (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. UHCI USB (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc.: Unknown device 3104 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc.: Unknown device 3177
00:11.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. AC97 Audio Controller (rev 50)
01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4966 (rev 01)
01:00.1 Display controller: ATI Technologies Inc: Unknown device 496e (rev 01)

Base System Installation Checklist:

Initial boot worked:	[O]
Configure network HW:	[O]
Config network:		[O]
Detect CD:		[O]
Load installer modules:	[O]
Detect hard drives:	[O]
Partition hard drives:	[O]
Create file systems:	[O]
Mount partitions:	[O]
Install base system:	[O]
Install boot loader:	[O]
Reboot:			[O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Having been a Debian user for 9 years, I'm really impressed.

As far as the non-graphical installer goes: I consider it a featue not a bug - 
a graphical installer really only looks better but doesn't give additioanl
functionality or ease of use. And surely, a non-grphical installer is way more
frugal regarding resources - think people in less privileged countries.

I'll try to avoid the old hat stuff like vicious circle for apt or outdated
kernel. The things I consider most severe are makred with '*', the rest is '-'.

At the end are a few remarks regarding testing in general. Although not part
of d-i, I thought I mention them because they had a lage impact on my
installation experience...

Initial install from CD:
- 'Detecting hardware' runs *three* times all in all. Can't we bring that down
  to 1? (Maybe the fact that I don't have a floopy is responsible.)
- name server should default to gateway rather than being blank IMHO (if no DHCP)
- the hostname is being asked for twice, not good
- domain not asked for, not good
* there is no feedback during filesystem and mountpoint creation, not good
  ('Creating filesystems and mount points - please, stand by' would suffice)
* there is no possibility to do a badblock scan of the HDD, not good
- 'Installing base system' stops at 75% and finishes, cosmetic but irritating
- 'Installing extra packages' stops at 66% and finishes, cosmetic but irritating
  (less than above because quicker)
- install does not try/offer to setup Australian Telstra Bigpond cable modem via
  bpalogin (yeah, might only be me but than again not...)

After reboot:
* I get a message saying: Invalid hostname "aurich3" and some blurb - aurich3 is
  definitely a perfectly valid hostname!
- hotplug is not part of CD - I'm surprised, there's is probablt a reason, though
* lilo config should default to offering choice so that people can specifiy things
  like 'single'

After installation:
* the X windows packages are terribly outdated - there is no excuse for this!
* configuration of xserver-xfree86 should really offer 1280x1024@60 (because
  that's what I use ;-) and so do many others - better 17" TFT)
* X windows is still not working for me, I finally get a graphical screen, the
  mouse is working, *the keyboboard isn't* and I can't even boot into single mode
  to examine the situation - cf. above regarding lilo setup (yeah, I can boot the
  Installation CD in rescue mode I suppose) My system is more than a year old!
- why is gdm not part of the gnome package (I have selected gnome in dselect)?
- time is messed up
- many outdated packages: postfix 2.0.16, mozilla 1.5, xsane 0.91, X,...
- Question: Do you want set up mandb setuid man? Explanation: nothing <doh>
- had to speciify the paper size twice
and so forth...

Bottom line: Debian is truely great (tried RedHat, Mandrake, Suse) - but still
only for the initiated - not read for the average desktop user :-(
Andree Leidenfrost
Sydney - Australia

Received: (at 231105-close) by bugs.debian.org; 3 Apr 2004 06:38:02 +0000
>From katie@ftp-master.debian.org Fri Apr 02 22:38:02 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1B9en4-0007NE-00; Fri, 02 Apr 2004 22:38:02 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1B9ehI-0007jJ-00; Sat, 03 Apr 2004 01:32:04 -0500
From: Joey Hess <joeyh@debian.org>
To: 231105-close@bugs.debian.org
X-Katie: $Revision: 1.46 $
Subject: Bug#231105: fixed in ddetect 0.81
Message-Id: <E1B9ehI-0007jJ-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Sat, 03 Apr 2004 01:32:04 -0500
Delivered-To: 231105-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Source: ddetect
Source-Version: 0.81

We believe that the bug you reported is fixed in the latest version of
ddetect, which is due to be installed in the Debian FTP archive:

  to pool/main/d/ddetect/archdetect_0.81_i386.udeb
  to pool/main/d/ddetect/ddetect_0.81.dsc
  to pool/main/d/ddetect/ddetect_0.81.tar.gz
  to pool/main/d/ddetect/ethdetect_0.81_all.udeb
  to pool/main/d/ddetect/hw-detect-full_0.81_all.udeb
  to pool/main/d/ddetect/hw-detect_0.81_all.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 231105@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated ddetect package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Fri,  2 Apr 2004 00:48:06 -0500
Source: ddetect
Binary: hw-detect-full archdetect hw-detect ethdetect
Architecture: source i386 all
Version: 0.81
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 archdetect - Hardware architect detector (udeb)
 ethdetect  - Detect network hardware and load kernel drivers for it (udeb)
 hw-detect  - Detect hardware and load kernel drivers for it (udeb)
 hw-detect-full - Detect hardware and load kernel drivers for it (full version) (udeb)
Closes: 231105 239429
 ddetect (0.81) unstable; urgency=low
   * Joey Hess
     - Remove manual title setting.
     - hw-detect can now be called with a parameter that is the name of a
       debconf template. If it is, it will use that template as the title
       for the progress bar. This allows for cusomised progress bars
       during the different hardware detection steps. Of course, it's kinda a
       gyp because hw-detect still loads all the modules it can in each pass.
     - ethdetect passes a custom title, as does hw-detect-full (so do
       cdrom-detect and iso-scan). Closes: #239429, #231105
   * Updated translations:
     - Welsh (cy.po) by Dafydd Harries
     - Danish (da.po) by Claus Hindsgaul
     - German (de.po) by Alwin Meschede
     - Greek, Modern (1453-) (el.po) by Konstantinos Margaritis
     - Spanish (Castilian) (es.po) by Javier Fernández-Sanguino
     - French (fr.po) by Christian Perrier
     - Hungarian (hu.po) by VER�K István
     - Indonesian (id.po) by Parlin Imanuel Toh
     - Japanese (ja.po) by Kenshi Muto
     - Polish (pl.po) by Bartosz Fenski
     - Portuguese (pt.po) by Miguel Figueiredo
     - Russian (ru.po) by Nikolai Prokoschenko
     - Slovak (sk.po) by Peter KLFMANiK Mann
     - Swedish (sv.po) by André Dahlqvist
     - Turkish (tr.po) by Osman Yüksel
     - Ukrainian (uk.po) by Eugeniy Meshcheryakov
     - Simplified Chinese (zh_CN.po) by Carlos Z.F. Liu
 852707b33e926021c73dc9d0f29420a8 767 debian-installer standard ddetect_0.81.dsc
 40ffc095e673d348b897206c68d5c49d 66627 debian-installer standard ddetect_0.81.tar.gz
 601e00f36e6204713f40f0d673218e76 25904 debian-installer optional hw-detect_0.81_all.udeb
 1b880d04edcb86b744c4ce2bd273a436 17064 debian-installer optional ethdetect_0.81_all.udeb
 8fec763797b2cd8cf0a9ef6360959dc6 2100 debian-installer optional hw-detect-full_0.81_all.udeb
 07c64a33b18b955898a09a64ca626914 2376 debian-installer standard archdetect_0.81_i386.udeb
package-type: udeb

Version: GnuPG v1.2.4 (GNU/Linux)


Reply to: