[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#241516: install-report success (sort of) on OldWorld PowerMac

Package: installation-reports


	Date: daily for powerpc for March 30, 2004.
	Image from: <http://gluck.debian.org/cdimage/testing/sarge_d-i/powerpc/20040330/sarge-powerpc-netinst.iso>

uname -a: 
	Linux debian 2.4.25-powerpc #1 ven mar 19 19:29:26 CET 2004 ppc GNU/Linux
	March 30, 2004 between Midnight and 4AM Eastern US time.
	How did you install? BootX -- with "DEBCONF_PRIORITY=medium" -- see
step-by-step description below...
	What did you boot off? MacOS 9.2.2 via BootX with kernel and initrd.gz
from the CD with the CD in the drive
	If network install, from where? ftp.us.debian.org
	Proxied?  No

	PowerMacintosh G3 (beige minitower)
	PowerPC G3
	192 MB 
Root Device:
	IDE /dev/hdc8

Root Size/partition table:

	# mac-fdisk -l
		#                    type name                  length   base      (
size )  system
	/dev/hdc1     Apple_partition_map Apple                     63 @ 1     
   ( 31.5k)  Partition map
	/dev/hdc2        Apple_Driver_ATA Macintosh                 54 @ 64    
   ( 27.0k)  Unknown
	/dev/hdc3        Apple_Driver_ATA Macintosh                 74 @ 118   
   ( 37.0k)  Unknown
	/dev/hdc4      Apple_Driver_IOKit Macintosh                512 @ 192   
   (256.0k)  Unknown
	/dev/hdc5           Apple_Patches Patch Partition          512 @ 704   
   (256.0k)  Unknown
	/dev/hdc6               Apple_HFS MacOS                2097152 @ 1216  
   (  1.0G)  HFS (MacOS system & BootX)
	/dev/hdc7               Apple_HFS boot                 2097152 @
2098368   (  1.0G)  HFS (for later use with miboot or quik)
	/dev/hdc8         Apple_UNIX_SVR2 root                41943040 @
4195520   ( 20.0G)  Linux native (ext3)
	/dev/hdc9                    swap swap                 2097152 @
46138560  (  1.0G)  Linux swap (swap)
	/dev/hdc10             Apple_Free Extra              220199743 @
48235712  (105.0G)  Free space
	Block size=512, Number of Blocks=268435454
	DeviceType=0x0, DeviceId=0x0
	1: @ 64 for 21, type=0x701
	2: @ 118 for 34, type=0xf8ff

Output of lspci:
	# lspci
	00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
	00:10.0 Class ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
	00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II
215GT [Mach64 GT] (rev 9a)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]  manually -- my local DHCP is flakey
Detect CD:              [O]
Load installer modules: [E]  detected hardware and presented a list of
candidate modules to load.
                             This all worked OK but it seemed to want to
load the same list of modules more than once
                             at different points in the process.
Detect hard drives:     [O]
Partition hard drives:  [O]  manually -- so as not to disrupt the MacOS
partiton already on the disk.
Create file systems:    [O]
Mount partitions:       [O]  Though I had to fill in "/etc/fstab"
manually.  It did not do that automatically (see below)
Install base system:    [O]
Install boot loader:    [E]  I had to tell it not to install a
bootloader.  OldWorld PowerMacs can't handle yaboot. (see below)
Reboot:                 [E]  This was a bit tricky because it didn't
fill in /etc/fstab before re-booting (see below)


<Description of the install, in prose, and any thoughts, comments
      and ideas you had during the initial install.>

When I tried it without "DEBCONF_PRIORITY=medium" it blew up trying to
install the yaboot bootloader.

Joey Hess wrote:
> I'm suprised this didn't already work; we have an option that is
> supposed to kick in if no other bootloader installer is available. It
> should have shown up on the menu as "Continue without boot loader", or
> been automatically run.

There is a "continue without boot loader" option on the main menu,
but the main menu doesn't show up by default.  You have to ask for
it in the kernel boot options -- or wait for an error to occur. 
In any case, it wasn't obvious when or how I was supposed to
invoke "continue without...", and before I knew what was
happening, the bootloader installer had blown up in my face.

So I set priority to medium and tried again following these steps...

1) Install MacOS (8.x or 9.x) in an HFS (*not* HFS+)

2) Install BootX in that partition.

3) Get the kernel and initrd.gz from the latest nightly
build businesscard CD and put them in the appropriate
places in the system folder of the MacOS partition.  Leave
the businesscard CD in the drive.

4) Run BootX to load that kernel and ram-disk.

5) Answer questions as appropriate.

6) I told it to install the HFS filesystem kernel
module to be able to copy the new kernel to the MacOS partition
so BootX can find it for the reboot.

6) When d-i gets to that point, partition and format the disk
manually,  being careful to leave the MacOS partition intact.
I made a 20 GB root partition and a 1 GB swap partition.

7) At this point, inform d-i that I don't want it to
install a boot loader by running "Continue without..."
By doing this *before* it automatically tries to install
yaboot, I avoid that part blowing up.

8) Pick a kernel package that is appropriate to the
hardware. Such as "kernel-image-2.4.25-powerpc-pmac"

9) When it's all done with the first phase and wants to
reboot so it can run the configuration stuff, I switch to
the second virtual console and copy the kernel to the
appropriate place in the system folder of the MacOS
partition.  I also have to manually build /target/etc/fstab
because some bug prevented it from getting built automatically
during the disk partitioning and formatting section.

10) Switch back to the main console and allow it to reboot,
which will wind me up back in MacOS where I can tell BootX
about the new kernel and the location of the new root disk.

11) Let BootX load Linux.

12) Answer the configuration questions.

This is roundabout, but it worked.  I'm typing this on the
resulting installed system.

Let me know if you need anything more, such as log files...


Reply to: