[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: BIDI support in Debian Installer : help needed

On Wed, Mar 31, 2004 at 02:24:06PM -0600, Steve Langasek wrote:
> On Tue, Mar 30, 2004 at 10:04:27PM -0800, Anmar Oueja wrote:
> > Can you tell me when this version of fribidi and its patch to slang are 
> > gonna be in the Debian installer as I like to have them tested ASAP. I 
> > want to get some screen shots to get the translators motivated to get 
> > Arabic Support there ASAP :)

> > Your kind response is greatly appreciated

> Please see http://people.debian.org/~vorlon/slang/ for a
> fribidi-enabled slang udeb.  Because fribidi is *not* enabled in the
> regular .deb, testing this library on a fully installed system requires
> unpacking the udeb by hand and loading the library (probably with
> LD_LIBRARY_PATH=./unpacked-slang/lib/).

> This udeb can't be uploaded to unstable until there is also a udeb
> available for libfribidi0.

... it also can't be uploaded until it actually works.

Testing with 

 LC_ALL=he_IL LD_LIBRARY_PATH=./debian/slang1a-utf8-udeb/lib apt-get install geneweb

I see that the debconf backend is crashing.  Actually, it crashes
without the LC_ALL, too.

Without the LD_LIBRARY_PATH, or pointing to the non-fribidi enabled lib,
package configuration proceeds as normal.

The packaging at that site should be reasonably correct now for
providing a fribidi-enabled udeb with a fribidiless deb, but it looks
like the fribidi patch to the slang source still needs some attention.

Steve Langasek
postmodern programmer

Attachment: signature.asc
Description: Digital signature

Reply to: