[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#224658: marked as done ("An error occurred" is not an acceptable message)

Your message dated Sat, 20 Mar 2004 13:24:11 -0800
with message-id <20040320212411.GA1616@triplehelix.org>
and subject line Closing bugs
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 20 Dec 2003 18:06:08 +0000
>From tbm@cyrius.com Sat Dec 20 12:05:59 2003
Return-path: <tbm@cyrius.com>
Received: from bangpath.uucico.de [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AXl0u-0000cq-00; Sat, 20 Dec 2003 11:35:40 -0600
Received: by bangpath.uucico.de (Postfix, from userid 10)
	id 873EE26B27; Sat, 20 Dec 2003 18:35:39 +0100 (CET)
Received: by deprecation.cyrius.com (Postfix, from userid 1000)
	id 0B6B0FEAE; Sat, 20 Dec 2003 18:33:56 +0100 (CET)
Date: Sat, 20 Dec 2003 18:33:56 +0100
From: Martin Michlmayr <tbm@cyrius.com>
To: submit@bugs.debian.org
Subject: dhcp & lvm problems, partconf & GRUB wishlist
Message-ID: <20031220173355.GA5849@deprecation.cyrius.com>
Mime-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
User-Agent: Mutt/1.5.4i
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 
	(1.212-2003-09-23-exp) on master.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0 tests=HAS_PACKAGE autolearn=no 

Package: installation-reports


Debian-installer-version: daily built from 17-Dec-2003
sarge-i386-netinst.iso      17-Dec-2003 07:34   120M
uname -a: 2.4.22
Date: Sat Dec 20 18:07:00 CET 2003
Method: boot from IDE CD-ROM, using netinst ISO

Machine: No-name desktop PC
Processor: K6-2 400 MHz
Memory: 128 MB
Root Device: IDE, also has a SCSI CD-ROM

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Why do you ask for the debconf priority at the beginning?  I think it
should just be "high" by default and people who want something lower can
pass "DEBCONF_PRIORITY".  I guess/hope this is currently only asked for
testing, and that it will be disabled later.  I chose "high".

Apparently, it looks for DHCP automatically.  While the PC had a network
card, it was not connected anywhere.  So I got the following error:

  Configure the network using dynamic addressing (DHCP)
  An error occured and the network configuration process has been aborted.

Since I didn't chose DHCP, it would be good if a short explanation could be
offered.  What DHCP is and why we tried to use it.  Some people might not
know what DHCP is.

Since I didn't have or want a network, I wanted to choose "Detect and mount
CD-ROM" next.  However, that would show the DHCP error again.  I could only
continue after manually configuring an IP address.  Please don't assume I
want a network just because I have a network card.  Also, why is the
"manually configure network" so much further down the menu?

At some point I went into the partition a hard drive menu.  It showed me:
    <info on my hard drive>
I chose my hard drive, got into cfdisk, did my stuff and quit.  After that,
the menu was on the hard drive again.  I think it should be one menu item
further down (on "Finish" in my case, or on the 2nd hard drive if I had one).

Before formating the hard drive, I got:
    WARNING: This will destroy all data on the partitions you have assigned
    file systems to.
    Ready to create file systems and mount partitions

I told partconf to format one partition (/dev/hda1) while leaving the rest
alone (/dev/hda5 was to be mounted as /home; this was a hard drive which
had some Linux stuff on it already).  So obviously it is only going to
format _one_ partition, while mounting more than one.  It would be nice if
this warning would show me exactly which partitions it is going to format.
   Formating and mounting:
       /dev/hda1 (ext3)
   Just mounting:

(It did the right thing, though, and only formated the first partition.)

Why is LILO installed by default?  I thought the decision was to go with

After rebooting:

/etc/mailname was "(none)" even though /etc/hosts contained the name of my
machine.  Also, /etc/hostname contained "localhost" instead of the correct

The <up> key does not work in debconf to go to the last menu item.  I never
noticed this before, but this is really annoying.

No install-report.template file was in /root.


OK, then I tried another installation on the same box, this time with
debconf priority "medium".

I chose the lvm udeb, but when I wanted to create LVM partitions it told
me: The current kernel doesn't support the Logical Volume Manager.
And yes, there was no lvm-mod module anywhere.

Also, why is lvm10 used instead of lvm2?  2.4.23-1 will have the
device-mapper patch included so I hope we can switch to lvm2 then.

I chose GRUB this time; it asked me on which device I want to install it.
It gave me (hd0) as default and had some info about GRUB having a different
device schema as Linux.  Who cares?  It would be much nicer if it would
display a list of hard drives (a la partconf) and then translated it to
GRUB's name itself.

I chose reiserfs for the root partition this time.  After reboot, I saw:
    fsck.reiserfs: not found
I guess reiserfsprogs should be installed if any reiserfs partition is

Also, from LVM I got "modprobe: modprobe: Can't locate module block-major-114".
dmesg said:
    loop: loaded (max 8 devices)
    md: md driver 9.90.0 MAX_MD_DEVS=256, MD_SB_DISK=27
    modprobe: modprobe: Can't locate module block-major-114
    [repeat ~40-50 times]
    vgcan -- "/etc/lvmtab" and "/etc/lvmtab.d" succesfully created

Martin Michlmayr

Received: (at 220264-done) by bugs.debian.org; 20 Mar 2004 21:24:18 +0000
>From joshk@triplehelix.org Sat Mar 20 13:24:18 2004
Return-path: <joshk@triplehelix.org>
Received: from smtp803.mail.sc5.yahoo.com [] 
	by spohr.debian.org with smtp (Exim 3.35 1 (Debian))
	id 1B4nx4-0005gf-00; Sat, 20 Mar 2004 13:24:18 -0800
Received: from unknown (HELO triplehelix.org) (edkwan@sbcglobal.net@ with login)
  by smtp803.mail.sc5.yahoo.com with SMTP; 20 Mar 2004 21:24:12 -0000
Received: by triplehelix.org (Postfix, from userid 1000)
	id 9971F2DDC1; Sat, 20 Mar 2004 13:24:11 -0800 (PST)
Date: Sat, 20 Mar 2004 13:24:11 -0800
To: 220264-done@bugs.debian.org, 224658-done@bugs.debian.org
Subject: Closing bugs
Message-ID: <20040320212411.GA1616@triplehelix.org>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="huq684BweRXVnRxX"
Content-Disposition: inline
User-Agent: Mutt/
From: joshk@triplehelix.org (Joshua Kwan)
Delivered-To: 220264-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_12 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-2.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

This bug is surely fixed in the latest version of netcfg that's in

Joshua Kwan

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (GNU/Linux)



Reply to: