[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#220264: marked as done (netcfg-dhcp: bad error description: "An error occured")

Your message dated Sat, 20 Mar 2004 13:24:11 -0800
with message-id <20040320212411.GA1616@triplehelix.org>
and subject line Closing bugs
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 11 Nov 2003 16:44:00 +0000
>From martin@piware.de Tue Nov 11 10:43:59 2003
Return-path: <martin@piware.de>
Received: from (SpeedMailer.intranet.fbn-dd.de) [] 
	by master.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1AJbcV-0004dU-00; Tue, 11 Nov 2003 10:43:59 -0600
Received: from server1.intranet.fbn-dd.de (192-168-0-1.transfer-000.intranet.fbn-dd.de [])
	by SpeedMailer.intranet.fbn-dd.de (Postfix) with ESMTP id D81923EFF9
	for <submit@bugs.debian.org>; Tue, 11 Nov 2003 17:43:57 +0100 (CET)
Received: from localhost (localhost [])
	by server1.intranet.fbn-dd.de (8.11.2/8.11.2/SuSE Linux 8.11.1-0.5) with ESMTP id hABGhTA27938
	for <submit@bugs.debian.org>; Tue, 11 Nov 2003 17:43:29 +0100
Received: from donald.balu5 (10-28-130-200.intranet-28-130.fbn-dd.de [])
	by server1.intranet.fbn-dd.de (AvMailGate- id 27906-32CF45F1;
	Tue, 11 Nov 2003 17:42:41 +0100
Received: from martin by donald.balu5 with local (Exim 3.36 #1 (Debian))
	id 1AJbaA-0000Fu-00
	for <submit@bugs.debian.org>; Tue, 11 Nov 2003 17:41:34 +0100
Date: Tue, 11 Nov 2003 17:41:34 +0100
From: Martin Pitt <martin@piware.de>
To: submit@bugs.debian.org
Subject: d-i report: DHCP, wrong button sort order
Message-ID: <20031111164126.GA919@donald.balu5>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="k+w/mQv8wyuph6w0"
Content-Disposition: inline
User-Agent: Mutt/1.5.4i
Sender: Martin Pitt <martin@piware.de>
X-AntiVirus: OK! AntiVir MailGate Version; AVE:; VDF:
	 at server1 has not found any known virus in this email.
Delivered-To: submit@bugs.debian.org
X-Spam-Status: No, hits=-5.0 required=4.0
X-Spam-Checker-Version: SpamAssassin 2.53-bugs.debian.org_2003_11_9 (

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Package: installation-reports
Version: 2003-11-10
Severity: normal
Tags: d-i


    sarge-iso: 2003-11-10 (beta-1) (100 MB variant)
    bootfloppy-image, floppy-image, cd_drivers-image:

uname -a: Linux donald 2.6.0-test9 #1 Tue Oct 28 19:40:11 CET 2003 i686 GNU=

Date: 2003-11-11 17:00 CET

Since direct booting from the cd does not work (cf. #220048),
I used bootfloppy-image, floppy-image and loaded the cd_drivers-image.
The packages were fetched from the CD.

I have a network card, but it was not connected to anything during

Machine: handcrafted Desktop system
  Motherboard: KinetiZ 7EV-A ATX (VIA KM133 chipset)
  CD-ROM used: NEC DV-5500A (IDE)
Processor: AMD Duron 1.3 GHz
Memory: 256 MB
Root Device: IDE, /dev/hda1
Root Size/partition table:=20
  Disk /dev/discs/disc0/disc: 13.0 GB, 13010264064 bytes
  16 heads, 63 sectors/track, 25209 cylinders
  Units =3D cylinders of 1008 * 512 =3D 516096 bytes

                  Device Boot      Start         End      Blocks   Id  Syst=
em     Mount
  /dev/discs/disc0/part1   *           1        2072     1044193+  83  Linu=
x      /
  ... [the other partitions were not used]

Output of lspci:
  00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (re=
v 81)
  00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
  00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] =
(rev 40)
  00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT=
8233/A/C/VT8235 PIPC Bus Master IDE (rev 06)
  00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 1a)
  00:07.3 USB Controller: VIA Technologies, Inc. USB (rev 1a)
  00:07.4 Bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev =
  00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97=
 Audio Controller (rev 50)
  00:0b.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (re=
v 43)
  01:00.0 VGA compatible controller: nVidia Corporation NV5 [RIVA TNT2/TNT2=
 Pro] (rev 11)

Base System Installation Checklist:

Initial boot worked:    [O]

  It would be great if besides floppy-image.img and an USB stick, a
  CD-ROM would be directly supported. I had to prepare three floppies
  to install from CD-ROM which seems unnecessary to me.

Configure network HW:   [O]
Config network:         [E]

  Same DHCP problem as in #220014. DHCP was attempted, then a
  confusing error message appeared. DHCP should be attempted only once
  (see below); if it fails, then the user should be presented a note
  saying that the network must be configured manually, not just a
  confusing "an error occurred". Besides the failing DHCP breaks the
  automatic installation: presenting the main menu is really not
  necessary here.

Detect CD:              [O] DHCP

  After this step, DHCP was reattempted. This happened quite often and
  is very annoying. I marked the steps where this occurred with
  "DHCP". If DHCP did not work once, then please forget about it.

Load installer modules: [O] DHCP
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O] DHCP
Mount partitions:       [O] DHCP
Install base system:    [O] DHCP
Install boot loader:    [O] DHCP
Reboot:                 [O]
[O] =3D OK, [E] =3D Error (please elaborate below), [ ] =3D didn't try it


I noticed that the buttons in some dialogs have the wrong order. E. g.
in the "configure and mount partitions" confirmation there are three
buttons (Yes, No, Back). If I'm at the righmost button and press
Cursor-Right, I land at the leftmost button. OTOH, I can press
Cursor-Left until I'm at the middle button, but cannot get to the
leftmost one by pressing Cursor-Left. Similar problem with error
messages with just two buttons (Cursor-Left goes right and vice

I did not install GRUB since I already have one (I installed sarge on
a free partition but don't want to destroy my "actual" installed sid).
I cannot boot the new partition (hda1) with my current grub, the
kernel always panics with "cannot mount root device 03:01". Neither
root=3D/dev/hda1 nor root=3D/dev/discs/disc0/part1 works.=20

Have a nice day!

Martin Pitt                 Debian GNU/Linux Developer
martin@piware.de                      mpitt@debian.org
http://www.piware.de             http://www.debian.org

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.3 (GNU/Linux)



Received: (at 220264-done) by bugs.debian.org; 20 Mar 2004 21:24:18 +0000
>From joshk@triplehelix.org Sat Mar 20 13:24:18 2004
Return-path: <joshk@triplehelix.org>
Received: from smtp803.mail.sc5.yahoo.com [] 
	by spohr.debian.org with smtp (Exim 3.35 1 (Debian))
	id 1B4nx4-0005gf-00; Sat, 20 Mar 2004 13:24:18 -0800
Received: from unknown (HELO triplehelix.org) (edkwan@sbcglobal.net@ with login)
  by smtp803.mail.sc5.yahoo.com with SMTP; 20 Mar 2004 21:24:12 -0000
Received: by triplehelix.org (Postfix, from userid 1000)
	id 9971F2DDC1; Sat, 20 Mar 2004 13:24:11 -0800 (PST)
Date: Sat, 20 Mar 2004 13:24:11 -0800
To: 220264-done@bugs.debian.org, 224658-done@bugs.debian.org
Subject: Closing bugs
Message-ID: <20040320212411.GA1616@triplehelix.org>
Mime-Version: 1.0
Content-Type: multipart/signed; micalg=pgp-sha1;
	protocol="application/pgp-signature"; boundary="huq684BweRXVnRxX"
Content-Disposition: inline
User-Agent: Mutt/
From: joshk@triplehelix.org (Joshua Kwan)
Delivered-To: 220264-done@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_12 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-2.0 required=4.0 tests=BAYES_00 autolearn=no 

Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

This bug is surely fixed in the latest version of netcfg that's in

Joshua Kwan

Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: Digital signature
Content-Disposition: inline

Version: GnuPG v1.2.4 (GNU/Linux)



Reply to: