[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#238144: installation-reports: a few problems on powerpc (AlBook), mostly successful

Package: installation-reports


Debian-installer-version: 20030413,
uname -a: Linux cairhien 2.6.1-rc1-ben1 #1 Fri Jan 2 16:57:27 GMT 2004 ppc GNU/Linux
          (in existing system, not installed system, sorry)
Date: 2004-03-14 20:10:00
Method: netinst CD

Machine: Aluminium PowerBook G4 15"
Processor: PPC 1GHz
Memory: 512MB
Root Device: IDE, /dev/hda10
Root Size/partition table:
          #                    type name                  length   base      ( size )  system
  /dev/hda1     Apple_partition_map Apple                     63 @ 1         ( 31.5k)  Partition map
  /dev/hda2          Apple_Driver43 Macintosh                 56 @ 64        ( 28.0k)  Driver 4.3
  /dev/hda3          Apple_Driver43 Macintosh                 56 @ 120       ( 28.0k)  Driver 4.3
  /dev/hda4        Apple_Driver_ATA Macintosh                 56 @ 176       ( 28.0k)  Unknown
  /dev/hda5        Apple_Driver_ATA Macintosh                 56 @ 232       ( 28.0k)  Unknown
  /dev/hda6          Apple_FWDriver Macintosh                512 @ 288       (256.0k)  Unknown
  /dev/hda7      Apple_Driver_IOKit Macintosh                512 @ 800       (256.0k)  Unknown
  /dev/hda8           Apple_Patches Patch Partition          512 @ 1312      (256.0k)  Unknown
  /dev/hda9         Apple_Bootstrap bootstrap               1600 @ 1824      (800.0k)  NewWorld bootblock
  /dev/hda10        Apple_UNIX_SVR2 swap                 1048576 @ 3424      (512.0M)  Linux swap
  /dev/hda11        Apple_UNIX_SVR2 root                62914560 @ 1052000   ( 30.0G)  Linux native
  /dev/hda12        Apple_UNIX_SVR2 spare               27879120 @ 63966560  ( 13.3G)  Linux native
  /dev/hda13              Apple_HFS Mac OS X            25364552 @ 91845680  ( 12.1G)  HFS
  /dev/hda14             Apple_Free                            8 @ 117210232 (  4.0k)  Free space
  # I installed into /dev/hda10, without any other swap partition, and
  # left the rest alone.
Output of lspci:
  00:0b.0 Host bridge: Apple Computer Inc. UniNorth 2 AGP
  00:10.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4e50
  01:0b.0 Host bridge: Apple Computer Inc.: Unknown device 0035
  01:12.0 Network controller: Broadcom Corporation BCM94306 802.11g (rev 03)
  01:13.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
  01:17.0 Class ff00: Apple Computer Inc.: Unknown device 003e
  01:18.0 USB Controller: Apple Computer Inc.: Unknown device 003f
  01:19.0 USB Controller: Apple Computer Inc.: Unknown device 003f
  01:1a.0 USB Controller: Apple Computer Inc.: Unknown device 003f
  01:1b.0 USB Controller: NEC Corporation USB (rev 43)
  01:1b.1 USB Controller: NEC Corporation USB (rev 43)
  01:1b.2 USB Controller: NEC Corporation USB 2.0 (rev 04)
  06:0b.0 Host bridge: Apple Computer Inc.: Unknown device 0036
  06:0d.0 Class ff00: Apple Computer Inc.: Unknown device 003b
  06:0e.0 FireWire (IEEE 1394): Apple Computer Inc. UniNorth 2 FireWire (rev 81)
  06:0f.0 Ethernet controller: Apple Computer Inc. UniNorth 2 GMAC (Sun GEM) (rev 80)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]


Hardware detection was pretty good, although I got an error message
about missing ide-scsi and usb-storage modules.

Is there no way for the network configuration to figure out its hostname
from DHCP?

kbd-chooser didn't work, and segfaulted when run from tty2; I expected
this, since it's probably #234513 fixed in 0.44 and the CD only had
0.42. I can use qwerty/us without too many problems, so that wasn't a

partman couldn't recognize my partition table (partman/unknown_label). I
guess this was the bug fixed in partman 25, so I'll try a newer image as
soon as I get the chance. fdisk worked. I didn't need to change the
partition table anyway, so I just continued past that.

The partconf UI is scary if you already have an installed system. It
strongly implied that it was going to erase everything that had an
assigned filesystem, but the previous screen displayed filesystem types
for all my existing partitions as well as the new ones! Browsing
partconf bug reports and the code confirmed to my satisfaction that it
wasn't going to trash my system, but I'd really like the text to be
improved here.

yaboot-installer didn't work because libdebian-installer's
subarchitecture-checking support is broken, so I didn't get a boot
loader. Bastian Blank found the problem after I mentioned this on IRC;
yaboot-installer has removed the subarchitecture field for now.

I haven't yet tried the second stage, mostly because I forgot the runes
to make my already-installed yaboot use a different partition and
couldn't be bothered to dredge them up. :)

To summarize, the serious problems I had should all have been fixed, and
I think 20030415 should be go on powerpc, at least for newpmac.

Colin Watson                                  [cjwatson@flatline.org.uk]

Reply to: