[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#237534: inst report: lots of partman and LVM issues

Package: installation-reports


Debian-installer-version: daily sid build from 10-March-2004
uname -a: 2.4.25
Method: boot from IDE CD-ROM, using netinst ISO, installin to SCSI disk

Machine: No-name desktop PC
Processor: P2
Memory: 128 MB
Root Device: SCSI, also has a IDE CD-ROM

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [ ] Didn't ask me to configure it even two I have 2 net cards
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O] lots of partman and LVM issues
Create file systems:    [O] partman forgot my configurationo
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


OK, first I wanted to partition the hard drive.  I chose "Automatically
partition a drive", "use entire", "separate partition for $HOME".  Then I
get a menu which says:

 - finish partition and write changes
 - automatically partition
 - undo changes
 - configure lvm

Well, I just did "automatically partition" so I don't think this menu
option should be there again.  Also, the automatic partitioner did not
create a physical volume (PG) for LVM, so the "configure LVM" menu option
should not be there either.

The automatically partitinoner made good default choices, but I don't like
that it decided to use logical partitions.  If it creates 4 or less
partitions, I think only primary partitions should be used.  Instead, it

  #1 primary root
  #5 logical swap
  #6 logical /home

Anyway, I was stupid enough to try LVM (I thought it would allow me to
create a PV), but it only gave me those options:
  Volume Groups
  Logical Volmes

Obviously that failed since I didn't have any Physical Volumes.  Only later
I realized that they have to be created before choosing "configure LVM".
As I said above, this menu entry should not be there if there are no
Physical Volums.

So I choose LVM, and it tell me that it is going to write changes to the
parition before continuing.  Okay.  Then LVM fails because I have no PVs.
So I get back to that menu.  I see those 3 partitions, decide crap, I want
a PV... so I want to configure the partition myself.  I therefore select
"undo changes to partitions", but that does _nothing at all_.   (Later I
realized I could probably have gone to the /home partition, removed it and
created some new stuff; but I didn't realize that I can actually go up
there.)  Anyway, "undo changes" should not be there after the changes have
been written to disk.

Okay, I'm totally confused by now.  I cannot do LVM, undoing my partitions
doesn't undo anything, and I have no idea how to edit my partition.  So I
go to the main menu and choose "Partition disks".  Unfortunately, this
does not start from scratch and ask me if I want to do the automatic stuff
or Be A Man and do it myself... it simply shows me my existing partition.

So I decide to wipe the whole thing with cfdisk and start all over.  Here I
find those menu entries:

    Partition disks
    Partition a hard drive

Very confusing names, imho.  I figured out the former is partman and the
latter cfdisk, but this is not clear to people not familiar with d-i.

Okay, I wipe the disk with cfdisk, and select "Partition disks" again, this
time doing everything myself.  I create a root partition, but decide to say
"do not use".  I create /home, etc... okay, obviously not having a root
sucks, so I go back and say "format", "use XFS" (yeah, I felt
experimental).  When I want to format the partitions, it complains about
XFS being on the root partition, and drops me back.  I choose ext3.  Well,
anyway, I have no idea how I did it, but it simpl forgot that I wanted to
format this partition.  It said "do not use" again, even thought I told
it before to format it.  I saw this several times, so this is not just me.
It complained about "No root file system is defined".

Another thing: when I was so smart not to format my root partition (i.e.
"do not use") the menu showed "ext3" anyway.

Okay, So I have a /, swap and another partition for LVM.  For some reason,
LVM didn't see the PV, so I just ignored LVM for now and decided to go
ahead and format my root partition.  It formats root, checks swap (why does
it check swap?  This is kinda slow), and then installs base.  Okay, but I
really want LVM.  So I choose "Configure LVM" again and now it sees my PV.

So I create a Volume Group (VG).  2 annoying things:
  - this shows devfs style partition names, which so does not fit in with
    part partman showed me before.

  - 1 created one VG, only have one PV, and after creating the VG I was
    back in the "creating and configuring VG groups" menu.  Obviously I
    want to be in the next menu (LV) - I cannot add another VG anyway.

OK, let's create a Logical Volume (LV):

  - I happily type "4GB" - which partman recognizes, but LVM doesn't.
        lvcreate -- ERROR option L argument "4GB"
    Okay, I admit I should have _read_ what the screen says, but this
    feels very awkward.  LVM should recognize the same terms as partman.

  - Also, the size should default to the rest which is still available.
    I had about 6.6 GB in my VG.  So I first did 4G for home, and then
    I wanted to use the rest for scratch.  But I could not easily found
    out _exactly_ what my rest was.  I simply typed 2G, but that left
    100 megs spare.  I think the size question should default to what
    is still available on the VG.

Okay, after doing all of this, and wanting to continue, I get this "No root
file system is defined!" error again.  Again it forgot about my root, which
I had defined.  Okay, let's define it again, format it and the LVM... and
then d-i wants to install GRUB.  Obviously it remembers I installed the
base system before; but I just formated my root, so the base is gone.
well, obviously installing GRUB failed.  So I manually choose "install
base", and installed base and GRUB, and that worked.

Hmm, "install base" installs pcmcia-cs.  This is a desktop PC without

Setting up a user account still does not ask for the real name. (Bug filed
a while ago)

After boot, my LVM physical group was not found.  /etc/lvmtab was empty.

Also, I realize now that the installer never asked me to configure a
network even though I have 2 network cards.

[OK, let's start all over]

Hmm, okay, another issue.  I partition the disk, have a root, swap and one
partition for LVM.  I then configure LVM; it tells me that it has to write
the information to disk, and then happily goes on formating my root
partition.  This skips the usual check asking if you really want to lose
your data.

Oh, it does it again.  I partitioned the disk new, created a root, told it
to use ext3 and use / as mountpoint, then added swap, then a partition for
LVM.  Then I configure LVM, add a VG and some LVs, then get back to the
menu.  I tell it to use the LVs for /home and /scratch, then go to the root
to check, but it says "do not use".  I don't know why it forgets this, but
it seems pretty repeatable.

So I tell it that I really want to us this as root with ext3, go on and
this partition gets formated again.  However, it was formated already when
I chose "configure LVM".  It shouldn't be formated twice.

After reboot, my LVM file systems are again not found.  pvscan simply
doesn't find anything ("no valid physical volumes found"); /dev/sda3 is of
type 83 (Linux LVM), though.   Ohhhhh, probably because lvm10 is installed
instead of lvm2!  Doh!

Hmm, GRUB also uses a difference naming schema for partitions.  partman,
LVM and GRUB/lilo really should use the name schema.

Anyway, partman looks really cute.  There are obviously still some issues,
but that was to be expected.  One thing I felt is that the whole thing felt
rather sluggish.  After making one choice, the whole window is redrawn, and
this seems to be quite slow (and this PC isn't that old).  Also, partman
takes a while to start; but I don't know what exactly it is doing.

Thanks for all the good work.  I'm glad to see cfdisk disappear, at least
on i386 and some other architectures.

Martin Michlmayr

Reply to: