[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

raid1 installation part. successful, was: NetInst CD Image with RAID1 support


I put together a noisy config with 2 scsi disks on a dumb scsi controller
on an otherwise homebrew i386 system.

I went through the install with the image provided by

  Paul Fleischer <proguy@proguy.dk>

available at http://www.daimi.au.dk/~pg/debian/netinst-raid1.iso

I managed to set up a /target tree on lvm on raid1 on scsi, but base
install failed (could not download coreutils), and no smoke test has taken
place. See below for details.

To summarize: I found all the neccessary tools! Good work! Thank you.
It needs a bit of polishing here and there, but AFAICS nothing really





uname -a:


    booting from CDROM


Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
configure MD		[E]
configure LVM		[E}
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


boot: linux DEBCONF_PRIORITY=medium

* Choose Language (US English)
* Choose Country (Germany)
* Select a Keyboard Layout (PS/2, US_english)
* Detect and mount CD-ROM
* Load installer components
  . lvmcfg, nobootloader

  1.  I did expect sw-raid or md to show up here, but it didn't

* Detect network hardware
* Configure the network (dhcp)
* Detect hardware (disks: 2 scsi, 1 ide, cdrom ide)
* Partition a hard drive
  ide0  part1  30 MB /boot
  scsi0 part1   1 GB +
  scsi1 part1   1 GB ==> /dev/md/0
  scsi0 part2   1 GB +
  scsi1 part2   1 GB ==> /dev/md/1

* configure md

  2. "configure md" is listed _after_ "configure lvm", where I would expect
     it the other way round. Not a big deal.

  3. of course I forgot to mark partition type 'fd' and hat to go back.
     Precise error message made that easy, though. :-)
  4. it took several attempts until I found that mdadm (cat /proc/mdstat)
     had some old junk information (2 broken md devs), which would prevent
     the new partitions from showing up in the menus.

     # mdadm --stop /dev/md/0
     # mdadm --stop /dev/md/1
     fixed that.

     Of course I zeroed out the drives first and rebooted several times
     after changes in the partition tables. But heck.

  5. the first raid device was created and started to sync. Then I wanted
     to create the second device. At first it seemed that it would block on
     the sync to finish (I used to raidtools2, rather). But that proved
     wrong. I could kill the "mdadm --create ..." process and restart.
     Again it did block (blue screen, nothing moving). So I killed it again
     and issued the command on the shell:

     # mdadm --create /dev/md/1 --force -l 1 -n 2 -x 0 /dev/scsi/...target{0,1}.../part2

     which did ask me, whether I wanted to proceed, yes or no. So maybe it
     needs a "do-it-and-don't-bother-me" switch set?
  At least I got 2 raid1 devices, synced and up, both consisting of 2
  partitions on the scsi disks.

* configure lvm

  6. lvmcfg complained, that it would not find any usable partitions. Which
     is true, kind of, since none where marked 'LVM'. However, it's wrong,
     kinf of, too, since it doesn't consult /dev/md devices, it seems.
     # pvcreate -ff /dev/md/0
     # pvcreate -ff /dev/md/1

     Unfortunately, no change (I reselected "configure lvm" from the menu).
     So I went ahead to do it on the shell

     # vgcreate vg00 /dev/md/0
     # vgextend vg00 /dev/md/1

     which worked fine.

  7. creating LVOLs worked as expected

     /dev/vg00/lvol1   128 MB  /
     /dev/vg00/lvol2   256 MB  /usr
     /dev/vg00/lvol3   256 MB  /var
     /dev/vg00/lvol4   256 MB  /tmp
     /dev/vg00/lvol5   256 MB  /home

* Configure and mount partitions

  8. in addition I mounted /dev/hda1 to /boot (board cannot boot from scsi)

* Install the base system
  fails consistently "cannot download coreutils". Did delete the file in
  /target/var/cache/apt/archives, but no change. But I believe this is a
  problem with my CDRom not liking CD-RW's rather than anything else.

  No messages on vc/3 or vc/4, though.

so giving at this point.

Reply to: