[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#231083: installation-reports: sarge i386 beta2, success but severe glitches

Package: installation-reports 
Debian-installer-version: beta2, Debian website
uname -a: whateer came with the installer, 2.4.22...
Date: 04 Feb 04, 21:00:00 GMT+11
Method: installed of 100MB CD, rest from mirror.aarnet.edu.au via ftp

Machine: home grown
Processor: AMD Athlon(tm) XP 2400+ stepping 01
Memory: 512MB
Root Device: /dev/hda2
Root Size/partition table: 
/dev/hda1 swap         1GB
/dev/hda2 /          150MB
/dev/hda3 /root      150MB
/dev/hda5 /tmp         1GB
/dev/hda6 /var         1GB
/dev/hda7 /usr         3GB
/dev/hda8 /usr/local   1GB
/dev/hda9 /home       33GB

Output of lspci (from woody):

00:00.0 Host bridge: VIA Technologies, Inc. VT8367 [KT266]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8367 [KT266 AGP]
00:06.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139 (rev 10)
00:10.0 USB Controller: VIA Technologies, Inc. UHCI USB (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. UHCI USB (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. UHCI USB (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc.: Unknown device 3104 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc.: Unknown device 3177
00:11.1 IDE interface: VIA Technologies, Inc. Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. AC97 Audio Controller (rev 50)
01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 4966 (rev 01)
01:00.1 Display controller: ATI Technologies Inc: Unknown device 496e (rev 01)

Base System Installation Checklist:

Initial boot worked:	[O]
Configure network HW:	[O]
Config network:		[O]
Detect CD:		[O]
Load installer modules:	[O]
Detect hard drives:	[O]
Partition hard drives:	[O]
Create file systems:	[O]
Mount partitions:	[O]
Install base system:	[O]
Install boot loader:	[O]
Reboot:			[O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Having been a Debian user for 9 years, I'm really impressed.

As far as the non-graphical installer goes: I consider it a featue not a bug - 
a graphical installer really only looks better but doesn't give additioanl
functionality or ease of use. And surely, a non-grphical installer is way more
frugal regarding resources - think people in less privileged countries.

I'll try to avoid the old hat stuff like vicious circle for apt or outdated
kernel. The things I consider most severe are makred with '*', the rest is '-'.

At the end are a few remarks regarding testing in general. Although not part
of d-i, I thought I mention them because they had a lage impact on my
installation experience...

Initial install from CD:
- 'Detecting hardware' runs *three* times all in all. Can't we bring that down
  to 1? (Maybe the fact that I don't have a floopy is responsible.)
- name server should default to gateway rather than being blank IMHO (if no DHCP)
- the hostname is being asked for twice, not good
- domain not asked for, not good
* there is no feedback during filesystem and mountpoint creation, not good
  ('Creating filesystems and mount points - please, stand by' would suffice)
* there is no possibility to do a badblock scan of the HDD, not good
- 'Installing base system' stops at 75% and finishes, cosmetic but irritating
- 'Installing extra packages' stops at 66% and finishes, cosmetic but irritating
  (less than above because quicker)
- install does not try/offer to setup Australian Telstra Bigpond cable modem via
  bpalogin (yeah, might only be me but than again not...)

After reboot:
* I get a message saying: Invalid hostname "aurich3" and some blurb - aurich3 is
  definitely a perfectly valid hostname!
- hotplug is not part of CD - I'm surprised, there's is probablt a reason, though
* lilo config should default to offering choice so that people can specifiy things
  like 'single'

After installation:
* the X windows packages are terribly outdated - there is no excuse for this!
* configuration of xserver-xfree86 should really offer 1280x1024@60 (because
  that's what I use ;-) and so do many others - better 17" TFT)
* X windows is still not working for me, I finally get a graphical screen, the
  mouse is working, *the keyboboard isn't* and I can't even boot into single mode
  to examine the situation - cf. above regarding lilo setup (yeah, I can boot the
  Installation CD in rescue mode I suppose) My system is more than a year old!
- why is gdm not part of the gnome package (I have selected gnome in dselect)?
- time is messed up
- many outdated packages: postfix 2.0.16, mozilla 1.5, xsane 0.91, X,...
- Question: Do you want set up mandb setuid man? Explanation: nothing <doh>
- had to speciify the paper size twice
and so forth...

Bottom line: Debian is truely great (tried RedHat, Mandrake, Suse) - but still
only for the initiated - not read for the average desktop user :-(
Andree Leidenfrost
Sydney - Australia

Reply to: