[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#230933: installation-reports: 2004-02-02 IBM thinkpad X30 net install lilo failed

Package: installation-reports
Version: N/A; reported 2004-02-03
Severity: grave
Justification: renders package unusable

Debian-installer-version: <2004-02-02 netinstall.iso and businescard.iso>
uname -a: kernel version 2.4.22 
Date: 2004-02-03
Method: <How did you install?  What did you boot off?  If network
      install, from where?  Proxied?>
      Tried cd install from usb, booted, but failed to load modules

      Thereafter network install using options

      net debian-installer/framebuffer=false DEBCONF_PRIORITY=medium

Machine: IBM Thinkpad X30, no cdrom, no dvdrom, only usb boot from external usb
Processor: Pentium mobile III
Memory: 256
Root Device: IDE 
Root Size/partition table: 
    part1   ext3  46   MB  /boot
    part5   swap  503  MB
    part6   ext3  5.1  GB /
    part7   ext3  5.1  GB /home
    part8   ext3  5.1  GB /var
    part3   ext3  10.1 GB unmounted 

Output of lspci:

Base System Installation Checklist:

Initial boot worked:    [OK]
Configure network HW:   [OK]
Config network:         [OK]
Detect CD:              [NO, since external usb cdrom]
Load installer modules: [OK]
Detect hard drives:     [OK]
Partition hard drives:  [OK]
Create file systems:    [OK]
Mount partitions:       [OK]
Install base system:    [OK]
Install boot loader:    [E]
Reboot:                 [E]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Major glitch: neither grub nor lilo installed MBR OK. Trying a manual lilo like the following

chroot /targets/

showed a problem, there was not found any /vmlinuz kernel in /target/vmlinuz (file simply not existant!), neither any linux kernels installed in /targets/boot

Minor glitch:

1) It is VERY irritating to type the framebuffer=false boot option 15 times on a danish keyboard. I think this option should be default!

2) making a net-install the second - or third - time, one HAS to re-format all the nicely made ext3 filesystems under "Create Filesystems", which is very irritating also 13 times.. this is probably to a bug in the installer script, which complains about not beeing able to manke a link to /targets/bin/awk and allthe others, if they exist in beforehand. There should be a suitable test to avoid this glitch

All in all, the installation was not possible at all on the thinkpad without a cd drive. Too bad, since everything worked except the boot loader installation.

Marc Cromme marc-at-indexdata-dot-dk

Reply to: