[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

install report (success, i386+xfs) was: XFS support in d-i: netinst CD image available for download

Hi Steve,

I have successfully installed a xfs based system. Details see
below. I was very pleased with the installer image! Thanks!


Package: installation-reports


    sarge-i386-xfs-netinst.iso (20040103-22:18

uname -a:
   Linux dione 2.4.22-xfs-386 #1 Fri Jan 2 10:40:30 CST 2004 i586 GNU/Linux

    Sun Jan  4 18:16:34 CET 2004

    boot: xfs DEBCONF_PRIORITY=medium

Machine: <Description of machine (eg, IBM Thinkpad R32)>
    board:   DFI K6BV3+/66
    ide0:    IBM-DJNA-371800
    ide3:    GCR-8523B (LG cdrom)

    model name  : AMD-K6tm w/ multimedia extensions
    cpu MHz     : 200.461

    MemTotal:       321952 kB

Root Device:
    /dev/hda7 4 GB

    Filesystem    Type   1K-blocks      Used Available Use% Mounted on
    /dev/hda7      xfs     3988960    210284   3778676   6% /
    /dev/hda3     ext3     3936432    559972   3176500  15% /mnt

Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.
    Disk /dev/hda: 18.0 GB, 18042716160 bytes
    240 heads, 63 sectors/track, 2330 cylinders
    Units = cylinders of 15120 * 512 = 7741440 bytes
       Device Boot      Start         End      Blocks   Id  System
    /dev/hda2               9          49      309960   82  Linux swap
    /dev/hda7            1637        2165     3999208+  83  Linux        <== /

Output of lspci:
    00:00.0 Host bridge: VIA Technologies, Inc. VT82C598 [Apollo MVP3] (rev 04)
    00:01.0 PCI bridge: VIA Technologies, Inc. VT82C598/694x [Apollo MVP3/Pro133x AGP]
    00:07.0 ISA bridge: VIA Technologies, Inc. VT82C596 ISA [Mobile South] (rev 23)
    00:07.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev 10)
    00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 11)
    00:07.3 Host bridge: VIA Technologies, Inc. VT82C596 Power Management (rev 30)
    00:12.0 Communication controller: NetMos Technology: Unknown device 9805 (rev 01)
    00:13.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8029(AS)
    00:14.0 SCSI storage controller: LSI Logic / Symbios Logic 53c860 (rev 02)
    01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)

    00:00.0 Class 0600: 1106:0598 (rev 04)
    00:01.0 Class 0604: 1106:8598
    00:07.0 Class 0601: 1106:0596 (rev 23)
    00:07.1 Class 0101: 1106:0571 (rev 10)
    00:07.2 Class 0c03: 1106:3038 (rev 11)
    00:07.3 Class 0600: 1106:3050 (rev 30)
    00:12.0 Class 0780: 9710:9805 (rev 01)
    00:13.0 Class 0200: 10ec:8029
    00:14.0 Class 0100: 1000:0006 (rev 02)
    01:00.0 Class 0300: 10de:002d (rev 15)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [E]  mkfs.xfs -f needed
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


* Configure and mount partitions

    hda7 xfs   /
    hda2 swap

  on second attempt to format already formatted xfs partition

  error: mkfs.xfs: Use the -f option to force overwrite

  workaround: issue command on shell, redo with "leave filesystem

* xfs

  I saw "fsck.xfs not found" in the smoke test reboot, and
  thereafter. I installed xfsprogs (which were not automatically
  installed). I cannot see the error, nor can I find it in

* install a kernel:
  the correct kernel was marked as default.  

Other than that, I did have only minor problems, which are not
related to the xfs stuff, as far as I can tell:

* retrieving + verifying coreutils failed. (DMA Thing?) but could
  not be reproduced after starting over.

* installing grub on '(hd0)' hung on "probing devices" again,
  killing it. Then "exit and reboot" will fire up "installing
  lilo. This menu does not give me the choice to get out --- has
  been reported. So killed it again.

  Installed grub into /dev/hda7, but that left me with an
  unbootable system ... did it again!

  After redoing the installation a 3rd time, installing grub
  worked like a breeze. I do not believe that this was a general

* devfs
  devfs does no seem to be mounted without
  me installing and activating devfsd
  is this the way it's supposed to be?

More general things:

* grub: /boot/grub/menu.lst

  grub-update generates the menu.lst file
  --- snip ----------------------------------------------------------
    ## ## End Default Options ##
    title		Debian GNU/Linux, kernel 2.4.22-xfs-386
    root		(hd0,6)
    kernel		/boot/vmlinuz-2.4.22-xfs-386 root=/dev/hda7 ro
    initrd		/boot/initrd.img-2.4.22-xfs-386
    title		Debian GNU/Linux, kernel 2.4.22-xfs-386 (recovery mode)
    root		(hd0,6)
    kernel		/boot/vmlinuz-2.4.22-xfs-386 root=/dev/hda7 ro
    initrd		/boot/initrd.img-2.4.22-xfs-386
  --- snap -----------------------------------------------------------

  I do not see a difference between the two entries other than
  the second being announced as "recovery mode", however, it
  would not achieve that, from what I can tell. I would expect
  either an 'S' or 'single' or 'init=/bin/bash' argument in the
  kernel line of the second entry. But maybe this has been
  reported long ago.

* installing a bootloader in general:

   I would like to suggest a single menu entry (similar to woody
   installer) like so:

   + make the system bootable

     + install lilo

     + install grub

     + create a boot floppy (recommended if you do not want to
       touch the Master Boot record)

     + do nothing (I know what I'm doing)

   would that be feasible? And IMHO I would default to the boot
   floppy. But that is definitely a matter of debate.

Reply to: