[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#225307: d-i: Invalid Release file, no entry for .../Packages

Package: installation-reports
Version: unknown; see below


Debian-installer-version: 2003-12-27,
uname -a: Linux (none) 2.4.22-1-386 #9 Sat Oct 4 14:30:39 EST 2003 i686 unknown
Date: 2003-12-28, 10:50 a.m. EST
Method: booted from DVD 1

Machine: HP Omnibook 6100
Processor: Pentium III
Memory: 512 MB RAM
Root Device: IDE: 7.5 GB partition of 60 GB drive
Root Size/partition table:

   Disk /dev/hda: 60.0 GB, 60011642880 bytes
   240 heads, 63 sectors/track, 7752 cylinders
   Units = cylinders of 15120 * 512 = 7741440 bytes

      Device Boot    Start       End    Blocks   Id  System
   /dev/hda1             1       145   1096168+  a0  IBM Thinkpad hibernation
   /dev/hda2   *       146       159    105840   83  Linux
   /dev/hda3           160      1108   7174440    7  HPFS/NTFS
   /dev/hda4          1109      7752  50228640    5  Extended
   /dev/hda5          1109      1871   5768248+  83  Linux
   /dev/hda6          1872      2912   7869928+  83  Linux
   /dev/hda7          2913      5246  17645008+  83  Linux
   /dev/hda8          5247      7580  17645008+   c  Win95 FAT32 (LBA)
   /dev/hda9          7581      7752   1300288+  82  Linux swap

   Configured d-i to leave /dev/hda2 intact and mount on /boot, create
   an ext3 file system on /dev/hda6 and mount on /, and to create swap
   on /dev/hda9.  All other partitions were left intact and not
   mounted.  (Of course, these were the /dev/ide0/... names...)

Output of lspci:

   00:00.0 Host bridge: Intel Corp. 82830 830 Chipset Host Bridge (rev 02)
   00:01.0 PCI bridge: Intel Corp. 82830 830 Chipset AGP Bridge (rev 02)
   00:1d.0 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 01)
   00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 41)
   00:1f.0 ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 01)
   00:1f.1 IDE interface: Intel Corp. 82801CAM IDE U100 (rev 01)
   00:1f.3 SMBus: Intel Corp. 82801CA/CAM SMBus Controller (rev 01)
   01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M6 LY
   02:03.0 Multimedia audio controller: ESS Technology ES1988 Allegro-1 (rev 12)
   02:04.0 Communication controller: Lucent Microelectronics LT WinModem (rev 02)
   02:05.0 CardBus bridge: Texas Instruments PCI1420
   02:05.1 CardBus bridge: Texas Instruments PCI1420
   02:08.0 Ethernet controller: Intel Corp. 82801CAM (ICH3) PRO/100 VM (KM) Ethernet Controller (rev 41)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [ ]
Config network:         [ ]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Note: uname -a run from shell in debian-installer; lspci and fdisk -l
run from Fedora Core 1 currently installed on the laptop.

After creating file systems, the main screen gave the error (retyped
from screen, hopefully without typos):

		     [!!] Install the base system
			   Debootstrap Error
    Invalid Release file, no entry for main/binary-i386/Packages.


After continuing:

		     [!!] Install the base system
		  Failed to install the base system
        The base system installation into /target/ failed.
	Please check /target/var/log/debootstrap.log and
	/target/var/log/debootstrap.err.log for details.


Hit Alt-F2, ENTER to get shell

Both above mentioned files exist and are zero length.  I had no
problems manually creating files in that directory; there is plenty of
disk space as the mounts and file system creation succeeded.

This is my first attempt at installing Debian for over three years, so
I don't know what to expect, but I do realize that I'm grabbing a test
image with Debian Installer hopefully days before beta 2 is released,
and that the images I've grabbed are not known to be good.

/cdrom/dists/sarge/Release contains an entry for
main/binary-i386/Packages whose size and checksum match the actual
main/binary-i386/Packages file on the DVD.  main/binary-i386/Release
contains the following contents:

Archive: testing
Component: main
Origin: Debian
Label: Debian
Architecture: i386

Hit Alt-F3; last line shows successful mounting of /boot

Hit Alt-F4; last line shows starting console on /dev/vc/2, line before
that is WARNING **: Unable to set title for debootstrap-udeb.  Before
that are several DEBUG lines.  Most indicate menu item selected or
configuring something with status 0.  Exceptions:

DEBUG: configure base-installer, status: 2
DEBUG: configure-debootstrap-udeb, status: 2

I hope I've provided all required information.  I'll try again after
Beta 2 of debian-installer is released, or I'll install woody and

Reply to: