[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Introduction to list

On Nov 19, 2003, at 11:47 AM, Gaudenz Steinlin wrote:

Am Mit, den 19.11.2003 schrieb Barry C.Hawkins um 16:28:
Hello. My name is Barry Hawkins. I am interested in getting involved
with the efforts for the new Debian installer.  I have no C experience
yet, and my shell skills are nascent.  I would be willing to help out
in the documentation area or wherever I might be of help. According to
the page on the Debian Installer
<http://www.debian.org/devel/debian-installer/>, I should introduce
myself to the list and then get a CVS checkout of Debian-Installer.  I
will get the CVS checkout and go through the TODO; are there any
additional steps to getting involved?
	As far as hardware, I have a 17" PowerBook G4.  I have pared down my
Panther installation to 35GB, so I have room to play with for installs. I ran the installer from the sarge-powerpc-netinst.iso last night, and things went fairly well, as long as I chose sarge for the distribution.
  Choosing sid led to the following:
Were you able to boot the CD simply by pressing "C" on boot or did you
enter open-firmware for booting. We had some reports that the CD is not
bootable on very new apple hardware.

Debootstrap Error
Failed getting Release file file:///cdrom/dists/sid/Release

Installing base system into /target/ failed.  Check
/target/var/log/debootstrap.log and /target/var/log/debootstrap.err.log
for the details.
Please file a bug about that. In my opinion the distribution choice
should not be offered for netinst cd's as they only contain sarge and
you can not install sid from them. Probably it would be possible to
install sid from the network with this CD, but then debootstrap should
fetch all the files from the net and not from then CD. But if you wanted
to do that, you would have fetched the businesscard CD in the first
place anyway.

	Both log files were empty when I open them in nano.  Restarting and
choosing sarge worked fine.
In my opinion this error message is a bit missleading too, because in
most of the cases debootstrap fails these files are in fact empty.
Debootstrap should be more verbose in the early stages, when
downloading/retrieving debs and package files.


I am completing the bug report now. To answer your question, yes, I had to use the OpenFirmware boot using the following directive:

bood cd:,install\powermac\yaboot

I tried to boot holding down the C key three times to no avail, then resorted to the OpenFirmware boot.

Barry C. Hawkins
All Things Computed
site: www.allthingscomputed.com
weblog: www.yepthatsme.com

Reply to: