[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

install report: floppy boot for cdrom install (vmware)

Debian-installer-version: 3 hand-built floppy images with packages I am
                          committing now, plus 2 day-old netinst CD
Machine: vmware
Method: Simulating a machine that cannot boot from CD, I left the CD
        drive disconnected at boot, and booted from the rootfloppy, then
	inserted the root floppy, then the cd_drivers floppy, then enabled
	the CD drive.
Processor: vmware
Memory: 95 mb
Root Device: 300 mb virtual scsi
Root Size/partition table: 300 mb
Output of lspci:

Base System Installation Checklist:

Initial boot worked:    [O]
Load CD Drivers:	[O]
Detect CD:              [O]
Configure network HW:   [O]
Config network:         [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


The syslinux help screens booting from the CD give wildly innaccurate
memory requirements from boot-floppies, as well as boot-floppy-specific
command line options, and do not document eg, DEBCONF_PRIORITY. FWIW, free
said I had 91 mb in use (no swap) when I was in the middle of running
debootstrap toward the end of this install. Yikes.

Everything was slick at high priority through loading the cd drivers and
detecting the cd.

Since I did not load the net_drivers floppy, it was unable to configure
network hardware. The only reason it asks about this at all is because the
root floppy includes very common network drivers. Unfortunatly, this breaks
out of high priority mode when that step fails. I manually selected 'load
modules from cdrom' to continue.

(One weird thing -- the cdrom-detect menu entry is the third thing on the
menu, above items with a lower priority. It doesn't hurt anything, but it
does look weird. I tried fixing some of the dependencies around it and
hw-detect, but this did not help.)

After loading d-i from cd, it autoselected netcfg and bailed out again
since it still didn't know my network HW. Again there's no reason this
should be asked for a cd install, probably. This points to a bug in netcfg;
it should depend on something provided by ethdetect, so it cannot be
selected without detecting network hardware first. (Bug filed.)

At this point I manually selected detect hardware, and it found my network
card using modules loaded from cd. Then I partitioned the hard drive, and
the default menu item jumped back up to netcfg-dhcp. Argh! I went ahead and
got a lease, chose a mirror, then download installer components failed (no
chance of it succeeding, my physical machine is offline).

Since the default every time the menu was displayed was going to be 
"download installer" every time now, I picked "finish installation and
reboot", and let main-menu run the formatter, base-installer, etc, to
satisfy its deps. Worked fine for the rest of the install.

Maybe this could be improved by making the *load-* udebs all provide
something like loaded-installer, and use the change Matt put in to
main-menu that should make it skip over alternatives. I'll look into it..

see shy jo

Attachment: signature.asc
Description: Digital signature

Reply to: