[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Successful (well, nearly..) installation report (vmware)

Debian-installer-version: sarge-i386-netinst.iso from 4 Nov
Method: cdrom install on vmware

Machine: vmware
Processor: PIII 800MHz
Memory: 196Mb in VmWare
Root Device: pseudo-scsi, 1073 mb
Root Size/partition table:  800 mb ext3 partition, another 273Mb partition swap

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
base-config:		[O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


hw-detect did not properly detect the PCNet32 virtual network card.

I had to switch to console 2 and "modprobe pcnet32".

The error message says "Go back to "Detect network hardware and load
corresponding modules" (in french)...but th emain menu showed after
this does not have this option..:-). The only shown option is "Detect
all hardware".

This conforts my suggestion for avoiding reference to installation steps
names in d-i debconf templates. This will for sure lead to several

The screen refresh problem when switching consoles is still there. Is
someone working on it?

About network config : no option is shown for manual (no DHCP) network
configuration. And, yes, I used low debconf priority (which is the
default, as far as I have seen).

The "DHCP name" question is never asked, even with low priority for

Choose mirror:

The country names are now translated...but still sorted according to
original version sort order. Thus "République Tchèque" is before
"Allemagne" and after "Costa Rica"..:-). I thought Denis had made
modifications to cdebconf for sorting the translated items.

Disk partitioning:

No more choice between autopartitioning of manual-->go to manual and
good ol' cfdisk (untranslated...but I've seen Alastair's efforts for
correcting this). Maybe this was because both the virtual disks I use were already partitioned.

Base system install:

Debootstrap error. /target/var/log/debootstrap.log contains:
ln: /target/usr/bin/awk: File exists

Install kernel:

Says that two required steps haven't been executed:
-automatic partioning..:-)
-"debian installer utility dfor creatin fstab fil"

...but installs kernel anyway...

Install boot loader:

Only LILO was proposed. No GRUB.

2nd stage install after reboot:

Nothing special except:

-"continents" not consistent in French : "real" continents use capitals while "Océan" is all lowercase....this makes the tzconfig templates look strange.

-Shadow package templates not translated. I am *very* angry against the package maintainer who waited really for a too long time before updating his package. Thus, the root and normal user prompting is made in english

Hopefully, the updated package will hit testing soon.

-cd-rom not detected-->thus I had to stop on minimal install.


Reply to: