[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

installation report



Hi all.  Great work with debian-installer; it has progressed quite a bit
since I last tested it a month or so ago.

I've downloaded the October 5 netinst image from
http://gluck.debian.org/cdimage/testing/netinst/i386/ and run through it
a few times on my laptop.  For the most part things went smoothly.

The first problems relate mostly to mobile systems.  I had to do a bit
of work to get my PCMCIA network card to work.  It was all possible
without having to drop to the console on tty2, but it certainly wasn't
right.  Early in the installation, d-i reported that no network
interfaces were available.  To fix that, I chose the main menu option to
start PCMCIA services.  Following that, my interface was still not
present.  I selected the main-menu interface to probe network hardware
and load the appropriate modules.  Here, I selected the option for
"other" module, which prompted me for a full path to a network card
driver.  I left this option blank, which resulted in errors (because
modprobe isn't happy if you give it "" as a module to load!)  This,
however, worked, and my network interface came to life.  From here, I
was able to successfully configure it with DHCP.

However, the wireless-tools package was not installed as part of the
installation system.  This made it impossible to set the wireless
network name (SSID), meaning that my machine would connect to either my
neighbors network or my network, depending on some kind of RF conditions
or something.  Ideally, d-i would show a list of available wireless
networks, allowing the user to choose one.  Assuming that's not likely
to happen, the user still needs to be able to manually set a network
name.

An additional problem came when creating filesystems.  ext3 could be
created with no problems, but reiserfs wanted input on tty3.  I suspect
that this is because I was trying to install on a partition where there
had previously been an ext3 filesystem, and it wanted to make sure it
was OK to blow this filesystem away.  I don't know if there's an option
that one can pass to the reiserfs creation tool to prevent it from
asking this, or if source code changes will need to be made, but
something should be done here.  It certainly didn't fail in a clean way,
and basically resulted in a hung installation.

The final problem was that for some reason d-i asked if I was sure that
I wanted to automatically partition my hard disk after I had already
manually partitioned it, configured filesystems, and installed the base
system.  It did this just before the step where it asked me to choose a
kernel to install.  Naturally I told it I didn't want to automatically
partition the hard drive, and it seemed satisfied...

Hmm.... One more problem.  The installation system seems to have
completed, but it didn't install the PCMCIA modules.  So even though I
used the PCMCIA NIC to successfully access the network during the
installation process and the pcmcia-cs package was installed, I was not
able to do so one the machine rebooted.  '/etc/init.d/pcmcia start'
resulted in "modules directory /lib/modules/2.4.22-1-386/pcmcia not
found"

I figure some of this problems are known already, but if not, please
feel free to contact me if you need more details or want me to test a
potential fix.

noah



Attachment: pgpY75LuvC2SM.pgp
Description: PGP signature


Reply to: