[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

d-i, kernel-img.conf and {link,image}_in_boot

link_in_boot is just the new name for image_in_boot.
rootskel/debian/templates-arch defined link_in_boot, which is used in
tools/base-installer/debian/kernel-installer.postinst when creating
/etc/kernel-img.conf.  However, that script writes

image_in_boot = yes
link_in_boot = $link_in_boot

which confuses elilo, at least.  elilo looks for either of those values
set to 'yes' to decide what to do, and for ia64 link_in_boot = no.

So should we set them both to $link_in_boot, or should we just delete
the old image_in_boot entry?  If no-one says different, I'll delete the
old image_in_boot entry.


Reply to: