[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#209286: partitioner: cfdisk is displayed black on black



* Petter Reinholdtsen <pere@hungry.com> [2003-09-09 11:33]:
| [Sebastian Ley]
| > After finally fixing the dependencies for cfdisk it still does not
| > work. Firing up partitioner shows cfdisk black on black. Since I am
| > able to quit with "q" I suppose it really is cfdisk I am not seeing...
| > 
| > This is most probably not a partitioner bug, but I thought this might
| > be a good starting point.
| 
| I believe this is related to file descriptor redirection.
| 
| The menu option to run a shell seem to behave in a similar way, being
| executed and accepting input but not displaying any output.
| 
| When looking in /proc/#/fd/, I notice that fd 0, 1 and 2 are all
| pointing to /dev/console, while fd 4 and 7 are pointing to a pipe, fd
| 4 and 5 are pointing to /dev/pty/s0, fd 6 is pointing to /dev/tty and
| fd 8 is pointing to the disk being partitioned.
| 
| Changing /usr/share/partitioner/common.sh to redirect stdout to
| /dev/tty solved the problem.  I replaced "cfdisk $DISK" with "cfdisk
| $DISK > /dev/tty".  I'm not sure why this worked.

can someone please test this? I'm currently to bussy in RL to test this.
Maybe we must include these changes in the other scripts also?

Thanks
Thorsten

-- 
Thorsten Sauter
<tsauter@gmx.net>

				(Is there life after /sbin/halt -p?)

Attachment: pgprSoOege5UM.pgp
Description: PGP signature


Reply to: